Forums

Home » Liferay Portal » English » 2. Using Liferay » General

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Sam Collett
Liferay redirecting when trying to log in
September 6, 2011 8:12 AM
Answer

Sam Collett

Rank: Junior Member

Posts: 58

Join Date: November 13, 2008

Recent Posts

Hi,

When I try to log into Liferay (6.0 GA4), by the Sign In link or the portlet, it keeps redirecting me back to the home page. Why is this? Clearing cache, closing browser etc doesn't help. Attached screen cap from Google Chrome. I am not logged in already.

Thanks,
Sam
Attachment

Attachments: liferay-redirect.PNG (52.0k)
Sam Collett
RE: Liferay redirecting when trying to log in
September 6, 2011 8:24 AM
Answer

Sam Collett

Rank: Junior Member

Posts: 58

Join Date: November 13, 2008

Recent Posts

I get a 'too many redirects' on other pages as well.
Attachment

Attachments: liferay-redirect2.PNG (83.1k)
Mika Koivisto
RE: Liferay redirecting when trying to log in
September 12, 2011 5:19 PM
Answer

Mika Koivisto

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1499

Join Date: August 7, 2006

Recent Posts

Try clearing your cookies.
Sam Collett
RE: Liferay redirecting when trying to log in
September 13, 2011 1:51 AM
Answer

Sam Collett

Rank: Junior Member

Posts: 58

Join Date: November 13, 2008

Recent Posts

Deleting cookies doesn't help either. However, I've found the cause.

When I create an organisation or community and give it a virtual host address, it prevents anything other than the home page for loading on all sites, even those running under portal instances. Although it doesn't happen right away, only after I have logged onto one or two of the instances then log out. As a result, I can only use virtual hosts on portal instances, since it impacts all users and all PC's I tried it on (even those that have never been used to visit the site).

It is running on Tomcat 7 on Windows Server 2008, but it also happened when using Tomcat 6.
Patrizio Munzi
RE: Liferay redirecting when trying to log in
November 7, 2011 2:04 AM
Answer

Patrizio Munzi

Rank: New Member

Posts: 12

Join Date: November 3, 2011

Recent Posts

We've got the same problem.
Did you find a solution?

Thanks