Combination View Flat View Tree View
Threads [ Previous | Next ]
Ben Brown
Active Directory Setup - can't log in.
September 16, 2011 3:04 AM
Answer

Ben Brown

Rank: Junior Member

Posts: 74

Join Date: July 7, 2010

Recent Posts

Hi,

I'm using Liferay EE 6.0 sp2/Tomcat on Ubuntu Server 11.04/64bit.

I have Active Directory users importing correctly into Liferay, but I am unable to log in using the AD user details...

I also use the Liberal Screen Name Validator because our usernames (mailNickname) have underscores in - e.g. mine is ben_b

In the database, the user_ table is showing the correct fields being populated too.

I have the set up as below:



When I try and log in as a user I can see in the database I get the following:

 109:48:08,829 DEBUG [LDAPAuth:362] Authenticator is enabled
 209:48:08,830 DEBUG [PortalLDAPUtil:44] -- listing properties --
 3java.naming.factory.initial=com.sun.jndi.ldap.LdapCtxFactory
 4java.naming.provider.url=ldap://mhdc-dcser1:389
 5com.sun.jndi.ldap.connect.pool.timeout=10000
 6java.naming.security.principal=xxxxxxxx
 7com.sun.jndi.ldap.connect.pool=true
 8com.sun.jndi.ldap.connect.pool.maxsize=50
 9java.naming.security.credentials=xxxxxxxxx
10java.naming.referral=follow
11
1209:48:08,831 DEBUG [LDAPSettingsUtil:51] Search filter before transformation (&(objectCategory=person)(mailNickname=@user_id@))
1309:48:08,831 DEBUG [LDAPSettingsUtil:65] Search filter after transformation (&(objectCategory=person)(mailNickname=0))
1409:48:08,832 DEBUG [LDAPSettingsUtil:44] -- listing properties --
15password=userPassword
16lastName=sn
17screenName=sAMAccountName
18firstName=givenName
19jobTitle=title
20emailAddress=mail
21group=memberOf
22fullName=cn
23
2409:48:08,833 DEBUG [LDAPAuth:320] Search filter did not return any results


Thanks for any help or advice, I assume I must have a filter set wrongly or something similar.

Ben
Sreeraj AV
RE: Active Directory Setup - can't log in.
September 17, 2011 9:03 PM
Answer

Sreeraj AV

Rank: Regular Member

Posts: 233

Join Date: April 26, 2010

Recent Posts

just try sAMAccountName=@screen_name@ instead of mailNickname=@user_id@
Ben Brown
RE: Active Directory Setup - can't log in.
September 19, 2011 12:41 AM
Answer

Ben Brown

Rank: Junior Member

Posts: 74

Join Date: July 7, 2010

Recent Posts

That worked!

Thanks very much for your help!

Ben
Hannes C.
RE: Active Directory Setup - can't log in.
September 10, 2012 4:32 AM
Answer

Hannes C.

Rank: New Member

Posts: 1

Join Date: September 4, 2012

Recent Posts

Sreeraj AV:
just try sAMAccountName=@screen_name@ instead of mailNickname=@user_id@


Do you know how to handle the problem with ,, Liferay 6.1 [tomcat bundle]" ? i ve got the same problem just with liferay 6.1 and cant find the ext.properties file but already read that this file doesn't exist for liferay 6.1 hmmmm... really thx for help cuz first time working with liferay and i cant find a solution for this problem emoticon
Attachment

Attachments: anmelden_fehlgeschlagen.png (22.3k)
Linus Sphinx
RE: Active Directory Setup - can't log in.
September 10, 2012 2:33 PM
Answer

Linus Sphinx

Rank: Junior Member

Posts: 84

Join Date: August 12, 2010

Recent Posts

Won't find it in any version unless you create it and fill it with the variables and values you want to over-ride.