Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Akash Mohan Patil
cache problem in theme deployment
December 4, 2011 11:01 PM
Answer

Akash Mohan Patil

Rank: Junior Member

Posts: 70

Join Date: December 12, 2010

Recent Posts

Hi.,

I developed a custom theme. but when i deploy it and refresh my page, it's not getting effect, i need to clear the cache to see the effects.
for that reason to cross verify, i downloaded sevencogs-theme sources, n deployed it. and again i changes some css from custom.css of sevencogs-theme, and again i deployed it. again i faced same problem. Without clearing the cache i am not able to see the new effect.

Even both properties are also set.

theme.css.fast.load=false
theme.images.fast.load=false

So please anyone give suggestion to solve this problem

Thanks,
Akash Patil
Thomas Berg
RE: cache problem in theme deployment
December 5, 2011 1:13 AM
Answer

Thomas Berg

Rank: Regular Member

Posts: 125

Join Date: September 7, 2009

Recent Posts

Be sure to use portal-deloper.properties in your development environment:

 1theme.css.fast.load=false
 2theme.images.fast.load=false
 3javascript.fast.load=true
 4javascript.log.enabled=true
 5layout.template.cache.enabled=false
 6browser.launcher.url=
 7combo.check.timestamp=true
 8freemarker.engine.cache.storage=soft:1
 9freemarker.engine.modification.check.interval=0
10openoffice.cache.enabled=false
11velocity.engine.resource.manager.cache.enabled=false
12com.liferay.portal.servlet.filters.cache.CacheFilter=false
13com.liferay.portal.servlet.filters.themepreview.ThemePreviewFilter=true

The file is included with the distribution. Check this page for more information about this.

You can also disable fast loading of css and images by adding url-parameters:

1http://myportal/?css_fast_load=0&images_fast_load=0

The above information is available at this wiki page

HTH Thomas