Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Liferay 6.1 startup problem Ubuntu karthik N December 13, 2011 10:01 PM
RE: Liferay 6.1 startup problem Ubuntu Juan Gonzalez December 13, 2011 11:51 PM
RE: Liferay 6.1 startup problem Ubuntu karthik N December 14, 2011 3:39 AM
RE: Liferay 6.1 startup problem Ubuntu Milen Dyankov December 14, 2011 4:05 AM
RE: Liferay 6.1 startup problem Ubuntu karthik N December 14, 2011 9:49 PM
RE: Liferay 6.1 startup problem Ubuntu Nagendra Kumar Busam December 14, 2011 10:26 PM
RE: Liferay 6.1 startup problem Ubuntu karthik N December 14, 2011 11:12 PM
RE: Liferay 6.1 startup problem Ubuntu karthik N December 14, 2011 11:15 PM
RE: Liferay 6.1 startup problem Ubuntu Ravi Kumar Gupta December 15, 2011 1:44 AM
RE: Liferay 6.1 startup problem Ubuntu karthik N December 15, 2011 1:57 AM
RE: Liferay 6.1 startup problem Ubuntu Geeta Raghu Vamsi Kotipalli December 15, 2011 2:47 AM
RE: Liferay 6.1 startup problem Ubuntu karthik N December 15, 2011 8:09 PM
RE: Liferay 6.1 startup problem Ubuntu long zhao July 4, 2012 8:28 AM
RE: Liferay 6.1 startup problem Ubuntu David H Nebinger July 4, 2012 12:34 PM
RE: Liferay 6.1 startup problem Ubuntu long zhao July 4, 2012 4:19 PM
RE: Liferay 6.1 startup problem Ubuntu Granger Guillaume July 31, 2013 6:02 AM
RE: Liferay 6.1 startup problem Ubuntu Geeta Raghu Vamsi Kotipalli December 14, 2011 10:40 PM
RE: Liferay 6.1 startup problem Ubuntu karthik N December 14, 2011 11:14 PM
RE: Liferay 6.1 startup problem Ubuntu Walter Christian Guardia Casas December 14, 2011 1:09 AM
RE: Liferay 6.1 startup problem Ubuntu karthik N December 14, 2011 3:17 AM
RE: Liferay 6.1 startup problem Ubuntu Raja Nagendra Kumar December 14, 2011 10:43 PM
karthik N
Liferay 6.1 startup problem Ubuntu
December 13, 2011 10:01 PM
Answer

karthik N

Rank: Regular Member

Posts: 106

Join Date: June 30, 2011

Recent Posts

Hi all,
Im new person to liferay , Im trying to install liferay 6.1 (beta version) in Ubuntu 11.10 server.
But i will not be able to start liferay in ubuntu machine when i run startup.sh file, im getting following things in console

Using CATALINA_BASE: /usr/liferay/liferay-portal-6.0.5/tomcat-6.0.26
Using CATALINA_HOME: /usr/liferay/liferay-portal-6.0.5/tomcat-6.0.26
Using CATALINA_TMPDIR: /usr/liferay/liferay-portal-6.0.5/tomcat-6.0.26/temp
Using JRE_HOME: /usr
Using CLASSPATH: /usr/liferay/liferay-portal-6.0.5/tomcat-6.0.26/bin/bootstrap.jar

, but im not able to enter into liferay using http://localhost:8080/web/guest/home?


Any help guys?

Thanks & Regards,
Karthik
Juan Gonzalez
RE: Liferay 6.1 startup problem Ubuntu
December 13, 2011 11:51 PM
Answer

Juan Gonzalez

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1970

Join Date: October 28, 2008

Recent Posts

karthik N:
Hi all,
Im new person to liferay , Im trying to install liferay 6.1 (beta version) in Ubuntu 11.10 server.
But i will not be able to start liferay in ubuntu machine when i run startup.sh file, im getting following things in console

Using CATALINA_BASE: /usr/liferay/liferay-portal-6.0.5/tomcat-6.0.26
Using CATALINA_HOME: /usr/liferay/liferay-portal-6.0.5/tomcat-6.0.26
Using CATALINA_TMPDIR: /usr/liferay/liferay-portal-6.0.5/tomcat-6.0.26/temp
Using JRE_HOME: /usr
Using CLASSPATH: /usr/liferay/liferay-portal-6.0.5/tomcat-6.0.26/bin/bootstrap.jar

, but im not able to enter into liferay using http://localhost:8080/web/guest/home?


Any help guys?

Thanks & Regards,
Karthik


Please post the logs (/usr/liferay/liferay-portal-6.0.5/tomcat-6.0.26/catalina.out)

Have you got permissions of read/write over that folder?
Walter Christian Guardia Casas
RE: Liferay 6.1 startup problem Ubuntu
December 14, 2011 1:09 AM
Answer

Walter Christian Guardia Casas

Rank: Regular Member

Posts: 126

Join Date: May 5, 2010

Recent Posts

Hi,

If you are using Liferay 6.1 B4 so the liferay bundle use tomcat 7 and JDK 1.6 u20 to run portal, that logs are Liferay 6.0.5, are you sure you run the correct shell?

Regards,
karthik N
RE: Liferay 6.1 startup problem Ubuntu
December 14, 2011 3:17 AM
Answer

karthik N

Rank: Regular Member

Posts: 106

Join Date: June 30, 2011

Recent Posts

Hi,

Using CATALINA_BASE: /home/bpauser/Desktop/liferay-portal-6.1.0-ce-b4/tomcat-7.0.22
Using CATALINA_HOME: /home/bpauser/Desktop/liferay-portal-6.1.0-ce-b4/tomcat-7.0.22
Using CATALINA_TMPDIR: /home/bpauser/Desktop/liferay-portal-6.1.0-ce-b4/tomcat-7.0.22/temp
Using JRE_HOME: /home/bpauser/Desktop/liferay-portal-6.1.0-ce-b4/tomcat-7.0.22/jre1.6.0_20/win
Using CLASSPATH: /home/bpauser/Desktop/liferay-portal-6.1.0-ce-b4/tomcat-7.0.22/bin/bootstrap.jar:/home/bpauser/Desktop/liferay-portal-6.1.0-ce-b4/tomcat-7.0.22/bin/tomcat-juli.jar

Actually im getting this information when start the startup.sh file?

Any clue?

Thanks.

Regards,
Karthik.
karthik N
RE: Liferay 6.1 startup problem Ubuntu
December 14, 2011 3:39 AM
Answer

karthik N

Rank: Regular Member

Posts: 106

Join Date: June 30, 2011

Recent Posts

hi,
im getting this error in my catalina.out file, even i tried stop run the another application i cannot able to start liferay,

Dec 13, 2011 12:57:53 PM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/lib/jvm/java-6-openjdk/jre/lib/i386/server:/usr/lib/jvm/java-6-openjdk/jre/lib/i386:/usr/lib/jvm/java-6-openjdk/jre/../lib/i386:/usr/java/packages/lib/i386:/usr/lib/jni:/lib:/usr/lib
Dec 13, 2011 12:57:53 PM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["http-bio-8080"]
Dec 13, 2011 12:57:53 PM org.apache.coyote.AbstractProtocol init
SEVERE: Failed to initialize end point associated with ProtocolHandler ["http-bio-8080"]
java.net.BindException: Address already in use <null>:8080
at org.apache.tomcat.util.net.JIoEndpoint.bind(JIoEndpoint.java:386)
at org.apache.tomcat.util.net.AbstractEndpoint.init(AbstractEndpoint.java:498)
at org.apache.coyote.AbstractProtocol.init(AbstractProtocol.java:369)
at org.apache.coyote.http11.AbstractHttp11JsseProtocol.init(AbstractHttp11JsseProtocol.java:119)
at org.apache.catalina.connector.Connector.initInternal(Connector.java:909)
Milen Dyankov
RE: Liferay 6.1 startup problem Ubuntu
December 14, 2011 4:05 AM
Answer

Milen Dyankov

Rank: Regular Member

Posts: 173

Join Date: September 23, 2009

Recent Posts

In your log file I can see 2 things:

1) The port 8080 is used by another application. You may think you have stopped it but it still uses the port. Try to run lsof -i :8080 to see which process uses the port and then stop/kill it.

2) you are using OpenJDK. Not sure if this is a problem with Liferay but I would suggest to switch to Sun's java.
karthik N
RE: Liferay 6.1 startup problem Ubuntu
December 14, 2011 9:49 PM
Answer

karthik N

Rank: Regular Member

Posts: 106

Join Date: June 30, 2011

Recent Posts

Hi Milen,
Thanks for your reply... I have installed sun java, bt still problem persist,
Any idea? when i type java -version in terminal, It shows open JDK only,
How can i make sunjava as default?

Regards,
Karthik
Nagendra Kumar Busam
RE: Liferay 6.1 startup problem Ubuntu
December 14, 2011 10:26 PM
Answer

Nagendra Kumar Busam

Rank: Liferay Master

Posts: 637

Join Date: July 7, 2009

Recent Posts

Did you try checking the classpath/path environment variables for java
Geeta Raghu Vamsi Kotipalli
RE: Liferay 6.1 startup problem Ubuntu
December 14, 2011 10:40 PM
Answer

Geeta Raghu Vamsi Kotipalli

Rank: Junior Member

Posts: 58

Join Date: November 9, 2011

Recent Posts

karthik N:
hi,
im getting this error in my catalina.out file, even i tried stop run the another application i cannot able to start liferay,

Dec 13, 2011 12:57:53 PM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/lib/jvm/java-6-openjdk/jre/lib/i386/server:/usr/lib/jvm/java-6-openjdk/jre/lib/i386:/usr/lib/jvm/java-6-openjdk/jre/../lib/i386:/usr/java/packages/lib/i386:/usr/lib/jni:/lib:/usr/lib
Dec 13, 2011 12:57:53 PM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["http-bio-8080"]
Dec 13, 2011 12:57:53 PM org.apache.coyote.AbstractProtocol init
SEVERE: Failed to initialize end point associated with ProtocolHandler ["http-bio-8080"]
java.net.BindException: Address already in use <null>:8080
at org.apache.tomcat.util.net.JIoEndpoint.bind(JIoEndpoint.java:386)
at org.apache.tomcat.util.net.AbstractEndpoint.init(AbstractEndpoint.java:498)
at org.apache.coyote.AbstractProtocol.init(AbstractProtocol.java:369)
at org.apache.coyote.http11.AbstractHttp11JsseProtocol.init(AbstractHttp11JsseProtocol.java:119)
at org.apache.catalina.connector.Connector.initInternal(Connector.java:909)



Hi Karthik

Apply this Command and check the process of the 8080 port

ps -aux|grep 8080 (grep can also be done with java,tomcat as well)

After that kill the process apart from the color related process (because color process is a default process)

then try to start the Tomcat

If u still face the same problem try to make the whole tomcat folder conversion with dos2unix and then try again (because some of the files which require the tomcat execution might be in the Windows format which a unix /linux platform cant recognize the files)

Thanks

K.G.R Vamsi
Raja Nagendra Kumar
RE: Liferay 6.1 startup problem Ubuntu
December 14, 2011 10:43 PM
Answer

Raja Nagendra Kumar

Rank: Expert

Posts: 484

Join Date: March 1, 2006

Recent Posts

Check your 8080 port.. is is already in use by some other application..

Try changing the LR tomcat port to some thing else in services.xml file.


Regards
Raja Nagendra Kumar,
C.T.O
www.tejasoft.com
karthik N
RE: Liferay 6.1 startup problem Ubuntu
December 14, 2011 11:12 PM
Answer

karthik N

Rank: Regular Member

Posts: 106

Join Date: June 30, 2011

Recent Posts

Hi,

PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/home/bpauser/Desktop/liferay-portal-6.1.0-ce-b4/tomcat-7.0.22/bin"
CATALINA_HOME="/home/bpauser/Desktop/liferay-portal-6.1.0-ce-b4/tomcat-7.0.22"
TOMCAT_HOME="/home/bpauser/Desktop/liferay-portal-6.1.0-ce-b4/tomcat-7.0.22"
JRE_HOME="/home/bpauser/Desktop/liferay-portal-6.1.0-ce-b4/tomcat-7.0.22/jre1.6.0_20/win"

this s my environment variable setup in /etc/environment...

IS der anything wrong with this?

Thanks and Regards,
Karthik
karthik N
RE: Liferay 6.1 startup problem Ubuntu
December 14, 2011 11:14 PM
Answer

karthik N

Rank: Regular Member

Posts: 106

Join Date: June 30, 2011

Recent Posts

Hi geeta,
I have checked with my port there is no problem with that, how can i change the tomcat folder dos2unix environment?


Thanks and Regards,
Karthik
karthik N
RE: Liferay 6.1 startup problem Ubuntu
December 14, 2011 11:15 PM
Answer

karthik N

Rank: Regular Member

Posts: 106

Join Date: June 30, 2011

Recent Posts

Hi all,
Im getting this information in my catalina.out file

eval: 1: /home/bpauser/Desktop/liferay-portal-6.1.0-ce-b4/tomcat-7.0.22/jre1.6.0_20/win/bin/java: not found
eval: 1: /home/bpauser/Desktop/liferay-portal-6.1.0-ce-b4/tomcat-7.0.22/jre1.6.0_20/win/bin/java: not found

Any clue guys?



Thanks and Regards,
Karthik
Ravi Kumar Gupta
RE: Liferay 6.1 startup problem Ubuntu
December 15, 2011 1:44 AM
Answer

Ravi Kumar Gupta

Rank: Liferay Legend

Posts: 1182

Join Date: June 23, 2009

Recent Posts

Hi.. Please check this directory /home/bpauser/Desktop/liferay-portal-6.1.0-ce-b4/tomcat-7.0.22/jre1.6.0_20/win

do you see bin, lib directories there.. if not then you have not set JRE_HOME correctly.. from the first look it seems it is /home/bpauser/Desktop/liferay-portal-6.1.0-ce-b4/tomcat-7.0.22/jre1.6.0_20 not with /win at the last..

Please confirm
karthik N
RE: Liferay 6.1 startup problem Ubuntu
December 15, 2011 1:57 AM
Answer

karthik N

Rank: Regular Member

Posts: 106

Join Date: June 30, 2011

Recent Posts

Hi all,
Thanks for all of your reply, solved that problem,
For operating system other then windows we need to Configure environmental variable as JRE_HOME="jre path in our java installation"

Regards,
Karthik
Geeta Raghu Vamsi Kotipalli
RE: Liferay 6.1 startup problem Ubuntu
December 15, 2011 2:47 AM
Answer

Geeta Raghu Vamsi Kotipalli

Rank: Junior Member

Posts: 58

Join Date: November 9, 2011

Recent Posts

karthik N:
Hi all,
Thanks for all of your reply, solved that problem,
For operating system other then windows we need to Configure environmental variable as JRE_HOME="jre path in our java installation"

Regards,
Karthik



Oh cool Man seems Like you are some what a new bee for the Setup of Liferay related to Environmental Changes emoticon
karthik N
RE: Liferay 6.1 startup problem Ubuntu
December 15, 2011 8:09 PM
Answer

karthik N

Rank: Regular Member

Posts: 106

Join Date: June 30, 2011

Recent Posts

Hi Geeta,
Thanks, Yes Im newbie to the Ubuntu
long zhao
RE: Liferay 6.1 startup problem Ubuntu
July 4, 2012 8:28 AM
Answer

long zhao

Rank: Junior Member

Posts: 39

Join Date: August 29, 2011

Recent Posts

Geeta Raghu Vamsi Kotipalli:
karthik N:
Hi all,
Thanks for all of your reply, solved that problem,
For operating system other then windows we need to Configure environmental variable as JRE_HOME="jre path in our java installation"

Regards,
Karthik



Oh cool Man seems Like you are some what a new bee for the Setup of Liferay related to Environmental Changes emoticon



I have the same problem.
What is your mean of "jre path in our java installation"?
I am using the Sun Java installed by myself at /usr/java/jdk1.6.0_27
David H Nebinger
RE: Liferay 6.1 startup problem Ubuntu
July 4, 2012 12:34 PM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 7157

Join Date: September 1, 2006

Recent Posts

so your jre path would be something like /usr/java/jdk1.6.0_27/jre...
long zhao
RE: Liferay 6.1 startup problem Ubuntu
July 4, 2012 4:19 PM
Answer

long zhao

Rank: Junior Member

Posts: 39

Join Date: August 29, 2011

Recent Posts

David H Nebinger:
so your jre path would be something like /usr/java/jdk1.6.0_27/jre...



That is just what I am using.
But I still have that bug. I am so confused about that.
Granger Guillaume
RE: Liferay 6.1 startup problem Ubuntu
July 31, 2013 6:02 AM
Answer

Granger Guillaume

Rank: New Member

Posts: 1

Join Date: May 18, 2010

Recent Posts

I have the same installation and the same problem...
Have you find why, Liferay don't start?
I have also this Stacktrace :

Exception in thread "main" java.lang.NoClassDefFoundError: Developer
Caused by: java.lang.ClassNotFoundException: Developer
at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)