Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
David Tildesley
Glassfish httpProxy setting for plugin repository access - broken
September 4, 2008 8:36 PM
Answer

David Tildesley

Rank: Junior Member

Posts: 34

Join Date: August 3, 2008

Recent Posts

Environment: Liferay 5.1.1 -glassfish2 bundle on windows XP.

Liferay app needs to go through a proxy server (no authentication required) to access the lilferay plugins repository.

I have tried putting the proxy settings in JVM options and in system-ext.properties in both the <liferay>/WEB-INF/classes and in the domain1/lib/classes with restarts of the domain server inbetween - nothing works. I watch the connections using Wireshark and I see that the proxy settings are not being used to access the liferay plugins repository.

If I configure the RSS portlet to subscribe to an external RSS feed - no problem - it works ok.

I've read all related posts, googled, and haven't found an answer to this problem.

Any help would be much appreciated.

Regards,
David.

P.S. A screenshot of the system-properties settings as shown by the Liferay Admin portlet is attached. You can see that the proxy settings have been picked up - they are just not being used for some reason.
Attachment

Attachments: liferay-system-properties.jpg (114.1k)
Christophe Knuchel
RE: Glassfish httpProxy setting for plugin repository access - broken
October 1, 2008 5:39 AM
Answer

Christophe Knuchel

Rank: New Member

Posts: 1

Join Date: September 26, 2008

Recent Posts

Hi,
I have the same problem (i'm under a proxy) with the last Liferay Portal Bundles liferay-portal-tomcat-5.5-5.1.1, I have add a properties file system.properties in \webapps\ROOT\WEB-INF\classes I'm able to see the value in the admin portlet, but when i try to connect to the liferay repository I' have the following error [jsp:124] Unable to communicate with repository http://plugins.liferay.com/official
Chris Pate
RE: Glassfish httpProxy setting for plugin repository access - broken
January 2, 2009 10:57 AM
Answer

Chris Pate

Rank: New Member

Posts: 1

Join Date: January 2, 2009

Recent Posts

Hi --

I am having the same problem with my Liferay installation ( Liferay Portal 5.1.2 (Calvin / Build 5102 / October 3, 2008) running on Tomcat. I am behind a firewall as well and it does not require username/password authorization. Further, I can see my
http.proxyHost / port settings in the admin portlet.

Have you been able to get past this issue??

Thanks,
Chris
Juan Gonzalez
RE: Glassfish httpProxy setting for plugin repository access - broken
January 5, 2009 12:49 AM
Answer

Juan Gonzalez

LIFERAY STAFF

Rank: Liferay Legend

Posts: 2381

Join Date: October 28, 2008

Recent Posts

After some weeks of investigation I finally solved the "unkown host" problem for Liferay with proxy.

After configure the system-ext.properties and portal-ext.properties with the correct parameters, you have to set the "system.properties.load" to "true" in your application server.

In glassfish v2 this can be done in the web admin console ->Configuration->System properties.

But after this now I´m stuck with the "error 407" of the proxy. Don´t kow how to solve this...
Jorge Luis Williams
RE: Glassfish httpProxy setting for plugin repository access - broken
February 24, 2009 3:28 PM
Answer

Jorge Luis Williams

Rank: New Member

Posts: 5

Join Date: February 24, 2009

Recent Posts

Has anyone found a solution to this problem with Tomcat? I'm having the exact same issue. I can also confirm that my proxy system properties are being picked up, but for some reason I keep getting...

Unable to communicate with repository http://plugins.liferay.com/official

I have noticed if I go to http://plugins.liferay.com/official directly I get a "Forbidden" error. Could it be that this is the issue and that the problem has nothing to do with our proxy settings???

Other people have reported the problem here, could it be that the two are related??
Vanita Chawla
RE: Glassfish httpProxy setting for plugin repository access - broken
June 2, 2010 6:22 AM
Answer

Vanita Chawla

Rank: New Member

Posts: 19

Join Date: March 25, 2010

Recent Posts

I am running into the same error "Unable to load repository http://plugins.liferay.com/enterprise com.liferay.portal.plugin.PluginPackageException: Unable to communicate with repository http://plugins.liferay.com/enterprise"

I am using Tomcat 6, Linux, MySQL with Liferay 5.2.x

We've configured the http proxy at various levels:
  • global linux setting in profile with http_proxy
  • Java net.properties for http proxy
  • set tomcat system settings for http proxy via setenv.sh


I can see the system properties under system administration and they seem to be set correctly. However, Liferay seems to be still ignoring the proxy settings.

We can reach external sites successfully and plugins.liferay.com with 403 forbidden status with elinks.

Does anybody else have the same issue and have you been able to resolve it?

I have also tried setting system-ext.properties with proxy settings. This does not seem to get loaded at all. Where do you specify the system-ext.properties override to be loaded at startup?

Any help is much appreciated.

Regards
Vanita
Vanita Chawla
RE: Glassfish httpProxy setting for plugin repository access - broken
June 2, 2010 12:03 PM
Answer

Vanita Chawla

Rank: New Member

Posts: 19

Join Date: March 25, 2010

Recent Posts

I figured it out.

There was a typo in the Tomcat setenv.sh for http.nonProxyHosts property. So this setting was essentially not being set.

From a Liferay resource, http.nonProxyHosts is required to avoid the error. The error is generated when the http.nonProxyHosts is null or not set (see issue below):

http://issues.liferay.com/browse/LPS-2520

When I tried to set it with the system-ext.properties, it was not in the proper location. Once I figured out the location, it works!

The location for system-ext.properties is:
{appserver}/webapps/ROOT/WEB-INF/classes

Hope this helps.

Vanita
Gowtham Mani
RE: Glassfish httpProxy setting for plugin repository access - broken
July 1, 2010 2:42 AM
Answer

Gowtham Mani

Rank: Junior Member

Posts: 56

Join Date: November 25, 2008

Recent Posts

Hi,

I've added the value for http.nonProxyHosts in the system-ext properties file and the value is being displayed in the system properties of Liferay, but still the plugin repository is not connecting with liferay's repository.

Regards,
Gowtham
Roger Thal
RE: Glassfish httpProxy setting for plugin repository access - broken
February 6, 2012 2:04 PM
Answer

Roger Thal

Rank: New Member

Posts: 16

Join Date: January 21, 2012

Recent Posts

Just a note to say that I'm using Tomcat and am able to fix the proxy problem by putting the following:
java.net.useSystemProxies=false
http.proxyHost=<your proxy host name>
http.proxyPort=<your proxy port number>
http.nonProxyHosts=localhost|127.0.0.1
into the file {tomcat}/webapps/ROOT/WEB-INF/classes/system-ext.properties, then restart Tomcat.


Vanita Chawla:
I figured it out.

There was a typo in the Tomcat setenv.sh for http.nonProxyHosts property. So this setting was essentially not being set.

From a Liferay resource, http.nonProxyHosts is required to avoid the error. The error is generated when the http.nonProxyHosts is null or not set (see issue below):

http://issues.liferay.com/browse/LPS-2520

When I tried to set it with the system-ext.properties, it was not in the proper location. Once I figured out the location, it works!

The location for system-ext.properties is:
{appserver}/webapps/ROOT/WEB-INF/classes

Hope this helps.

Vanita