Forums

Home » Liferay IDE » English

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Roger Thal
Error: Dynamic Web Module 3.0 requires Java 1.6 or newer
February 18, 2012 6:53 PM
Answer

Roger Thal

Rank: New Member

Posts: 16

Join Date: January 21, 2012

Recent Posts

I installed Liferay IDE and successfully imported two "Liferay Projects from Plugins SDK".

When trying to import the 3rd projects from the Plugins SDK, all of the sudden there's a popup with this error message

One or more constraints have not been satisfied.
One or more constraints have not been satisfied.
One or more constraints have not been satisfied.
Dynamic Web Module 3.0 requires Java 1.6 or newer.

Nothing changed in my Eclipse JEE Indigo setup, nothing changed in my Java environment. What gives ?
Gregory Amerson
RE: Error: Dynamic Web Module 3.0 requires Java 1.6 or newer
February 19, 2012 5:03 PM
Answer

Gregory Amerson

LIFERAY STAFF

Rank: Liferay Master

Posts: 911

Join Date: February 16, 2010

Recent Posts

Check to see that your original project that you are trying to import doesn't have a .settings/org.eclipse.wst.common.project.facet.core.xml that specifies web 3.0 or java 1.6. Another thing to check would be if your project has web.xml version 3.0 specified.
Roger Thal
RE: Error: Dynamic Web Module 3.0 requires Java 1.6 or newer
February 20, 2012 5:05 PM
Answer

Roger Thal

Rank: New Member

Posts: 16

Join Date: January 21, 2012

Recent Posts

The projects that I'm trying to import are of the simplest kind, i.e. generated by "create.bat" (I'm just trying to learn JSP).
Furthermore, I'm using Java 1.7 rje so it shouldn't even complain about needing 1.6 or higher. Just strange.
Gregory Amerson
RE: Error: Dynamic Web Module 3.0 requires Java 1.6 or newer
February 20, 2012 5:15 PM
Answer

Gregory Amerson

LIFERAY STAFF

Rank: Liferay Master

Posts: 911

Join Date: February 16, 2010

Recent Posts

Roger Thal:
The projects that I'm trying to import are of the simplest kind, i.e. generated by "create.bat" (I'm just trying to learn JSP).
Furthermore, I'm using Java 1.7 rje so it shouldn't even complain about needing 1.6 or higher. Just strange.



Check to see what your default JRE compiler level is for your workspace, make sure that it is not set to low.
Roger Thal
RE: Error: Dynamic Web Module 3.0 requires Java 1.6 or newer
February 23, 2012 10:36 AM
Answer

Roger Thal

Rank: New Member

Posts: 16

Join Date: January 21, 2012

Recent Posts

The compiler compliance level is already set to 1.7.

But the problem seems to get resolved by doing the following (which does not make sense to me, but it seems to work!):

Preferences / Java / Compiler:
Make sure Compiler compliance level is 1.6 or higher (mine was already set to 1.7)
Uncheck "Use default compliance settings"
Leave all the choices that were greyed out now active as is, i.e. 1.7 in my case.
Roger Thal
RE: Error: Dynamic Web Module 3.0 requires Java 1.6 or newer
February 25, 2012 6:54 AM
Answer

Roger Thal

Rank: New Member

Posts: 16

Join Date: January 21, 2012

Recent Posts

Delete the project in the IDE (make sure do not delete from disk!)
Import again.
No more error about Dynamic Web Module 3.0 requiring Java 1.6 or newer (when your RJE is already 1.7!)
Hitoshi Ozawa
RE: Error: Dynamic Web Module 3.0 requires Java 1.6 or newer
February 26, 2012 5:06 AM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7990

Join Date: March 23, 2010

Recent Posts

From your description, it just seemed to have been a cache problem. There may have been an old version in the cache. I've encountered this problem several times myself too with eclipse. emoticon
mohammad azaruddin
RE: Error: Dynamic Web Module 3.0 requires Java 1.6 or newer
December 26, 2012 4:27 AM
Answer

mohammad azaruddin

Rank: Expert

Posts: 433

Join Date: September 17, 2012

Recent Posts

Hi
Hitoshi Ozawa

I tried above mentioned method.but it is not working.So Can u tel me how can we solve cache problem

Regards
azar
Bijan Vakili
RE: Error: Dynamic Web Module 3.0 requires Java 1.6 or newer
November 15, 2013 10:15 PM
Answer

Bijan Vakili

Rank: Regular Member

Posts: 138

Join Date: March 10, 2009

Recent Posts

mohammad azaruddin:
Hi
Hitoshi Ozawa

I tried above mentioned method.but it is not working.So Can u tel me how can we solve cache problem

Regards
azar



Hi Azar,

I realize this response is past due.
I had the same issue as you today; but then, I discovered this solution:
Remove all JREs except v6.

Eclipse Standard/SDK
Version: Kepler Service Release 1
Build id: 20130919-0819

OS: Ubuntu 13.10

Default JRE was java-1.7.0-openjdk-amd64
java version "1.7.0_25"
OpenJDK Runtime Environment (IcedTea 2.3.12) (7u25-2.3.12-4ubuntu3)
OpenJDK 64-Bit Server VM (build 23.7-b01, mixed mode)


It's not great, but it works. Good luck my friend.
Attachment

Attachments: eclipse_installed_jres_fix_error.png (101.5k)
mohammad azaruddin
RE: Error: Dynamic Web Module 3.0 requires Java 1.6 or newer
November 17, 2013 9:23 PM
Answer

mohammad azaruddin

Rank: Expert

Posts: 433

Join Date: September 17, 2012

Recent Posts

Hi thank you emoticon

Yeah...Greate job...May be helpful to someone else in future emoticonemoticonemoticon