Forums

Home » Liferay Portal » English » 2. Using Liferay » General

Combination View Flat View Tree View
Threads [ Previous | Next ]
Mathias Lehmann
Messageboard with Jackrabbit very slow
August 31, 2011 11:49 PM
Answer

Mathias Lehmann

Rank: New Member

Posts: 19

Join Date: March 2, 2011

Recent Posts

Hello @all,
i use the messageboard portlet. I configured the portal to use Jackrabbit.
All works fine. But if a thread contains attachment it takes a very long time to open the thread emoticon.

There is a thread with 9 messages. Each message has a file size about 200,4 k. So it takes me about 5 minutes to open the thread.
What can i do to make it faster? I think the problem is, that portlet don't save the filename for each message. So if i want to open the Thread
first the data is loading.
Maybe it is better to save the filenames in the message table and generate the links to the jackrabbit table.

Any one have a solution on it? It is very importent to improve the performance.
I use Liferay 6.0 SP1 EE with IE8

Thanks in advance.
Best regards,
Mathias
Mathias Lehmann
RE: Messageboard with Jackrabbit very slow
November 4, 2011 1:30 AM
Answer

Mathias Lehmann

Rank: New Member

Posts: 19

Join Date: March 2, 2011

Recent Posts

Hello @all,
does anyone have a suggestion on my problem or a bug fix? Maybe i do something wrong in the *.xml configuration files for jackrabbit (e.g workspace.xml, repository.xml).
The users are very frusted on that. They have to wait up to 10 minutes or longer to open a thread.

Please help me. Please let me know if there are any questions on my problem.

Thx in advance!

Best regards,
Mathias
Tri www.VSSIC.com
RE: Messageboard with Jackrabbit very slow
March 6, 2012 11:11 PM
Answer

Tri www.VSSIC.com

Rank: Junior Member

Posts: 31

Join Date: June 8, 2005

Recent Posts

hic, same 2 you
I dont' know why our message board is very slow loading in Topic !
And can't create new topic too
However , in other Portal Instance ( virtual host), everything seems well