Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Tomcat not running properly amol sarang March 8, 2012 9:25 AM
RE: Tomcat not running properly David H Nebinger March 8, 2012 9:32 AM
RE: Tomcat not running properly amol sarang March 8, 2012 9:51 AM
RE: Tomcat not running properly Hitoshi Ozawa March 8, 2012 3:33 PM
RE: Tomcat not running properly amol sarang March 15, 2012 10:45 PM
RE: Tomcat not running properly Hitoshi Ozawa March 16, 2012 5:27 AM
RE: Tomcat not running properly Hitoshi Ozawa March 16, 2012 6:49 AM
RE: Tomcat not running properly afreen shaik February 26, 2015 3:10 AM
RE: Tomcat not running properly David H Nebinger February 26, 2015 6:47 AM
RE: Tomcat not running properly afreen shaik February 26, 2015 7:45 AM
RE: Tomcat not running properly David H Nebinger February 26, 2015 8:18 AM
RE: Tomcat not running properly afreen shaik February 26, 2015 8:50 AM
RE: Tomcat not running properly David H Nebinger February 26, 2015 9:09 AM
RE: Tomcat not running properly Olaf Kock February 27, 2015 12:34 AM
RE: Tomcat not running properly David H Nebinger February 27, 2015 6:07 AM
RE: Tomcat not running properly afreen shaik March 2, 2015 9:00 AM
RE: Tomcat not running properly David H Nebinger March 2, 2015 9:43 AM
RE: Tomcat not running properly afreen shaik March 3, 2015 8:29 AM
RE: Tomcat not running properly David H Nebinger March 3, 2015 8:58 AM
RE: Tomcat not running properly Wilson Man March 3, 2015 10:25 AM
RE: Tomcat not running properly afreen shaik March 3, 2015 11:06 AM
RE: Tomcat not running properly Anil Sunkari March 16, 2012 6:03 AM
RE: Tomcat not running properly amol sarang March 17, 2012 4:16 AM
RE: Tomcat not running properly Anil Sunkari March 18, 2012 11:41 PM
RE: Tomcat not running properly Hitoshi Ozawa March 19, 2012 1:29 AM
amol sarang
Tomcat not running properly
March 8, 2012 9:25 AM
Answer

amol sarang

Rank: New Member

Posts: 10

Join Date: February 28, 2012

Recent Posts

Hi Everyone,

I am new in Liferay Portal. I have set environment variable properly .I have liferay tomacat bundle installed .But when i start the tomcat(double click on startup.bat) window opens and closes immadiately. Tomcat is not starting properly.
I am confused why this happens?

please guide me to start the tomcat server.

Thanks,
Amol
David H Nebinger
RE: Tomcat not running properly
March 8, 2012 9:32 AM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 7887

Join Date: September 1, 2006

Recent Posts

Open a command prompt and manually start the startup.bat. Any errors will be displayed and the window will not close automatically.
amol sarang
RE: Tomcat not running properly
March 8, 2012 9:51 AM
Answer

amol sarang

Rank: New Member

Posts: 10

Join Date: February 28, 2012

Recent Posts

Thanks a lot for quick reply David.I tried using command prompt . but i am facing the same problem.Tomcat window is closing immeadiately. still not able to start Tomcat.
i have to set.I have set:

Variable: JAVA_HOME
Value:C:\Program Files\Java\jdk1.6.0_13

does we need to set the Classpath?or if what the value of Classpath?
or any other variables required.

Thanks in advance,
Amol
Hitoshi Ozawa
RE: Tomcat not running properly
March 8, 2012 3:33 PM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7952

Join Date: March 23, 2010

Recent Posts

Check catalina.xxxx-xx-xx.log files under liferay-portal-6.1.0-ce-ga1\tomcat-7.0.23\logs

See if there is any errors there.
amol sarang
RE: Tomcat not running properly
March 15, 2012 10:45 PM
Answer

amol sarang

Rank: New Member

Posts: 10

Join Date: February 28, 2012

Recent Posts

Hi Hitoshi,

Sorry For late Reply.I have checked the logs directory but its empty.
and problem is still there.Not getting what the problem is.emoticon


Thanks,
Amol
Hitoshi Ozawa
RE: Tomcat not running properly
March 16, 2012 5:27 AM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7952

Join Date: March 23, 2010

Recent Posts

Which version of Windows are you using? Are you running console in Administration mode?

Are you starting up Liferay by %tomcat%\bin\startup.bat
Anil Sunkari
RE: Tomcat not running properly
March 16, 2012 6:03 AM
Answer

Anil Sunkari

Rank: Expert

Posts: 397

Join Date: August 11, 2009

Recent Posts

Not a good idea .. but just try wether you are able to start the app after doing the below steps.

1) Goto environment variables
2) create "CATALINA_HOME" & set the path till tomcat folder
3) try it now.

Thanks,
Anil Sunkari
Hitoshi Ozawa
RE: Tomcat not running properly
March 16, 2012 6:49 AM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7952

Join Date: March 23, 2010

Recent Posts

From the command prompt, enter the following:
java -version

If the version of java displays property, type the following:
echo %JAVA_HOME%
amol sarang
RE: Tomcat not running properly
March 17, 2012 4:16 AM
Answer

amol sarang

Rank: New Member

Posts: 10

Join Date: February 28, 2012

Recent Posts

Hi Anil,

Thank you very much for your reploy.
I already set CATALINA_HOME variable.But now the interesting thing is my Laptop had 512MB RAM.And when I run the startup.bat server was running for a while and system get restarted(some blue screen coming).So i have changed RAM to 2GB. And then when i run startup.bat its not starting the server.
So i reinserted 512MB of RAM and i have deleted sevencogs-hook folder from web-apps directory of tomcat.
And finally its starting the server properly.and I am able to see the Liferays home page.
But its too slow.I dont know whats the problem is(whether it is because of RAM or something else)

Anyway its working now.
Thanks a lot to all of you.

Thanks,
Amol
Anil Sunkari
RE: Tomcat not running properly
March 18, 2012 11:41 PM
Answer

Anil Sunkari

Rank: Expert

Posts: 397

Join Date: August 11, 2009

Recent Posts

Cool .. good to here this news & congratess .Yes you should have better ram configuration.Please refer the below url for exact requirements to work on liferay.

http://www.liferay.com/services/training/topics/portal-administrator-training (Look at bottome right corner box named as "Requirements")

I mean to say you can take this as reference atleast.
Regards,
Anil Sunkari
Hitoshi Ozawa
RE: Tomcat not running properly
March 19, 2012 1:29 AM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7952

Join Date: March 23, 2010

Recent Posts

Open up Task Manager and look at the total physical memory to make sure you really have that much memory.
afreen shaik
RE: Tomcat not running properly
February 26, 2015 3:10 AM
Answer

afreen shaik

Rank: New Member

Posts: 6

Join Date: February 16, 2015

Recent Posts

hi everyone,
Iam new to liferay field..i installed liferay6.2. in Windows8.1(64bits)
my error is when i used to run the "startup.bat" cmd the window is opened and closed immediately...
firstly i set the environment variable to var-name="JAVA_HOME" and value="C:\Program Files\Java\jdk1.6.0_43\bin"
then i got error is JRE_HOME environment variable is not defined correctly.this environment var is needed to run the program....

now i changed to var-name="CATALINA_HOME" and value="C:\Program Files\Java\jdk1.6.0_43\bin"
then i got error is CATALINA_HOME environment variable is not defined correctly.this environment var is needed to run the program....

now please help me to sort the issue...
Thanks in advance
Afreen.shaik
David H Nebinger
RE: Tomcat not running properly
February 26, 2015 6:47 AM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 7887

Join Date: September 1, 2006

Recent Posts

JAVA_HOME should not point to the bin directory, it should be the home of the installation. Same with CATALINA_HOME.
afreen shaik
RE: Tomcat not running properly
February 26, 2015 7:45 AM
Answer

afreen shaik

Rank: New Member

Posts: 6

Join Date: February 16, 2015

Recent Posts

thanks for reply....but still it is not working
David H Nebinger
RE: Tomcat not running properly
February 26, 2015 8:18 AM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 7887

Join Date: September 1, 2006

Recent Posts

the next step would be to open a command prompt in the CATALINA_HOME\bin directory and from there do a ".\startup.bat" command. Instead of flashing and going away you should see whatever message is blocking you.
afreen shaik
RE: Tomcat not running properly
February 26, 2015 8:50 AM
Answer

afreen shaik

Rank: New Member

Posts: 6

Join Date: February 16, 2015

Recent Posts

thanks for reply.......please find the attachment and sort the issue
Attachments: cmd.docx (731.6k)
David H Nebinger
RE: Tomcat not running properly
February 26, 2015 9:09 AM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 7887

Join Date: September 1, 2006

Recent Posts

sorry, docx is a private format prone to virus distribution. Please repost as text or something.
Olaf Kock
RE: Tomcat not running properly
February 27, 2015 12:34 AM
Answer

Olaf Kock

LIFERAY STAFF

Rank: Liferay Legend

Posts: 2111

Join Date: September 23, 2008

Recent Posts

David H Nebinger:
the next step would be to open a command prompt in the CATALINA_HOME\bin directory and from there do a ".\startup.bat" command. Instead of flashing and going away you should see whatever message is blocking you.


Does "startup.bat" do this or rather "catalina.bat run"?

+1 for pure text requirement. It's most likely just a few lines that could easily be pasted in the message body anyway
David H Nebinger
RE: Tomcat not running properly
February 27, 2015 6:07 AM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 7887

Join Date: September 1, 2006

Recent Posts

Olaf Kock:
Does "startup.bat" do this or rather "catalina.bat run"?


I think it's 6 of one, a half dozen of the other in most cases.

For the OP's case she has JAVA_HOME mapped to all the wrong places, CATALINA_HOME also mapped incorrectly, so those are my guess as to what's wrong.

When those work it's typically JVM related (i.e. wanting more memory than available, those kinds of things) and when startup.bat is used you just get the flashing window and need to switch to "catalina.bat run".

For those unaware, basically startup.bat invokes the command "catalina.bat start".

The difference between the start and run arguments, start is used to launch the background Tomcat process whereas run will launch the foreground Tomcat process that outputs within the console.

The second makes it easy to see the transition from windows issues into java issues without the flashing window, but it's sometimes more than what a newbie needs to understand.
afreen shaik
RE: Tomcat not running properly
March 2, 2015 9:00 AM
Answer

afreen shaik

Rank: New Member

Posts: 6

Join Date: February 16, 2015

Recent Posts

thanks for reply,,,,,,,but still it is not working.....same error was repeated
David H Nebinger
RE: Tomcat not running properly
March 2, 2015 9:43 AM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 7887

Join Date: September 1, 2006

Recent Posts

what error? no error was listed? If you're talking about the one in the word doc, well then strip it out and paste it here...
afreen shaik
RE: Tomcat not running properly
March 3, 2015 8:29 AM
Answer

afreen shaik

Rank: New Member

Posts: 6

Join Date: February 16, 2015

Recent Posts

hi....,
now my liferay is working.....
my problem was i didnt set the environment variable path...i rectified my error...
thanks for helping me...


please suggest me the links to develop the applications in liferay....
thanks in advance
Afreen.Shaik
David H Nebinger
RE: Tomcat not running properly
March 3, 2015 8:58 AM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 7887

Join Date: September 1, 2006

Recent Posts

Purchase and read Liferay in Action.
Wilson Man
RE: Tomcat not running properly
March 3, 2015 10:25 AM
Answer

Wilson Man

LIFERAY STAFF

Rank: Liferay Master

Posts: 579

Join Date: June 21, 2006

Recent Posts

afreen shaik:
now i changed to var-name="CATALINA_HOME" and value="C:\Program Files\Java\jdk1.6.0_43\bin"
then i got error is CATALINA_HOME environment variable is not defined correctly.this environment var is needed to run the program....


Not sure if this is just a typo, or that you've already fixed, but CATALINA_HOME should not be set to your JDK bin.

CATALINA_HOME should point to your top level tomcat home directory (for most cases).
afreen shaik
RE: Tomcat not running properly
March 3, 2015 11:06 AM
Answer

afreen shaik

Rank: New Member

Posts: 6

Join Date: February 16, 2015

Recent Posts

Wilson Man:
afreen shaik:
now i changed to var-name="CATALINA_HOME" and value="C:\Program Files\Java\jdk1.6.0_43\bin"
then i got error is CATALINA_HOME environment variable is not defined correctly.this environment var is needed to run the program....


Not sure if this is just a typo, or that you've already fixed, but CATALINA_HOME should not be set to your JDK bin.

CATALINA_HOME should point to your top level tomcat home directory (for most cases).



hi,,
while setting environment variable path->
in user variable window->
after clicking add button.Var name="JAVA_HOME" and value="C:\Java\jdk1.7.0_75"and again adds
var-name="PATH" and value="C:\Java\jdk1.7.0_75\bin" saved
then,
i run the startup.bat file
now it is working.....

nw iam looking for the developer links....please suggest me the links

thanks in advance
Afreen.shaik