Liferay is a Gartner Magic Quadrant Leader for the Sixth Year! Find out why

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Klaus Müller
No connection with PostgreSQL
March 9, 2012 4:53 AM
Answer

Klaus Müller

Rank: New Member

Posts: 3

Join Date: March 9, 2012

Recent Posts

Hi,

I am fighting with the error message:
1"Database connection could not be established. Please check your connection settings."


My current settings for installation process:
1Database Type: PostgreSQL
2JDBC URL: jdbc:postgresql://localhost:5432/lportal
3JDBC Driver Class Name: org.postgresql.Driver
4User Name: **
5Password: **


User name and password are set correctly.

The database and the user exists on the PostgreSQL server. Does Liferay need special rights? Currently the owner of the lportal - database is the user entered at liferay.

I hope you can help me solving this problem. I read lots of threads here, but nothing worked for me.

The complete system is a virtual machine and runs on Debian 6.0.

Thanks for your help emoticon
Hitoshi Ozawa
RE: No connection with PostgreSQL
March 10, 2012 4:26 AM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7949

Join Date: March 23, 2010

Recent Posts

Which version of postgresql are you using? Have you tried replacing the jdbc driver installed with Liferay (it's under lib\ext).
Klaus Müller
RE: No connection with PostgreSQL
March 10, 2012 12:14 PM
Answer

Klaus Müller

Rank: New Member

Posts: 3

Join Date: March 9, 2012

Recent Posts

Thanks for your reply!
I am using PostgreSQL 9.1.3 and I tried replacing the postgresql jdbc driver. But I still get the old error warning...pgAdmin shows that everything is fine.

Must the jdbc driver have a special name? Currently it is named "postgresql.jar". In /lib/ and /lib/ext/
Hitoshi Ozawa
RE: No connection with PostgreSQL
March 11, 2012 1:33 AM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7949

Join Date: March 23, 2010

Recent Posts

Currently it is named "postgresql.jar". In /lib/ and /lib/ext/


There should only be one. Delete the "postgresql.jar" in the /lib directory.
Klaus Müller
RE: No connection with PostgreSQL
March 12, 2012 1:15 AM
Answer

Klaus Müller

Rank: New Member

Posts: 3

Join Date: March 9, 2012

Recent Posts

I deleted the file in /lib, but the problem is still the same.
Needs the Liferay portal a special PostgreSQL-Account or can I choose some Account?
Currently the owner of the database is the user I named in the configuration menu.

I checked the connection settings for all the PostgreSQL databases and from localhost I can connect to all databases.

Anyone an idea what's wrong?