Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Aritra Ghosh
deployment problem in liferay 6.1
March 13, 2012 11:14 AM
Answer

Aritra Ghosh

Rank: Junior Member

Posts: 63

Join Date: November 8, 2011

Recent Posts

Hi All,
I developed a liferay jsf project using liferay 6.0.6.But now,when I check-out the codes from svn and try to deploy it in liferay 6.1 GA1 server,it is not being deployed.I am getting invoker exception.The stack-trace is like as follows:
at com.liferay.portal.kernel.servlet.filters.invoker.InvokerFilter.doFilter(InvokerFilter.java:70)
at com.liferay.portal.kernel.servlet.filters.invoker.InvokerFilterChain.processDoFilter(InvokerFilterChain.java:203)
at com.liferay.portal.kernel.servlet.filters.invoker.InvokerFilterChain.doFilter(InvokerFilterChain.java:105)

There is no path issues.I make recognized the server runtime,JRE etc properly.Any help???

Thanks & regards,
Aritra
Juan Gonzalez
RE: deployment problem in liferay 6.1
March 13, 2012 11:29 AM
Answer

Juan Gonzalez

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1980

Join Date: October 28, 2008

Recent Posts

It's a known bug, solved in current trunk.

Download nightly build of Liferay and try to deploy there.
Aritra Ghosh
RE: deployment problem in liferay 6.1
March 14, 2012 6:15 AM
Answer

Aritra Ghosh

Rank: Junior Member

Posts: 63

Join Date: November 8, 2011

Recent Posts

Juan Gonzalez P:
It's a known bug, solved in current trunk.

Download nightly build of Liferay and try to deploy there.


Thanks Juan.Can you please guide me how to make a liferay-tomcat bundle by checking out source code from svn.I checked-out latest portal trunk from liferay svn already.
regards,
Aritra
Jan Geißler
RE: deployment problem in liferay 6.1
March 14, 2012 8:27 AM
Answer

Jan Geißler

Rank: Expert

Posts: 358

Join Date: July 5, 2011

Recent Posts

We also experienced this problem. Try the following steps:

1. Remove your Portlet completly from the server.
2. Check in your {portalTomcatDir}/conf/Catalina/localhost/ folder if there is a file called: {projectName}.xml. If it is there, delete it.
3. Dont use the IDE Deploy Mechanics.
4. Use the Liferay->Deploy ant Task, to publish your portlet to the server.

That should do the trick. The Liferay Deploy in the IDE is somehow broke.


Regards
Jan