Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
moving images from 6.0.6 to 6.1ga1 fails gordon daniels April 16, 2012 1:57 PM
RE: moving images from 6.0.6 to 6.1ga1 fails David H Nebinger April 16, 2012 2:03 PM
RE: moving images from 6.0.6 to 6.1ga1 fails gordon daniels April 16, 2012 2:08 PM
RE: moving images from 6.0.6 to 6.1ga1 fails Hitoshi Ozawa April 16, 2012 2:14 PM
RE: moving images from 6.0.6 to 6.1ga1 fails gordon daniels April 16, 2012 3:38 PM
RE: moving images from 6.0.6 to 6.1ga1 fails David H Nebinger April 16, 2012 4:18 PM
RE: moving images from 6.0.6 to 6.1ga1 fails gordon daniels April 16, 2012 4:39 PM
RE: moving images from 6.0.6 to 6.1ga1 fails gordon daniels April 16, 2012 7:17 PM
RE: moving images from 6.0.6 to 6.1ga1 fails David H Nebinger April 16, 2012 8:26 PM
RE: moving images from 6.0.6 to 6.1ga1 fails gordon daniels April 16, 2012 8:49 PM
RE: moving images from 6.0.6 to 6.1ga1 fails gordon daniels April 16, 2012 9:15 PM
RE: moving images from 6.0.6 to 6.1ga1 fails David H Nebinger April 17, 2012 8:26 AM
RE: moving images from 6.0.6 to 6.1ga1 fails gordon daniels April 17, 2012 8:34 AM
RE: moving images from 6.0.6 to 6.1ga1 fails David H Nebinger April 17, 2012 9:24 AM
RE: moving images from 6.0.6 to 6.1ga1 fails gordon daniels April 17, 2012 9:37 AM
RE: moving images from 6.0.6 to 6.1ga1 fails Heinz Lätsch April 17, 2012 10:38 PM
RE: moving images from 6.0.6 to 6.1ga1 fails gordon daniels April 18, 2012 5:44 AM
RE: moving images from 6.0.6 to 6.1ga1 fails Willem Vermeer April 18, 2012 2:13 AM
RE: moving images from 6.0.6 to 6.1ga1 fails Juan Gonzalez April 18, 2012 9:24 AM
RE: moving images from 6.0.6 to 6.1ga1 fails Willem Vermeer April 19, 2012 12:46 AM
RE: moving images from 6.0.6 to 6.1ga1 fails James Falkner April 19, 2012 11:53 AM
RE: moving images from 6.0.6 to 6.1ga1 fails Juan Gonzalez April 19, 2012 12:45 PM
RE: moving images from 6.0.6 to 6.1ga1 fails Juan Gonzalez April 20, 2012 10:43 AM
RE: moving images from 6.0.6 to 6.1ga1 fails Hitoshi Ozawa April 22, 2012 5:05 PM
RE: moving images from 6.0.6 to 6.1ga1 fails Sunil Rai May 10, 2012 6:18 AM
RE: moving images from 6.0.6 to 6.1ga1 fails Antônio Junior August 17, 2012 2:40 PM
gordon daniels
moving images from 6.0.6 to 6.1ga1 fails
April 16, 2012 1:57 PM
Answer

gordon daniels

Rank: Liferay Master

Posts: 670

Join Date: August 23, 2008

Recent Posts

I have read the doc on how to upgrade and it always fails. I have given up on that. Is there a way to scp images from one server to another and have liferay detect them?

thanks
David H Nebinger
RE: moving images from 6.0.6 to 6.1ga1 fails
April 16, 2012 2:03 PM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 7238

Join Date: September 1, 2006

Recent Posts

I'm assuming you're testing the upgrade process using a copy of your 6.0 DB, right?

If so, you also need a copy of the 6.0 data directory.

Just as you tweak portal-ext.properties to point to the copy of the DB for the upgrade, you also need to point at the copy of the data directory for the upgrade.

No, it's not as simple as doing an scp between systems. The files may be stored locally on the filesystem, but the database will still have links to the old images, the indexing will not be correct, ...
gordon daniels
RE: moving images from 6.0.6 to 6.1ga1 fails
April 16, 2012 2:08 PM
Answer

gordon daniels

Rank: Liferay Master

Posts: 670

Join Date: August 23, 2008

Recent Posts

thank you for your reply. I did all that you suggested, that is what the upgrade guide tells to do. It does not work. You will see other posts where others are having problems with docs and images on upgrade as well.

I was hoping to avoid having to re-upload the images but at this point it looks as if that is the way to proceed.

thanks
Hitoshi Ozawa
RE: moving images from 6.0.6 to 6.1ga1 fails
April 16, 2012 2:14 PM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7954

Join Date: March 23, 2010

Recent Posts

Liferay support WebDAV. I found that to be easiest way to upload files to Liferay.
gordon daniels
RE: moving images from 6.0.6 to 6.1ga1 fails
April 16, 2012 3:38 PM
Answer

gordon daniels

Rank: Liferay Master

Posts: 670

Join Date: August 23, 2008

Recent Posts

that is something I have not tried with liferay. Thanks for the suggestion.
David H Nebinger
RE: moving images from 6.0.6 to 6.1ga1 fails
April 16, 2012 4:18 PM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 7238

Join Date: September 1, 2006

Recent Posts

Except that is only for uploading new images. If you have web content that already uses existing images in the 6.0 line, you have to get through the upgrade process to retain them.

There were problems w/ some of the earlier release candidates, but many of those (but not necessarily all) were fixed with the final GA.

Can you provide some examples of the errors you're encountering, or have you confirmed that they are the same that others have posted about?
gordon daniels
RE: moving images from 6.0.6 to 6.1ga1 fails
April 16, 2012 4:39 PM
Answer

gordon daniels

Rank: Liferay Master

Posts: 670

Join Date: August 23, 2008

Recent Posts

I have already started uploading images. I've spent way too much time trying to do the upgrade. Right now I want to get the site back up. However, I will try again and post here the errors.

thank you for taking the time to respond.
gordon daniels
RE: moving images from 6.0.6 to 6.1ga1 fails
April 16, 2012 7:17 PM
Answer

gordon daniels

Rank: Liferay Master

Posts: 670

Join Date: August 23, 2008

Recent Posts

David: here is the error message. I copied the data directory according to the upgrade document and pointed to it in my portal.ext-properties file.

ERROR [ImageProcessorImpl:181] com.liferay.portlet.documentlibrary.NoSuchFileException: /opt/marsh/data/document_library/10132/10157/3/1
.0

I looked in that directory and there is no doc. However, this stops the server from starting. Any thoughts?
David H Nebinger
RE: moving images from 6.0.6 to 6.1ga1 fails
April 16, 2012 8:26 PM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 7238

Join Date: September 1, 2006

Recent Posts

So was that file available in the original 6.0.6 doc library path?

Is it available in the directory before you start the 6.1 upgrade?
gordon daniels
RE: moving images from 6.0.6 to 6.1ga1 fails
April 16, 2012 8:49 PM
Answer

gordon daniels

Rank: Liferay Master

Posts: 670

Join Date: August 23, 2008

Recent Posts

its an empty directory on 6.0. Don't know why. Does deleteing it solve problem?
gordon daniels
RE: moving images from 6.0.6 to 6.1ga1 fails
April 16, 2012 9:15 PM
Answer

gordon daniels

Rank: Liferay Master

Posts: 670

Join Date: August 23, 2008

Recent Posts

David: I added an explicit path to image folder in portal.ext-properties. Those error messages went away. Now it gives this message:

ERROR [MainServlet:198] com.liferay.portal.kernel.events.ActionException: com.liferay.portal.kernel.upgrade.UpgradeException: com.liferay.portal.kernel.upgrade.UpgradeException: com.mysql.jdbc.exceptions.MySQLSyntaxErrorException: Table 'marshportal.IGFolder' doesn't exist

Is that the Image Gallery table? Any thoughts on how to fix? The server won't startup when it encounters that message.
David H Nebinger
RE: moving images from 6.0.6 to 6.1ga1 fails
April 17, 2012 8:26 AM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 7238

Join Date: September 1, 2006

Recent Posts

gordon daniels:
its an empty directory on 6.0. Don't know why. Does deleteing it solve problem?


So that's really the source of the problem (for both doc lib and image gallery)...

Somehow the underlying folders/files were removed. Whether it was done within Liferay or by someone directly in the filesystem would be hard to guess, but basically the files/folders are gone. Liferay 6.0 will happily chug along though because, unless it is specifically accessed, 6.0 has no reason to validate that they're still there on the filesystem.

Then the 6.1 upgrade process starts. Since this does have an upgrade for the tables used, the upgrade process is now going through and verifying that all of the data in the tables match what is supposed to be in the filesystem. Not finding what should be there, it starts throwing exceptions.

Many people call it a bug, but I have a different perspective. To me the upgrade process is reporting an inconsistency between the database and the filesystem and, in a production environment, I would want to be able to address the inconsistency before anything else happens. But that's my own opinion, and I think it was shared by Liferay for the first GA release.

The next GA release is supposed to be coming out at the end of the month that is supposed to allow the upgrade to continue when these kinds of inconsistencies are encountered.
gordon daniels
RE: moving images from 6.0.6 to 6.1ga1 fails
April 17, 2012 8:34 AM
Answer

gordon daniels

Rank: Liferay Master

Posts: 670

Join Date: August 23, 2008

Recent Posts

thank you for the detailed response. So, basically I am out of luck on upgrade until new release?

I really appreciate you taking the time to respond.
David H Nebinger
RE: moving images from 6.0.6 to 6.1ga1 fails
April 17, 2012 9:24 AM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 7238

Join Date: September 1, 2006

Recent Posts

Based upon forum threads, I think many of the upgrade issues are to be resolved with the next release, but YMMV. It's due out towards the end of the month, so it might be easier to wait rather than pull your hair out... emoticon
gordon daniels
RE: moving images from 6.0.6 to 6.1ga1 fails
April 17, 2012 9:37 AM
Answer

gordon daniels

Rank: Liferay Master

Posts: 670

Join Date: August 23, 2008

Recent Posts

thanks.
Heinz Lätsch
RE: moving images from 6.0.6 to 6.1ga1 fails
April 17, 2012 10:38 PM
Answer

Heinz Lätsch

Rank: New Member

Posts: 1

Join Date: December 22, 2011

Recent Posts

If you are facing Image Gallery upgrade problems, it might be caused by the size of your image files. If you changed the max dimensions of your images on 6.0 than you probably need to set the dl.file.max.size=3072000 to a value which fits to your images.
Willem Vermeer
RE: moving images from 6.0.6 to 6.1ga1 fails
April 18, 2012 2:13 AM
Answer

Willem Vermeer

Rank: New Member

Posts: 22

Join Date: March 30, 2012

Recent Posts

Does this means that its scheduled release date of Friday April 20th will not be met?
Thanks,
Willem
gordon daniels
RE: moving images from 6.0.6 to 6.1ga1 fails
April 18, 2012 5:44 AM
Answer

gordon daniels

Rank: Liferay Master

Posts: 670

Join Date: August 23, 2008

Recent Posts

Heinz: thanks for the reply. That's not the problem but I appreciate the info. I didn't know about the max limits emoticon

thanks
Juan Gonzalez
RE: moving images from 6.0.6 to 6.1ga1 fails
April 18, 2012 9:24 AM
Answer

Juan Gonzalez

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1984

Join Date: October 28, 2008

Recent Posts

Why it wouldn't meet? It should be out AFAIK.
Willem Vermeer
RE: moving images from 6.0.6 to 6.1ga1 fails
April 19, 2012 12:46 AM
Answer

Willem Vermeer

Rank: New Member

Posts: 22

Join Date: March 30, 2012

Recent Posts

I have high hopes that the 6.1.1 CE GA2 release will fix the problems we're currently experiencing when upgrading from 6.0.5 to 6.1.0 CE. In this thread it is stated that the next release is to be expected towards the end of this month. The due date of the release is Friday April 20th according to:
http://issues.liferay.com/browse/LPS/fixforversion/11326#atl_token=AIHS-9O28-DDC7-7908|280318a3df98715713d3894e1841e8eaadcd43bb|lout&selectedTab=com.atlassian.jira.plugin.system.project%3Aversion-summary-panel
I'd like to know when I can expect to be able to download an official 6.1.1. CE GA2.
Maybe it's just me, reading too much into comments posted by a Liferay Legend who is not a Liferay Staff Employee.
Thanks,
Willem
James Falkner
RE: moving images from 6.0.6 to 6.1ga1 fails
April 19, 2012 11:53 AM
Answer

James Falkner

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1222

Join Date: September 17, 2010

Recent Posts

Willem Vermeer:
I have high hopes that the 6.1.1 CE GA2 release will fix the problems we're currently experiencing when upgrading from 6.0.5 to 6.1.0 CE. In this thread it is stated that the next release is to be expected towards the end of this month. The due date of the release is Friday April 20th according to:
http://issues.liferay.com/browse/LPS/fixforversion/11326#atl_token=AIHS-9O28-DDC7-7908|280318a3df98715713d3894e1841e8eaadcd43bb|lout&selectedTab=com.atlassian.jira.plugin.system.project%3Aversion-summary-panel
I'd like to know when I can expect to be able to download an official 6.1.1. CE GA2.
Maybe it's just me, reading too much into comments posted by a Liferay Legend who is not a Liferay Staff Employee.
Thanks,
Willem



The original date was April 20, but we are pushing back 2 weeks to deal with some last minute issues, so expect CE GA2 on May 4th. There are some exciting and complex cross-dependencies between Portal, Social Office 2, and Marketplace, all expected within 2 weeks of each other.
Juan Gonzalez
RE: moving images from 6.0.6 to 6.1ga1 fails
April 19, 2012 12:45 PM
Answer

Juan Gonzalez

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1984

Join Date: October 28, 2008

Recent Posts

James Falkner:

The original date was April 20, but we are pushing back 2 weeks to deal with some last minute issues, so expect CE GA2 on May 4th. There are some exciting and complex cross-dependencies between Portal, Social Office 2, and Marketplace, all expected within 2 weeks of each other.


Ouch! Can someone update release date in JIRA? BTW, this would be a chance to solve some more issues for 6.1.1(for example, when upgrading).
Juan Gonzalez
RE: moving images from 6.0.6 to 6.1ga1 fails
April 20, 2012 10:43 AM
Answer

Juan Gonzalez

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1984

Join Date: October 28, 2008

Recent Posts

Ups! Seems release date is now May 11.
Hitoshi Ozawa
RE: moving images from 6.0.6 to 6.1ga1 fails
April 22, 2012 5:05 PM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7954

Join Date: March 23, 2010

Recent Posts

Liferay just moved back the release date of Liferay 6.1.1 GA2 to May 11.

http://issues.liferay.com/browse/LPS#selectedTab=com.atlassian.jira.ext.calendar%3Aissuecalendar-panel

FYI, James, who gave the 20th +/- date is a Liferay staff. With development distributed around the globe, it probably is difficult to not get delayed unless there is a strong schedule planning and review. I personally don't delay projects unless I get further funding ,but from what I've been seeing, release date tends to get delayed often here probably because they're not getting paid by customer by hours like most of us. Anyways, my customers don't want software with bugs OOTB so I'm using the most stable release which I've patched up - for us, it's not whether you can fix a bug or not, it's more about whether there is a bug or not.

Hope the delay is because of bug fixes and isn't because of adding addition features.

I personally don't think upgrade issues can be fully resolved. If it has, Liferay.com probably would have been upgraded already. emoticon

Sorry, have to go. Just got back last Saturday from a business trip, but have to setup a pre-sales demo for tomorrow and another for a day after. Kind of busy this week again. :-)
Sunil Rai
RE: moving images from 6.0.6 to 6.1ga1 fails
May 10, 2012 6:18 AM
Answer

Sunil Rai

Rank: Junior Member

Posts: 43

Join Date: January 31, 2012

Recent Posts

Any update on the release date of Liferay 6.1.1 GA2 ?
Antônio Junior
RE: moving images from 6.0.6 to 6.1ga1 fails
August 17, 2012 2:40 PM
Answer

Antônio Junior

LIFERAY STAFF

Rank: Junior Member

Posts: 63

Join Date: July 5, 2011

Recent Posts

http://www.liferay.com/web/james.falkner/blog/-/blogs/14850038