Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
amit mahajan
delegate functionality not working
April 19, 2012 4:22 AM
Answer

amit mahajan

Rank: New Member

Posts: 10

Join Date: May 17, 2011

Recent Posts

Hello

We have to deploy liferay to one server where we have only one shared URL.

We tried updating the context root of liferay application and we were able to see our portlets.

The probelm is all the functionality related to delegate has stopped worknig since liferay ctx is changed but we have hard coded the delete servlet url in many of our pages.

Kindly help us ASAP as we need to deploy it by EOD today only. emoticon

Thanks & Regards

Amit
David H Nebinger
RE: delegate functionality not working
April 19, 2012 5:48 AM
Answer

David H Nebinger

Community Moderator

Rank: Liferay Legend

Posts: 9271

Join Date: September 1, 2006

Recent Posts

So you hard coded something, it's now broke, but somehow we can fix it?

I'll tell you how to fix it... Fire the person that decided it was okay to hard code something. This would be an example of one bad decision they made, I'm willing to bet there's a bunch more that you haven't found yet.

Remove the hard coding and you'll be fine.
Hitoshi Ozawa
RE: delegate functionality not working
April 27, 2012 9:09 PM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7949

Join Date: March 23, 2010

Recent Posts

Well, it's may be late, but you could have used Liferay bundle and copy all your other web pages under Liferay's ROOT\html directory.