Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Pablo Casos
Install plugin from software catalog Lucene Error
May 2, 2012 5:12 AM
Answer

Pablo Casos

Rank: New Member

Posts: 2

Join Date: May 2, 2012

Recent Posts

Hi,

I'm trying to setup a plugin repository by using the software catalog portlet, but cannot get any portlet display while searching.
After debugging the code looks like Lucene is not finding any portlet plugin, though I can see, when refreshing the plugin repositories from "Browse Repository" tab , that plugin repositories and associated portlet are correctly added to cache and indexed (at least, it calls the indexer).
If I repeat the search specifying a plugin repository in the "Repository" combobox, I find out this error in Liferay's logs:

11:54:06,484 WARN [LuceneHelperImpl:342] Unable to parse +(+((+(entryClassName:com.liferay.portal.kernel.plugin.PluginPackage)))) +(+(type:portlet)) +(repositoryURL:http://plugins.liferay.com/enterprise)

Have looked around forums and google and haven't find any info about Lucene problems on Plugin repositories...

Has anyone meet such an error log before? Are there any problems with indexation on plugin repositories?

This is a 6.0.12 EE setup.


Thanks in advance.
Hitoshi Ozawa
RE: Install plugin from software catalog Lucene Error
May 2, 2012 5:22 AM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7952

Join Date: March 23, 2010

Recent Posts

Make sure there aren't any error during the startup - especially about not being able to connect to liferay.com repository.
Pablo Casos
RE: Install plugin from software catalog Lucene Error
May 4, 2012 7:03 AM
Answer

Pablo Casos

Rank: New Member

Posts: 2

Join Date: May 2, 2012

Recent Posts

Hitoshi Ozawa:
Make sure there aren't any error during the startup - especially about not being able to connect to liferay.com repository.



Hi Hitoshi,

thanks for your answer!

I'm testing with two repositories; the other one is exists in the same machine, and is correctly added when clicking the Refresh button. It is when searching on a specific repo when I get the Lucene error.
Anyway, don't think a connection error would cause Liferay to create an incorrect Lucene search expression..