Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Debasis Padhi
BUILD SUCCESSFUL BUT NOT DEPLOYED
May 29, 2012 1:14 AM
Answer

Debasis Padhi

Rank: Junior Member

Posts: 55

Join Date: March 23, 2012

Recent Posts

Buildfile: /home/mpower/Project/ITConvergence/portal/itc/trunk/plugins/hooks/itc-training-hook/build.xml
compile:
merge:
Copying 4 files to /home/mpower/Project/ITConvergence/portal/itc/trunk/plugins/hooks/itc-training-hook/docroot/WEB-INF/lib
Copying 4 files to /home/mpower/Project/ITConvergence/portal/itc/trunk/plugins/hooks/itc-training-hook/docroot/WEB-INF/lib
compile-java:
merge:
war:
clean-portal-dependencies:
Building zip: /home/mpower/Project/ITConvergence/portal/itc/trunk/plugins/dist/itc-training-hook-6.1.0.1.war
deploy:
Copying 1 file to /home/mpower/Software/bundles/deploy
BUILD SUCCESSFUL
Total time: 2 seconds
Oliver Bayer
RE: BUILD SUCCESSFUL BUT NOT DEPLOYED
May 29, 2012 1:19 AM
Answer

Oliver Bayer

Rank: Liferay Master

Posts: 883

Join Date: February 18, 2009

Recent Posts

Hi Debasis,

it seems that you're missing the "your-login-build.properties" file. There you should override the key "app.server.dir" and point to your server e.g. your tomcat bundle. If your're using the eclipse ide you can configure this via the GUI.

HTH Oli
Apoorva Prakash
RE: BUILD SUCCESSFUL BUT NOT DEPLOYED
May 29, 2012 4:49 AM
Answer

Apoorva Prakash

Rank: Liferay Master

Posts: 659

Join Date: June 15, 2010

Recent Posts

Yes Debasis, Oliver said very correct..
Create a file with following name in plugin SDK folder

build.<USER-NAME>.properties

and then
app.server.dir=D:/workspace/liferay-portal-tomcat-6.0.5/tomcat-6.0.26

put the path where your server is located (the given path is just an example).

Hope this will help,
Thanks and Regards,
Apoorva Prakash
asif aftab
RE: BUILD SUCCESSFUL BUT NOT DEPLOYED
April 1, 2014 4:08 AM
Answer

asif aftab

Rank: Junior Member

Posts: 85

Join Date: September 2, 2013

Recent Posts

Thank you for your reply Apoorva, I checked in build<username>.properties file each and every thing is good, then what is the cause of such behavior that on deploy upto build successful message is ok then it is stop so now I am using direct deploy and it is working. I am using Liferay 6.x tomcat 7 and java 1.7.x, windows 7

content of my file
# Managed by Liferay IDE (remove this comment to prevent future updates)
#Managed by Liferay IDE (remove this comment to prevent future updates)
#Tue Apr 01 14:33:14 IST 2014
app.server.portal.dir = D:\\ExpandoHookWorkSpace\\liferay-portal-6.2.0-ce-ga1\\tomcat-7.0.42\\webapps\\ROOT
app.server.lib.global.dir = D:\\ExpandoHookWorkSpace\\liferay-portal-6.2.0-ce-ga1\\tomcat-7.0.42\\lib\\ext
app.server.deploy.dir = D:\\ExpandoHookWorkSpace\\liferay-portal-6.2.0-ce-ga1\\tomcat-7.0.42\\webapps
app.server.type = tomcat
app.server.dir = D:\\ExpandoHookWorkSpace\\liferay-portal-6.2.0-ce-ga1\\tomcat-7.0.42
asif aftab
RE: BUILD SUCCESSFUL BUT NOT DEPLOYED
April 10, 2014 12:10 AM
Answer

asif aftab

Rank: Junior Member

Posts: 85

Join Date: September 2, 2013

Recent Posts

go to plugins-sdk folder.
open build.<userName>.properties (In my case name of file is build.asif.properties)
open it..
add the below line
auto.deploy.dir = D:\\nWorkSpace\\liferay-portal-6.2.0-ce-ga1\\deploy
where nWorkSpace is my workspace. My problem is resolve.
Hope helpful for others