Combination View Flat View Tree View
Threads [ Previous | Next ]
Diego Silva
OpenAM + Active Directory + Liferay
June 15, 2012 3:00 PM
Answer

Diego Silva

Rank: Junior Member

Posts: 35

Join Date: June 16, 2010

Recent Posts

Hola a todos

Trato de configurar mi Liferay 6.1 para que utilice la autenticación del OpenAM que debería estar configurado con el AD.

El LR + AD me funciona perfecto. El usuario "principal" es una cuenta de usuario común, es decir, sin permisos de administrador. Por seguridad, no me han dado ni me van a dar alguna cuenta con privilegios de administrador.

Ahora, quiero implementar el OpemAM + AD. Al parecer lo he logrado, aunque con alguna configuración adicional. Por ejemplo, he establecido que ignore el perfil de usuario (Authentication > All Core setting > User Profile= Ignored) No lo necesario, realmente, porque solo quiero que inicie sesión. Primera pregunta: ¿es necesario esta configuración?. Cabe resaltar que en el AD tengo como 1600 usuarios, pero cuando los "subjects" de OpenAM solo me muestra 103. Además, inicio sesión con una cuenta que no está en los "subjects" y se conecta correctamente.

Ahora, como ya tengo el OpenAM+AD, quiero usar el LR con OpenAM. He puesto todos los parametros que indica acá https://wikis.forgerock.org/confluence/display/openam/integrate+OpenAM+with+Liferay

Entro al LR, entro al enlace de inicio de sesión, me muestra el formulario de OpenAM, inicio sesión en el OpemAM sin problema.. pero luego me redireccion al inicio de sesión del LR.. Pareciera que algo no está configurado correctamente. ¿A alguien le ha pasado lo mismo?

Las cookies están encriptadas.


¿Quizás hay algun mapeo que falta entre OpenAM + LR + AD? ¿Es necesario una cuenta de admiistrador para hacer todo esto?