Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Carlos Adolfo Ortiz Quirós
JDK7 or JDK6 for Liferay V6.0.6 and V6.1.0
June 26, 2012 6:17 AM
Answer

Carlos Adolfo Ortiz Quirós

Rank: Junior Member

Posts: 40

Join Date: May 22, 2010

Recent Posts

Hi

This is a topic that I am not sure or I don't know where is it documented?

I am studying V6.0.6 the most, but V6.1.0 is a target as well.
I have installed JDK 7 and then the Tomcat bundle for V6.0.6, it apparently works, but I have told that many things don't work as expected and I want you to confirm about this. The same holds for V6.1.0?

Where can I find which JDK works or in which JDK is Liferay certified?
David H Nebinger
RE: JDK7 or JDK6 for Liferay V6.0.6 and V6.1.0
June 26, 2012 6:19 AM
Answer

David H Nebinger

Community Moderator

Rank: Liferay Legend

Posts: 8617

Join Date: September 1, 2006

Recent Posts

JDK 6 is the only one that will work completely.

JDK 7 will appear to work, but there are issues w/ the Lucene version shipped and JDK 7. JDK 7 should be avoided until the issues have been resolved and the updated lucene is shipped with the liferay bundle.
Hitoshi Ozawa
RE: JDK7 or JDK6 for Liferay V6.0.6 and V6.1.0
June 30, 2012 8:48 AM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7952

Join Date: March 23, 2010

Recent Posts

Check James (with Liferay.com) comment in the following thread. JDK 1.7 is not supported by liferay.com because there are still pending issues.

http://www.liferay.com/community/forums/-/message_boards/message/13426867