Combination View Flat View Tree View
Threads [ Previous | Next ]
Peter Hellstrand
The portal is slow (very few users)
July 11, 2012 12:24 PM
Answer

Peter Hellstrand

Rank: Regular Member

Posts: 167

Join Date: November 30, 2011

Recent Posts

Hi

I have a problem with an application. It is not in production yet so very few users. The problem only occur sometimes. Most times if you havent touched anything for a while. It is not our portlets generally speaking. I it for example when uploading files. creating web content and so on. Can you give me a hint we to start? Do you have any tools for this.

I use the tomcat bundled version.
David H Nebinger
RE: The portal is slow (very few users)
July 11, 2012 1:46 PM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 6276

Join Date: September 1, 2006

Recent Posts

If you run it under eclipse you can use the profiling tools...
Peter Hellstrand
RE: The portal is slow (very few users)
July 11, 2012 10:26 PM
Answer

Peter Hellstrand

Rank: Regular Member

Posts: 167

Join Date: November 30, 2011

Recent Posts

Thank you as usual david. You mean on my local liferay portal?

I installed VisualVM and it looks like nothing strange as I can see. Maybe a network problem.


image host
David H Nebinger
RE: The portal is slow (very few users)
July 11, 2012 2:37 PM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 6276

Join Date: September 1, 2006

Recent Posts

Is the snapshot taken during the slow period, or are you saying it is consistently slow?
Hitoshi Ozawa
RE: The portal is slow (very few users)
July 11, 2012 3:08 PM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7990

Join Date: March 23, 2010

Recent Posts

If you are having performance issue while uploading file or creating web content (do you mean when saving web content?), it may be an issue with network or your database.

Check if performance slows down while other is uploading a file or if it's just slow to upload your file.
Peter Hellstrand
RE: The portal is slow (very few users)
July 11, 2012 10:25 PM
Answer

Peter Hellstrand

Rank: Regular Member

Posts: 167

Join Date: November 30, 2011

Recent Posts

Thank you. I have to investigate this further beacuse the slow periods is very rare and did not happend to me during the 30+min I was clicking around. The snapshot is not during a slow period.
Peter Hellstrand
RE: The portal is slow (very few users)
July 11, 2012 10:32 PM
Answer

Peter Hellstrand

Rank: Regular Member

Posts: 167

Join Date: November 30, 2011

Recent Posts

This is how our customer describes it.

"When it comes to performance, I have sometimes experienced this when I go between pages or open an editor such as when I am editing an article."
Hitoshi Ozawa
RE: The portal is slow (very few users)
July 12, 2012 6:23 AM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7990

Join Date: March 23, 2010

Recent Posts

The editor performance is probably javascript download time as it oftens happens here on liferay.com
OR
it just may be that your customer is running something else while viewing or editing a page.
Peter Hellstrand
RE: The portal is slow (very few users)
July 12, 2012 7:25 AM
Answer

Peter Hellstrand

Rank: Regular Member

Posts: 167

Join Date: November 30, 2011

Recent Posts

I put this in portal-ext.properties. Hopes it help.


last.modified.check=false
theme.css.fast.load=true
javascript.fast.load=true
Linus Sphinx
RE: The portal is slow (very few users)
July 12, 2012 10:42 AM
Answer

Linus Sphinx

Rank: Junior Member

Posts: 84

Join Date: August 12, 2010

Recent Posts

I have found this quite helpful in similar situations;
http://httpd.apache.org/docs/2.0/programs/ab.html
God speed and good luck.