Forums

Home » Alloy UI » English

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Nithin KV
Hooks is not getting Deployed in Staging Server
July 30, 2012 7:38 AM
Answer

Nithin KV

Rank: New Member

Posts: 20

Join Date: July 23, 2012

Recent Posts

Hi,

I have modified Image Gallery using Hooks in Liferay 5.2. I am using Netbeans and Glassfish 2.1. When i Deploy the hook in my local server , changes to the jsp's are getting reflected. But when i deploy it in my staging server, none of the changes are getting reflected and it is not displaying any error in the Server Logs. Is there any problem with the hook Deployment ?.. Does it need to be deployed in any other way?? .. I am not able to figure out the exact reason. Kindly provide me the solution if you got any.. emoticon
David H Nebinger
RE: Hooks is not getting Deployed in Staging Server
July 30, 2012 7:48 AM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 6527

Join Date: September 1, 2006

Recent Posts

Sure, give me access to your staging system and I'll log in and check it out...

Seriously, there's absolutely no info here that would allow anyone to help you. Is there anything in the server logs to indicate the hook deployed? Did it fail in some way? How different is the staging system from your local system? Do you have things deployed locally that are not in staging? Are you using the same database for both environments? What about differences in portal-ext.properties?
Nishikant sapkal
RE: Hooks is not getting Deployed in Staging Server
July 31, 2012 12:04 AM
Answer

Nishikant sapkal

Rank: Junior Member

Posts: 71

Join Date: February 15, 2010

Recent Posts

Nithin KV:
Hi,

I have modified Image Gallery using Hooks in Liferay 5.2. I am using Netbeans and Glassfish 2.1. When i Deploy the hook in my local server , changes to the jsp's are getting reflected. But when i deploy it in my staging server, none of the changes are getting reflected and it is not displaying any error in the Server Logs. Is there any problem with the hook Deployment ?.. Does it need to be deployed in any other way?? .. I am not able to figure out the exact reason. Kindly provide me the solution if you got any.. emoticon


If you are hooking changes are only in jsp , you can follow the below approach to track whether hook is deployed properly -

If you have made changes in view.jsp of image gallery portlet.
1} go to the location $tomcat_home\webapps\ROOT\html\portlet\image_gallery
2} See if there is file created with the name view.portal.jsp
3} Open file view.jsp and check if your changes are there?
Nithin KV
RE: Hooks is not getting Deployed in Staging Server
August 1, 2012 2:50 AM
Answer

Nithin KV

Rank: New Member

Posts: 20

Join Date: July 23, 2012

Recent Posts

Hi I have Checked the Path that you mentioned in my staging server and there are no *.portal.jsp files getting created in the folder path /html/portlet/image_gallery.. But in my local Server all the *.portal.jsp files are getting created. what are the files i should check in my staging server so that hook will get deployed in staging server like how it is getting deployed in my local server.
Nishikant sapkal
RE: Hooks is not getting Deployed in Staging Server
August 2, 2012 4:29 AM
Answer

Nishikant sapkal

Rank: Junior Member

Posts: 71

Join Date: February 15, 2010

Recent Posts

Nithin KV:
Hi I have Checked the Path that you mentioned in my staging server and there are no *.portal.jsp files getting created in the folder path /html/portlet/image_gallery.. But in my local Server all the *.portal.jsp files are getting created. what are the files i should check in my staging server so that hook will get deployed in staging server like how it is getting deployed in my local server.



Just copy the $tomcat_home\webapps\ROOT\html\portlet\image_gallery from your local server to staging server and restart your web server. emoticon