Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Venkata Harish Tallam
Getting errors while evaluating Liferay EE 6.1
September 7, 2012 5:17 AM
Answer

Venkata Harish Tallam

Rank: New Member

Posts: 4

Join Date: September 5, 2012

Recent Posts

Hi All,

We are trying to evaluate LifeRay EE 6.1.20.ga2 with JBoss Enterprise Edition (7.1.2).

I have configured LifeRay dependency jars as and other configurations which is mentioned in the below link

http://www.liferay.com/documentation/liferay-portal/6.1/user-guide/-/ai/lp-6-1-ugen11-installing-liferay-on-jboss-7-0

I have downloaded liferay dependency jars from the following link

http://www.liferay.com/downloads/liferay-portal/additional-files.

But when I try to deploy Enterprise Edition ROOT war, it is deploying with the following errors.

izer' for service type 'org.xmlpull.v1.XmlPullParserFactory'
15:17:33,299 INFO [org.jboss.as.osgi] (MSC service thread 1-6) JBAS011907: Register module: Module "deployment.ROOT.war:main" from Service Module Loader
15:17:35,946 ERROR [org.apache.catalina.core.StandardContext] (MSC service thread 1-2) Error listenerStart
15:17:35,946 ERROR [org.apache.catalina.core.StandardContext] (MSC service thread 1-2) Context [] startup failed due to previous errors
15:17:35,976 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-2) MSC000001: Failed to start service jboss.web.deployment.default-host./: org.jboss.msc.service.StartException in service jboss.web.deployment.default-host./: JBAS018040: Failed to start context
at org.jboss.as.web.deployment.WebDeploymentService.start(WebDeploymentService.java:95)
at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA-redhat-1.jar:1.0.2.GA-redhat-1]
at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA-redhat-1.jar:1.0.2.GA-redhat-1]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.6.0_22]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.6.0_22]
at java.lang.Thread.run(Thread.java:679) [rt.jar:1.6.0_22]

15:17:36,219 INFO [org.jboss.as.server] (ServerService Thread Pool -- 28) JBAS018559: Deployed "ROOT.war"
15:17:36,220 INFO [org.jboss.as.server] (ServerService Thread Pool -- 28) JBAS018559: Deployed "services.ear"
15:17:36,223 INFO [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report
JBAS014777: Services which failed to start: service jboss.web.deployment.default-host./: org.jboss.msc.service.StartException in service jboss.web.deployment.default-host./: JBAS018040: Failed to start context

15:17:36,242 INFO [org.jboss.as] (Controller Boot Thread) JBAS015951: Admin console listening on http://192.168.2.19:9990
15:17:36,242 ERROR [org.jboss.as] (Controller Boot Thread) JBAS015875: JBoss EAP 6.0.0.GA (AS 7.1.2.Final-redhat-1) started (with errors) in 58151ms - Started 1889 of 2005 services (2 services failed or missing dependencies, 112 services are passive or on-demand)



Using the same configuration, I'm able to deploy liferay community edition ROOT war without any errors and problems.


Plz help me out regarding this
Davy Kamerbeek
RE: Getting errors while evaluating Liferay EE 6.1
September 7, 2012 12:13 PM
Answer

Davy Kamerbeek

Rank: New Member

Posts: 23

Join Date: March 12, 2012

Recent Posts

The Liferay 6.1.20 EE GA2 release is 'broken' in different ways:

  1. the default update managing (in control panel) function won't work (can't upload portlets). You have to install the private plugin installer
  2. the dependencies that you can download from the site are actually from the CE version see here

We're trying to do same as you but we use Weblogic 10.3.6 with Liferay 6.1.20 EE GA2. There are additional issues with weblogic, see here and here

Hope this helps.
Venkata Harish Tallam
RE: Getting errors while evaluating Liferay EE 6.1
September 8, 2012 12:50 AM
Answer

Venkata Harish Tallam

Rank: New Member

Posts: 4

Join Date: September 5, 2012

Recent Posts

Hi Davy,

Thnx for the reply.

Now, I have copied LifeRay EE dependency jars.

Now getting following errors.


10:36:25,728 INFO (MSC service thread 1-1) 10:36:25,727 INFO [MSC service thread 1-1][DialectDetector:136] Found dialect org.hibernate.dialect.HSQLDialect
10:36:32,469 ERROR [org.apache.catalina.core.StandardContext] (MSC service thread 1-1) Error listenerStart
10:36:32,469 ERROR [org.apache.catalina.core.StandardContext] (MSC service thread 1-1) Context [] startup failed due to previous errors
10:36:32,481 INFO (MSC service thread 1-1) 10:36:32,479 ERROR [MSC service thread 1-1][PortalContextLoaderListener:107] java.lang.NullPointerException
10:36:32,482 INFO (MSC service thread 1-1) java.lang.NullPointerException
10:36:32,482 INFO (MSC service thread 1-1) at com.liferay.portal.kernel.servlet.DirectServletRegistryUtil.clearServlets(DirectServletRegistryUtil.java:27)
10:36:32,482 INFO (MSC service thread 1-1) at com.liferay.portal.spring.context.PortalContextLoaderListener.contextDestroyed(PortalContextLoaderListener.java:104)
10:36:32,482 INFO (MSC service thread 1-1) at org.apache.catalina.core.StandardContext.listenerStop(StandardContext.java:3489)
10:36:32,482 INFO (MSC service thread 1-1) at org.apache.catalina.core.StandardContext.stop(StandardContext.java:3999)
10:36:32,483 INFO (MSC service thread 1-1) at org.apache.catalina.core.StandardContext.start(StandardContext.java:3917)
10:36:32,483 INFO (MSC service thread 1-1) at org.jboss.as.web.deployment.WebDeploymentService.start(WebDeploymentService.java:90)
10:36:32,483 INFO (MSC service thread 1-1) at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811)
10:36:32,483 INFO (MSC service thread 1-1) at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746)
10:36:32,483 INFO (MSC service thread 1-1) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
10:36:32,484 INFO (MSC service thread 1-1) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
10:36:32,484 INFO (MSC service thread 1-1) at java.lang.Thread.run(Thread.java:679)
10:36:32,506 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-1) MSC000001: Failed to start service jboss.web.deployment.default-host./: org.jboss.msc.service.StartException in service jboss.web.deployment.default-host./: JBAS018040: Failed to start context
at org.jboss.as.web.deployment.WebDeploymentService.start(WebDeploymentService.java:95)

at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA-redhat-1.jar:1.0.2.GA-redhat-1]
at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA-redhat-1.jar:1.0.2.GA-redhat-1]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.6.0_22]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.6.0_22]
at java.lang.Thread.run(Thread.java:679) [rt.jar:1.6.0_22]

10:36:32,748 INFO [org.jboss.as.server] (ServerService Thread Pool -- 28) JBAS018559: Deployed "ROOT.war"
10:36:32,749 INFO [org.jboss.as.server] (ServerService Thread Pool -- 28) JBAS018559: Deployed "order-ear-0.0.2-SNAPSHOT.ear"
10:36:32,750 INFO [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report
JBAS014777: Services which failed to start: service jboss.web.deployment.default-host./: org.jboss.msc.service.StartException in service jboss.web.deployment.default-host./: JBAS018040: Failed to start context

10:36:32,772 INFO [org.jboss.as] (Controller Boot Thread) JBAS015951: Admin console listening on http://192.168.2.19:9990
10:36:32,772 ERROR [org.jboss.as] (Controller Boot Thread) JBAS015875: JBoss EAP 6.0.0.GA (AS 7.1.2.Final-redhat-1) started (with errors) in 74601ms - Started 1889 of 2005 services (2 services failed or missing dependencies, 112 services are passive or on-demand)
Venkata Harish Tallam
RE: Getting errors while evaluating Liferay EE 6.1
September 8, 2012 1:13 AM
Answer

Venkata Harish Tallam

Rank: New Member

Posts: 4

Join Date: September 5, 2012

Recent Posts

I have copied following liferay ee dependency jars into modules,

1. hsql.jar
2. portal-service.jar
3. portlet.jar
Davy Kamerbeek
RE: Getting errors while evaluating Liferay EE 6.1
September 8, 2012 2:48 AM
Answer

Davy Kamerbeek

Rank: New Member

Posts: 23

Join Date: March 12, 2012

Recent Posts

The logging suggests that it's missing 2 dependencies. Do you know for sure that all the (correct) dependencies are in place? In particular the JBOSS specific libraries?

Don't waste you're time with the EE 6.1.20 version if the CE version works correctly out of the box. The EE is still too buggy. We're getting EE support for this problem. When i get some anwsers i will let you know.
Hitoshi Ozawa
RE: Getting errors while evaluating Liferay EE 6.1
September 8, 2012 7:00 AM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7952

Join Date: March 23, 2010

Recent Posts

JBoss 7.0.x and JBoss 7.1.x is different. GA1 is using 7.0.x and GA2 is using 7.1.x. I think the documents are updated for the most recent releases yet.
Venkata Harish Tallam
RE: Getting errors while evaluating Liferay EE 6.1
September 9, 2012 10:46 PM
Answer

Venkata Harish Tallam

Rank: New Member

Posts: 4

Join Date: September 5, 2012

Recent Posts

I'm using GA2 with JBoss 7.1.2 EE
devaraj s
RE: Getting errors while evaluating Liferay EE 6.1
October 12, 2012 6:40 AM
Answer

devaraj s

Rank: Regular Member

Posts: 207

Join Date: May 21, 2012

Recent Posts

Hi,
I am trying to install liferay 6.1 ce ga2 in existing jboss -7.1.1.final version but getting error in console is,

ERROR [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 1) {"JBAS014653: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-2" => {"JBAS014671: Failed services" => {"jboss.web.deployment.default-host./" => "org.jboss.msc.service.StartException in service jboss.web.deployment.default-host./: JBAS018040: Failed to start context"}}}}



Not able to find out the error plz help me in this case..


Thanks in advance
Koen Vermeulen
RE: Getting errors while evaluating Liferay EE 6.1
February 14, 2013 6:08 AM
Answer

Koen Vermeulen

Rank: New Member

Posts: 13

Join Date: February 16, 2010

Recent Posts

Does this mean that noone ever could try the new 30day trial EE edition (6.1 EE GA2), because the dependancy jars for EE cannot be find on liferay.com??

The error you get when you use the CE dependancies together with EE is:

java.lang.IllegalStateException: Attempting to deploy an older Liferay Portal version.
Current build version is 6110 and attempting to deploy version 6101
Hitoshi Ozawa
RE: Getting errors while evaluating Liferay EE 6.1
February 14, 2013 1:31 PM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7952

Join Date: March 23, 2010

Recent Posts

That just because CE and EE have different version numbers. Can't use CE on EE. Best to contact sales@liferay.com to get EE dependencies. I think similar issue has come up when using EE trial and sales@liferay.com was able to provide assistance.

Sorry, but we can't distribute EE stuffs here.
Mika Koivisto
RE: Getting errors while evaluating Liferay EE 6.1
February 14, 2013 2:00 PM
Answer

Mika Koivisto

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1505

Join Date: August 7, 2006

Recent Posts

Please contact Liferay Sales they will be able to help you find what you need. You can find contact details to your area sales team from contact us page.
Koen Vermeulen
RE: Getting errors while evaluating Liferay EE 6.1
February 20, 2013 2:29 AM
Answer

Koen Vermeulen

Rank: New Member

Posts: 13

Join Date: February 16, 2010

Recent Posts

Thank you very much for your help.
An email is sent to Sales.
I keep you informed about their reply.
Anil T
RE: Getting errors while evaluating Liferay EE 6.1
June 26, 2014 9:13 AM
Answer

Anil T

Rank: Regular Member

Posts: 234

Join Date: January 14, 2012

Recent Posts

Hi,

We have also facing the same issue with the jboss server. Do anyone has solution for this issue ? we are using Liferay 6.2 CE version.

Thanks,
Anil T
Arun R S Chandran
RE: Getting errors while evaluating Liferay EE 6.1
September 3, 2014 7:14 PM
Answer

Arun R S Chandran

Rank: Junior Member

Posts: 88

Join Date: March 12, 2013

Recent Posts

Hi All,
Does anyone fixed this issue? I'm facing the same issue now. Can anyone help me for it?
Olaf Kock
RE: Getting errors while evaluating Liferay EE 6.1
September 4, 2014 7:57 AM
Answer

Olaf Kock

LIFERAY STAFF

Rank: Liferay Legend

Posts: 2225

Join Date: September 23, 2008

Recent Posts

You're probably not evaluating Liferay EE 6.1, right? You might get more attention if you post a new thread with an appropriate title and the description of the error message that you see. Don't forget to add the version numbers (Liferay, JBoss) and what you did until the error message stopped you.

This thread is already long, gives many different descriptions and just stating that you have "the same" issue as someone two years ago doesn't really help. Please make it easier for us to help you by providing all information together, with a proper headline.