Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Miguel Ángel Júlvez
Liferay 6.1 CE GA1 on JBoss 7.1.1.Final
June 27, 2012 12:45 AM
Answer

Miguel Ángel Júlvez

Rank: Junior Member

Posts: 56

Join Date: March 29, 2011

Recent Posts

Hi all!

When I deploy liferay war on JBoss 7.1.1.Final everything seems to work fine but I get these logs warnings every time:

09:28:34,815 WARN [org.quartz.simpl.PropertySettingJobFactory] (MemoryQuartzSchedulerEngineInstance_QuartzSchedulerThread) No setter on Job class com.liferay.portal.scheduler.job.MessageSenderJob for property 'MESSAGE'
09:28:34,815 WARN [org.quartz.simpl.PropertySettingJobFactory] (MemoryQuartzSchedulerEngineInstance_QuartzSchedulerThread) No setter on Job class com.liferay.portal.scheduler.job.MessageSenderJob for property 'STORAGE_TYPE'
09:28:34,816 WARN [org.quartz.simpl.PropertySettingJobFactory] (MemoryQuartzSchedulerEngineInstance_QuartzSchedulerThread) No setter on Job class com.liferay.portal.scheduler.job.MessageSenderJob for property 'DESCRIPTION'
09:28:34,816 WARN [org.quartz.simpl.PropertySettingJobFactory] (MemoryQuartzSchedulerEngineInstance_QuartzSchedulerThread) No setter on Job class com.liferay.portal.scheduler.job.MessageSenderJob for property 'DESTINATION_NAME'
09:28:34,817 WARN [org.quartz.simpl.PropertySettingJobFactory] (MemoryQuartzSchedulerEngineInstance_QuartzSchedulerThread) No setter on Job class com.liferay.portal.scheduler.job.MessageSenderJob for property 'JOB_STATE'

Any idea?

Thanks!
Hitoshi Ozawa
RE: Liferay 6.1 CE GA1 on JBoss 7.1.1.Final
June 30, 2012 10:22 PM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7954

Join Date: March 23, 2010

Recent Posts

Probably because org.quartz.scheduler.jobFactory.class is not set in quartz.properties and default to using org.quartz.simpl.PropertySettingJobFactory.
evan ni
RE: Liferay 6.1 CE GA1 on JBoss 7.1.1.Final
July 3, 2012 10:33 PM
Answer

evan ni

Rank: New Member

Posts: 2

Join Date: December 27, 2010

Recent Posts

I am using tomcat also encounter this problem

I can't find quartz.properties in any place.

How to deal with this problem?

thanks
Manuel Pinto
RE: Liferay 6.1 CE GA1 on JBoss 7.1.1.Final
August 20, 2012 10:37 AM
Answer

Manuel Pinto

Rank: New Member

Posts: 4

Join Date: August 20, 2012

Recent Posts

I am using liferay 6.1 CE GA2 bundled with JBoss and also found this problem.

Any Idea?

Thanks
Marco Dussin
RE: Liferay 6.1 CE GA1 on JBoss 7.1.1.Final
September 28, 2012 3:38 AM
Answer

Marco Dussin

Rank: Junior Member

Posts: 41

Join Date: July 6, 2010

Recent Posts

I've that problem too (LR 6.1.0 ce-ga1, Jboss 7)

Any help wiil be appreciated

Thanks a lot

Marco
Ondřej Životský
RE: Liferay 6.1 CE GA1 on JBoss 7.1.1.Final
October 1, 2012 12:18 AM
Answer

Ondřej Životský

Rank: Junior Member

Posts: 28

Join Date: March 11, 2011

Recent Posts

Liferay store some important informations (MESSAGE, DESCRIPTION, JOB_STATE, ...) to JobDataMap in QuartzSchedulerEngine class. But org.quartz.simpl.PropertySettingJobFactory expects only fields in this map.
If you don't want to see this warnings, set log level for class org.quartz.simpl.PropertySettingJobFactory to ERROR level.
James Falkner
RE: Liferay 6.1 CE GA1 on JBoss 7.1.1.Final
October 1, 2012 8:28 AM
Answer

James Falkner

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1222

Join Date: September 17, 2010

Recent Posts

Ondřej Životský:
Liferay store some important informations (MESSAGE, DESCRIPTION, JOB_STATE, ...) to JobDataMap in QuartzSchedulerEngine class. But org.quartz.simpl.PropertySettingJobFactory expects only fields in this map.
If you don't want to see this warnings, set log level for class org.quartz.simpl.PropertySettingJobFactory to ERROR level.


I believe this is a result of Liferay not configuring the logging level properly - you can see in Control Panel that the log level for org.quartz set to ERROR yet INFO and WARNs are getting through. This does not happen on the Tomcat bundles. I suspect there is an issue with the fix for LPS-27399. IF you set the log level to ERROR through JBoss' recommended log configuration mechanism (I don't have the details but you can search for them) and this eliminates the WARNs I will re-open the bug for you to add details!
Marco Dussin
RE: Liferay 6.1 CE GA1 on JBoss 7.1.1.Final
October 2, 2012 1:28 AM
Answer

Marco Dussin

Rank: Junior Member

Posts: 41

Join Date: July 6, 2010

Recent Posts

JBoss users must consider also this issue if the configuration page for log levels is missing.

Marco
Marco Dussin
RE: Liferay 6.1 CE GA1 on JBoss 7.1.1.Final
October 2, 2012 3:11 AM
Answer

Marco Dussin

Rank: Junior Member

Posts: 41

Join Date: July 6, 2010

Recent Posts

I've still the error using CE GA1, also after setting portal-log4j-ext.xml as
1<?xml version="1.0"?>
2<!DOCTYPE log4j:configuration SYSTEM "log4j.dtd">
3<log4j:configuration xmlns:log4j="http://jakarta.apache.org/log4j/">
4<category name="org.quartz.simpl.PropertySettingJobFactory">
5<priority value="ERROR" />
6</category>
7</log4j:configuration>



Marco
Igor Spasić
RE: Liferay 6.1 CE GA1 on JBoss 7.1.1.Final
October 19, 2012 5:02 AM
Answer

Igor Spasić

LIFERAY STAFF

Rank: New Member

Posts: 10

Join Date: April 26, 2010

Recent Posts

try this: open standalone.xml and set the logging level. For example:
1
2    <profile>
3        <subsystem xmlns="urn:jboss:domain:logging:1.1">
4....
5            <logger category="org.quartz">
6                <level name="ERROR"/>
7            </logger>
8...


source:
http://www.liferay.com/community/wiki/-/wiki/Main/JBoss+AS7+tips#section-JBoss+AS7+tips-Setting+log+level