Combination View Flat View Tree View
Threads [ Previous | Next ]
Tom Picklesimer
Unable to install marketplace plugins
October 3, 2012 2:47 PM
Answer

Tom Picklesimer

Rank: New Member

Posts: 24

Join Date: June 15, 2012

Recent Posts

Hello all,
I've been trying to download/install marketplace plugins (I've tried several) for the last few days and am unable to. I "purchase" the plug in, then go to the purchased page and click download, and it says please wait... I wait, and wait, and wait, and it never downloads/installs. Any ideas?

I'm using Liferay 6.1.1 CE and Tomcat 7.

Thanks,

Tom
Tom Picklesimer
RE: Unable to install marketplace plugins
October 4, 2012 10:02 AM
Answer

Tom Picklesimer

Rank: New Member

Posts: 24

Join Date: June 15, 2012

Recent Posts

Can anybody offer any advice on my problem here? I'm stuck and could really use some help!

Thanks,

Tom
Mika Koivisto
RE: Unable to install marketplace plugins
October 4, 2012 10:58 AM
Answer

Mika Koivisto

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1501

Join Date: August 7, 2006

Recent Posts

Can your server make requests to internet? You can test it with RSS feeds portlet and see if can fetch a feed.
Tom Picklesimer
RE: Unable to install marketplace plugins
October 4, 2012 11:29 AM
Answer

Tom Picklesimer

Rank: New Member

Posts: 24

Join Date: June 15, 2012

Recent Posts

Well I feel like a huge idiot... never thought my IT department had the server locked out from the outside world! Oy. Needless to say, no, I can't make requests to the Internet!

Do you know how I go about installing plugins manually on 6.1.1 with tomcat 7?

Thanks for your help!

Tom
Mika Koivisto
RE: Unable to install marketplace plugins
October 4, 2012 2:46 PM
Answer

Mika Koivisto

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1501

Join Date: August 7, 2006

Recent Posts

That's pretty common practice that's why I asked. Most environment I've worked with had a proxy server that allow http access. You can also download the install package if you go to Marketplace here on Liferay.com and then from left side menu click purchased. That'll list all the plugins you've "purchased" and you can download them. Then you can just drop them to your Liferay installations Liferay auto deploy folder.
Hitoshi Ozawa
RE: Unable to install marketplace plugins
October 4, 2012 3:52 PM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7954

Join Date: March 23, 2010

Recent Posts

Most environment I've worked with had a proxy server that allow http access.


Most of our servers are intranet servers and behind a firewall without any outside access. Have to have virus check and security/performance check with workflow approvals before installing anything on the server. It may be because we'll using liferay differently.

Unfortunately for me, Marketplace is just making plugin installation more difficult then it used to be. It would be better if I can at least download plugins easily as I used to be able to from sourceforge and community plugin site.

That said, I'm sure that people having Internet access from their servers are gaining advantages from Marketplace so I'm just speaking personally on my conditions.
Tom Picklesimer
RE: Unable to install marketplace plugins
October 4, 2012 3:52 PM
Answer

Tom Picklesimer

Rank: New Member

Posts: 24

Join Date: June 15, 2012

Recent Posts

Where is my auto deploy folder? Is it generally in the root of the Liferay install? I don't see a deploy directory anywhere...

Sorry for all the questions, I just really want to get these plugins installed.

Thanks,

Tom
Hitoshi Ozawa
RE: Unable to install marketplace plugins
October 4, 2012 9:23 PM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7954

Join Date: March 23, 2010

Recent Posts

If you're using Liferay tomcat bundle, the deploy directory should be created under liferay-portal-6.1.1-ce-ga2 directory. Just copy the plugin file into the deploy directory while liferay is running and it will deploy it to tomcat.
Tom Picklesimer
RE: Unable to install marketplace plugins
October 5, 2012 8:52 AM
Answer

Tom Picklesimer

Rank: New Member

Posts: 24

Join Date: June 15, 2012

Recent Posts

Ok thanks for the pointer. However, I didn't have a deploy directory under my liferay-portal-6.1.1-ce directory so I created a deploy directory and moved the file I wanted deployed into it and nothing happened. Tried rebooting the server and it still didn't do anything. Am I doing something wrong?
Hitoshi Ozawa
RE: Unable to install marketplace plugins
October 6, 2012 3:48 AM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7954

Join Date: March 23, 2010

Recent Posts

Shouldn't need to create a deploy folder. It should have been created when you started up liferay. Are you sure your liferay is working properly?
Tom Picklesimer
RE: Unable to install marketplace plugins
October 10, 2012 11:24 AM
Answer

Tom Picklesimer

Rank: New Member

Posts: 24

Join Date: June 15, 2012

Recent Posts

Thanks everybody for the help, I finally figured it out... for some reason the deploy directory is in the directory above my liferay install in the repo folder... go figure. The IT guy that set it up did it that way for some reason.
Tom Picklesimer
RE: Unable to install marketplace plugins
October 10, 2012 4:52 PM
Answer

Tom Picklesimer

Rank: New Member

Posts: 24

Join Date: June 15, 2012

Recent Posts

Correction: I found the deploy directory but when I drop plugins in there and restart the server, nothing is deployed/installed.
I've noticed that when I drop a file in there, it will disappear after a few seconds, but nothing seems to change even after I reboot the server.

Am I doing something wrong? As I said, my deploy directory is in the directory above the liferay main directory. I've attached my server log in case that might be helpful.

Thanks in advance,

Tom
Attachments: liferay.2012-10-10.log (110.2k)
Hitoshi Ozawa
RE: Unable to install marketplace plugins
October 10, 2012 4:49 PM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7954

Join Date: March 23, 2010

Recent Posts

Try copying the plugin to the deploy directory when liferay is running. There should be some messages displayed in the console. It's also possible to copy the plugin and then startup the server but you'll get liferay's server's startup messages with the plugin deploy message.

The most common error is when EE version of the plugin is deployed to liferay CE version or vice versa. This will result in an error and some error messages should be displayed.
Tom Picklesimer
RE: Unable to install marketplace plugins
October 11, 2012 8:09 AM
Answer

Tom Picklesimer

Rank: New Member

Posts: 24

Join Date: June 15, 2012

Recent Posts

According to the log I posted, I don't see any errors (as far as I can tell). I tried deploying it while the server was running and the log below is what I got. Nothing shows up in the plugin installer section like it says it's supposed to for the private plugin installer.

-------------------------------------------------

15:11:01,800 INFO [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][AutoDeployDir:177] Processing 15474932_15997511_15998278(1).lpkg
15:11:01,813 INFO [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][LiferayPackageAutoDeployListener:48] Extracting Liferay package for /srv/repo/deploy/15474932_15997511_15998278(1).lpkg
15:11:01,831 INFO [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][LiferayPackageAutoDeployer:88] Extracting private-plugin-installer-hook-6.1.1.1-ce-ga2-20120808165352698.war from 15474932_15997511_15998278(1).lpkg
15:11:01,843 INFO [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][LiferayPackageAutoDeployer:88] Extracting liferay-marketplace.properties from 15474932_15997511_15998278(1).lpkg
15:11:01,844 INFO [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][LiferayPackageAutoDeployListener:54] Liferay package for /srv/repo/deploy/15474932_15997511_15998278(1).lpkg extracted successfully. Deployment will start in a few seconds.
15:11:04,845 INFO [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][AutoDeployDir:177] Processing private-plugin-installer-hook-6.1.1.1-ce-ga2-20120808165352698.war
15:11:04,846 INFO [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][HookAutoDeployListener:48] Copying hook plugin for /srv/repo/deploy/private-plugin-installer-hook-6.1.1.1-ce-ga2-20120808165352698.war
15:11:04,847 INFO [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][BaseDeployer:763] Deploying private-plugin-installer-hook-6.1.1.1-ce-ga2-20120808165352698.war
15:11:06,855 WARN [http-bio-8080-exec-10][ThemeLocalServiceImpl:149] No theme found for specified theme id liferayjedi_WAR_cg52theme. Returning the default theme.
15:11:08,079 INFO [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][BaseDeployer:859] Updating Private Plugin Installer from version 6.1.1.1-ce-ga2-20120808165352698 to version 6.1.1.1-ce-ga2-20120808165352698
15:11:09,459 INFO [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][BaseDeployer:2083] Modifying Servlet 2.4 /srv/liferay-6.1.1-ce/tomcat-7.0.27/temp/20121011151108122/WEB-INF/web.xml
15:11:09,770 INFO [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][HookAutoDeployListener:54] Hook for /srv/repo/deploy/private-plugin-installer-hook-6.1.1.1-ce-ga2-20120808165352698.war copied successfully. Deployment will start in a few seconds.
15:11:11,965 WARN [http-bio-8080-exec-12][ThemeLocalServiceImpl:149] No theme found for specified theme id liferayjedi_WAR_cg52theme. Returning the default theme.
15:11:17,075 WARN [http-bio-8080-exec-6][ThemeLocalServiceImpl:149] No theme found for specified theme id liferayjedi_WAR_cg52theme. Returning the default theme.
Hitoshi Ozawa
RE: Unable to install marketplace plugins
October 11, 2012 3:57 PM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7954

Join Date: March 23, 2010

Recent Posts

There's no other message after that? It's finding the plugin and trying to deploy it so it's not the location of the deploy directory.
Tom Picklesimer
RE: Unable to install marketplace plugins
October 15, 2012 9:41 AM
Answer

Tom Picklesimer

Rank: New Member

Posts: 24

Join Date: June 15, 2012

Recent Posts

Nope, no other message after that... that was the end of the log file for that day. Any ideas?

Thanks,

Tom
Hitoshi Ozawa
RE: Unable to install marketplace plugins
October 15, 2012 3:44 PM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7954

Join Date: March 23, 2010

Recent Posts

There isn't anything in the webapps directory? Check your list of plugins from Control Panel to see if it's there or not.
Tom Picklesimer
RE: Unable to install marketplace plugins
October 16, 2012 8:49 AM
Answer

Tom Picklesimer

Rank: New Member

Posts: 24

Join Date: June 15, 2012

Recent Posts

Nope, there isn't anything in the webapps directory. HOWEVER, I stumbled upon something curious: in my home directory on the server, there is a webapps directory that has two folders in it for server manager plugin and private plugins installer. Why are they being installed there? How do I correct that? They aren't showing up in the control panel list of plugins because they aren't actually being installed I'm guessing... since they are going in a completely wrong directory.

Thanks,

Tom
Hitoshi Ozawa
RE: Unable to install marketplace plugins
October 18, 2012 5:49 PM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7954

Join Date: March 23, 2010

Recent Posts

Seems your liferay isn't properly installed. Check your portal-ext.properties. There's probably some properties setting the directory.