Forums

Home » Liferay Portal » English » 2. Using Liferay » General

Combination View Flat View Tree View
Threads [ Previous | Next ]
Sara M
Liferay 6.1 - add entry blog button doesn't work
February 8, 2012 3:13 AM
Answer

Sara M

Rank: New Member

Posts: 7

Join Date: February 8, 2012

Recent Posts

Hi everybody,

I have some problem trying to add a new entry blog in a portal page. If I access from local browser the problem doesn't appear, but if I use a remote pc to get the portal page the button doesn't do anything.

This is the button html code that I can see from the browser:

<input class="aui-button-input" id="_33_addEntryButton" onClick="location.href = location.href.replace(location.hash, ´´);" type='button' value="Add Blog Entry" />

Does anybody know why it is happening?

Thanks in advance.
H Sparks
RE: Liferay 6.1 - add entry blog button doesn't work
February 9, 2012 11:09 AM
Answer

H Sparks

Rank: New Member

Posts: 3

Join Date: January 30, 2012

Recent Posts

Are you getting a JS error similar to what I'm getting?

http://www.liferay.com/community/forums/-/message_boards/message/12441922

If so, I hope someone addresses it.
Cyril Barillet
RE: Liferay 6.1 - add entry blog button doesn't work
July 15, 2012 8:52 PM
Answer

Cyril Barillet

Rank: New Member

Posts: 4

Join Date: February 28, 2011

Recent Posts

Hi.

I have the same problem: the blog's "add button" doesn't work with Liferay 6.1
I haven't any javascript error.
I test with IE9 and Chrome 20.0.1132.57.

Does anyone tell if it's a bug ?

Best regards.
Tiur LG //Softbless
RE: Liferay 6.1 - add entry blog button doesn't work
October 6, 2012 10:01 PM
Answer

Tiur LG //Softbless

Rank: New Member

Posts: 7

Join Date: June 11, 2010

Recent Posts

I had same problem. How do you access remotely? By IP Address or by domain name?

If it's IP address you could add these lines to portal-ext.properties

The sample below, if you're using IP address

 1
 2#redirect.url.security.mode=domain
 3redirect.url.security.mode=ip
 4
 5#
 6# Input a list of comma delimited domains which the portal is allowed to
 7# redirect to. Input a blank list to allow any domain.
 8#
 9redirect.url.domains.allowed=
10
11#
12# Input a list of comma delimited IPs which the portal is allowed to
13# redirect to. Input a blank list to allow any IP. SERVER_IP will be
14# replaced with the IP of the host server.
15#
16redirect.url.ips.allowed=127.0.0.1,put-ip-address-here
Hitoshi Ozawa
RE: Liferay 6.1 - add entry blog button doesn't work
October 7, 2012 5:41 AM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7990

Join Date: March 23, 2010

Recent Posts

Most actual web systems use domain names instead of ip address so it's actually better to set to use domain name:
redirect.url.security.mode=domain
#redirect.url.security.mode=ip
Cyril Barillet
RE: Liferay 6.1 - add entry blog button doesn't work
October 7, 2012 5:45 AM
Answer

Cyril Barillet

Rank: New Member

Posts: 4

Join Date: February 28, 2011

Recent Posts

I access remotely by domain name.

I fixed my problem:
1) I updated from 6.1 GA1 to 6.1 GA2.
2) I replaced the default virtual host name "localhost" by "portal.cyril-barillet.com".

It works fine now.