Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Paul Schmidt
Theme for private user page
October 26, 2012 4:25 AM
Answer

Paul Schmidt

Rank: Junior Member

Posts: 30

Join Date: July 28, 2010

Recent Posts

Hello community,

I created a page, set the theme and exported the configuration as lar file.

I added these entries to my portal-ext.properties:
1
2default.user.private.layouts.lar=${liferay.home}/default_private_userpage.lar
3default.user.private.layouts.enable=true
4default.user.public.layouts.enabled=false
5default.user.private.layout.regular.theme.id=mytheme_WAR_mytheme (it's the entry from layout table in Liferay database)


The I created a new user and logged in.

When I go to his private user page, I get an exeption:
1
2An unexpected system error occurred.
3 javax.servlet.jsp.JspException: org.apache.velocity.exception.MethodInvocationException: Invocation of method 'include' in class com.liferay.taglib.util.VelocityTaglib threw exception java.lang.NullPointerException at _SERVLET_CONTEXT_/html/themes/classic/templates/portal_normal.vm[line 83, column 8]


It seems, that the configured theme is not used.

I tried to export the lar with theme options checked and unchecked. No changes.
For every try, I created a new user.

What is wrong with my configuration.
Gaurav Jain
RE: Theme for private user page
October 26, 2012 5:27 AM
Answer

Gaurav Jain

Rank: Regular Member

Posts: 141

Join Date: January 31, 2011

Recent Posts

I used it for my portal. It was working fine.

However I didn't used following property:
default.user.private.layout.regular.theme.id=

Can you please try after commenting/removing this property ?
Paul Schmidt
RE: Theme for private user page
October 26, 2012 5:43 AM
Answer

Paul Schmidt

Rank: Junior Member

Posts: 30

Join Date: July 28, 2010

Recent Posts

I tried again two exports (with/out theme options) and two new users. Same result.
Gaurav Jain
RE: Theme for private user page
October 26, 2012 5:48 AM
Answer

Gaurav Jain

Rank: Regular Member

Posts: 141

Join Date: January 31, 2011

Recent Posts

Is the theme applied on user classic or your custom mytheme?
If your custom them - do you have certain conditions in your theme which is causing this exception? Maybe you can check this once.
Paul Schmidt
RE: Theme for private user page
October 26, 2012 5:50 AM
Answer

Paul Schmidt

Rank: Junior Member

Posts: 30

Join Date: July 28, 2010

Recent Posts

I want all new private userpages to have my custom theme.
The exeption thrown is not on my custom theme, because a vm file is referenced.

My theme is written in Freemarker (ftl)
Paul Schmidt
RE: Theme for private user page
October 29, 2012 12:26 AM
Answer

Paul Schmidt

Rank: Junior Member

Posts: 30

Join Date: July 28, 2010

Recent Posts

Does anybody else have a hint for me?
Florencia Gadea
RE: Theme for private user page
February 15, 2013 7:04 AM
Answer

Florencia Gadea

Rank: Regular Member

Posts: 159

Join Date: March 27, 2012

Recent Posts

Hi!

Did you ever find a solution to this? I'm facing the same issue...

Thanks,

Flor.
Paul Schmidt
RE: Theme for private user page
February 15, 2013 7:12 AM
Answer

Paul Schmidt

Rank: Junior Member

Posts: 30

Join Date: July 28, 2010

Recent Posts

Using a custom side template is working with the portal-ext.properties params.

The only unsolved issue is the theme problem.

Because of that we used another way to achieve our target.
We are using one public page and reading the required parameters from user object. Its a really dirty workaround because we need many custom fields and lots of processing overhead.
Florencia Gadea
RE: Theme for private user page
February 15, 2013 7:16 AM
Answer

Florencia Gadea

Rank: Regular Member

Posts: 159

Join Date: March 27, 2012

Recent Posts

What a pity... I have the theme problem too... and I can't use a public page.

Ok, thanks for sharing Paul.
Florencia Gadea
RE: Theme for private user page
February 15, 2013 7:55 AM
Answer

Florencia Gadea

Rank: Regular Member

Posts: 159

Join Date: March 27, 2012

Recent Posts

Hey, my problem got solved. I changed the name of the page, it had a dash on it.

Is it possible that this was the cause???
Paul Schmidt
RE: Theme for private user page
February 17, 2013 11:48 PM
Answer

Paul Schmidt

Rank: Junior Member

Posts: 30

Join Date: July 28, 2010

Recent Posts

Unfortunately not. My page was named "Home"
Florencia Gadea
RE: Theme for private user page
February 19, 2013 7:19 AM
Answer

Florencia Gadea

Rank: Regular Member

Posts: 159

Join Date: March 27, 2012

Recent Posts

One more test. Did you uncheck the 'hidden' checkbox? (if checked)
Paul Schmidt
RE: Theme for private user page
February 19, 2013 7:30 AM
Answer

Paul Schmidt

Rank: Junior Member

Posts: 30

Join Date: July 28, 2010

Recent Posts

The page wasn't hidden.