Combination View Flat View Tree View
Threads [ Previous | Next ]
Jignesh Vachhani
Embed portlet in layout using Liferay 6.1.1
November 30, 2012 12:23 AM
Answer

Jignesh Vachhani

Rank: Liferay Master

Posts: 780

Join Date: March 10, 2008

Recent Posts

Hi Everyone,

I am trying to put navigation portlet in my layout.
Now i am using below code to embed navigation portlet in layout :

$theme.runtime("71_INSTANCE_MAIN", "", $velocityPortletPreferences.toString())

So portlet is being embedded but out side of layout div tags .
Does anybody have any idea ? Is this Liferay OOB error ?
Jignesh Vachhani
RE: Embed portlet in layout using Liferay 6.1.1 EE GA2
November 30, 2012 3:02 AM
Answer

Jignesh Vachhani

Rank: Liferay Master

Posts: 780

Join Date: March 10, 2008

Recent Posts

I think I found the issue is ,



1) When i am using $processor.processPortlet

Ans : I used $processor.processPortlet("71_INSTANCE_MAIN") to embed portlet in layout .tpl file
but it can not read this.
I dig the code and found that it seems to be problem in Liferay Code TemplateProcessor.java class
In this class,processPortlet method seems to be using wrong portlet id @ 175 line number. (See below code)
 1
 2public String processPortlet(String portletId) throws Exception {
 3        try {
 4            _request.setAttribute(
 5                WebKeys.RENDER_PORTLET_RESOURCE, Boolean.TRUE);
 6
 7            return RuntimePortletUtil.processPortlet(
 8                _servletContext, _request, _response, null, null, [b]_portletId[/b],
 9                null, false);
10        }
11        finally {
12            _request.removeAttribute(WebKeys.RENDER_PORTLET_RESOURCE);
13        }
14    }


2) When i am using $theme.runtime
Its rendering the code outside of layout and trying to find out the solution
Jignesh Vachhani
RE: Embed portlet in layout using Liferay 6.1.1
December 5, 2012 10:51 PM
Answer

Jignesh Vachhani

Rank: Liferay Master

Posts: 780

Join Date: March 10, 2008

Recent Posts

Thanks Liferay.

I got patch from liferay and now its working properly.
Karen Smallwood
RE: Embed portlet in layout using Liferay 6.1.1
February 11, 2013 8:38 PM
Answer

Karen Smallwood

Rank: New Member

Posts: 3

Join Date: May 17, 2010

Recent Posts

I have the same issue. Can you share where you located the patch?
Jignesh Vachhani
RE: Embed portlet in layout using Liferay 6.1.1
February 26, 2013 11:17 PM
Answer

Jignesh Vachhani

Rank: Liferay Master

Posts: 780

Join Date: March 10, 2008

Recent Posts

you can find this patch from liferay if you are using EE version
Andew Jardine
RE: Embed portlet in layout using Liferay 6.1.1
October 31, 2013 10:48 AM
Answer

Andew Jardine

Rank: Regular Member

Posts: 240

Join Date: December 22, 2010

Recent Posts

I just ran into the same issue this morning but I have found a work around (CE version, no patch). For me, I used the following line in my layout template and it worked --

$theme.runtime(", '', '')
James Falkner
RE: Embed portlet in layout using Liferay 6.1.1
April 14, 2014 7:29 AM
Answer

James Falkner

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1216

Join Date: September 17, 2010

Recent Posts

Jignesh Vachhani:
1 - Stop Tomcat
2 - Copy the attached liferay-hotfix-110-6120.zip into $LIFERAY_HOME/patching-tool/patches folder
3 - Run 'patching-tool install' at $LIFERAY_HOME/patching-tool folder
4 - Run 'patching-tool info' to ensure that the patch has installed
5 - Start Tomcat


Hey Jignesh, please don't post EE hotfixes to our forums - as they are for enterprise subscription customers only. Thanks!
Jignesh Vachhani
RE: Embed portlet in layout using Liferay 6.1.1
April 14, 2014 7:51 AM
Answer

Jignesh Vachhani

Rank: Liferay Master

Posts: 780

Join Date: March 10, 2008

Recent Posts

Ohhh Thanks James for reminding me. Removed post