Forums

Home » Liferay Portal » English » Liferay Legacy

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Marcel Friedmann
Internet Explorer: Downloads do not work via https
October 22, 2007 6:51 AM
Answer

Marcel Friedmann

Rank: Junior Member

Posts: 63

Join Date: September 10, 2007

Recent Posts

Hi,
we suffering following Problem:
It is not possible to download files via IE6 and IE7 when accessing the portal via https.
In Firefox downloads are possible.
It seems IE7 is not getting to nessesary parameters and just wants to download get_file.
Downloading over http works.
Does anybody know a solution to this behavouir?
Marcel Friedmann
RE: Internet Explorer Downloads do not work via https
October 10, 2007 5:48 AM
Answer

Marcel Friedmann

Rank: Junior Member

Posts: 63

Join Date: September 10, 2007

Recent Posts

Found support-tickets of mircosoft:
http://support.microsoft.com/kb/812935/en-us
http://support.microsoft.com/kb/870700/en-us

So, how to change cache control?
Marcel Friedmann
RE: Internet Explorer Downloads do not work via https
October 19, 2007 4:02 AM
Answer

Marcel Friedmann

Rank: Junior Member

Posts: 63

Join Date: September 10, 2007

Recent Posts

Hi there,emoticon
i analyzed the Response:
 1   Response Header:
 2      Date[Fri, 19 Oct 2007 10:35:46 GMT]
 3      Server[IBM_HTTP_Server/6.1 Apache/2.0.47 (Unix)]
 4      Pragma[public]
 5      content-disposition[attachment; filename="ersteschritte.pdf"]
 6      Set-Cookie[COOKIE_SUPPORT=true; Expires=Sat, 18 Oct 2008 10:35:53 GMT; Path=/]
 7      Expires[Thu, 01 Dec 1994 16:00:00 GMT]
 8      Cache-Control[no-cache="set-cookie, set-cookie2"]
 9      Keep-Alive[timeout=100, max=89]
10      Connection[Keep-Alive]
11      Transfer-Encoding[chunked]
12      Content-Type[b][applicationpdf][/b]
13      Content-Language[en-US]


Probaly the Content-Type is the cause. It should be application/pdf

So... how to change the content-type????

Anybody out there???
Marcel Friedmann
RE: Internet Explorer: Downloads do not work via https
October 24, 2007 6:43 AM
Answer

Marcel Friedmann

Rank: Junior Member

Posts: 63

Join Date: September 10, 2007

Recent Posts

finally we found a solution.
We are useing Websphere Application Servers. WAS is setting the header if addCookie-Methodes gets invoked.
So you have to rewritte the header after the addCookie-Methode.

we also posted a LEP:
http://support.liferay.com/browse/LEP-4069