Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Ravi Golia
Question
December 24, 2012 5:07 AM
Answer

Ravi Golia

Rank: New Member

Posts: 9

Join Date: December 22, 2012

Recent Posts

After making some changes on liferay portal .. Add menu from docbar went off .. please suggest the reason behind this
Gaurav Jain
RE: Question
December 24, 2012 5:09 AM
Answer

Gaurav Jain

Rank: Regular Member

Posts: 141

Join Date: January 31, 2011

Recent Posts

Ravi Golia:
After making some changes on liferay portal .. Add menu from docbar went off .. please suggest the reason behind this



Maybe you can elaborate this!!
- What changes you did?
- Your current logged in user has enough permissions?
- Which scope you are checking now? (Site Page? User Page? Template page? Others?)
Hitoshi Ozawa
RE: Question
December 24, 2012 2:55 PM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7990

Join Date: March 23, 2010

Recent Posts

You shouldn't directly modify liferay source code. Create a hook to overwrite view.jsp.
It didn't work correctly because you probably have a bug in your code. Without knowing what error you are getting and your code, it's impossible to provide you further assistance.
Guenter Nobody
RE: Question
December 25, 2012 11:32 AM
Answer

Guenter Nobody

Rank: Regular Member

Posts: 119

Join Date: January 27, 2012

Recent Posts

Without modifying the source code we would easily waste 3-5 times more time than we already do with Liferay. Its a wonder that this entire thing is working at all. When I look back to 2012 I can say : I never wasted so much time like with Liferay. That makes in total over 700 hours for nothing but just fixing bugs, watching Liferay how it deployes your portlets wrong or it needs over 10 minutes for a theme deploy (30files) or worst even : getting your site rescued.
Ravi Kumar Gupta
RE: Question
December 25, 2012 9:19 PM
Answer

Ravi Kumar Gupta

Rank: Liferay Legend

Posts: 1146

Join Date: June 23, 2009

Recent Posts

I guess its just permission problem.. Can you please recheck the roles you have.. ??

-Ravi