Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Althaf Hussain Shaik
OPEN-ID ISSUE
January 31, 2013 4:47 AM
Answer

Althaf Hussain Shaik

Rank: Junior Member

Posts: 61

Join Date: May 3, 2012

Recent Posts

Hi All,


Can any body explain me how to log in with open id in liferay.

I have created one hook and overrided portal.properties file as

open.sso.auth.enabled=true , i had created open id and also i had checked from control panel in portal settings--Authentications.

But still it is not able to login the page. It is throwing

Your request failed to complete.

Can any body help me out....
Subhash Pavuskar
RE: OPEN-ID ISSUE
January 31, 2013 7:11 AM
Answer

Subhash Pavuskar

Rank: Regular Member

Posts: 234

Join Date: March 12, 2012

Recent Posts

Hi,

Try out this one !! In your portal-ext.properties file add the following

1    open.id.auth.enabled=true
Hitoshi Ozawa
RE: OPEN-ID ISSUE
January 31, 2013 2:56 PM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7990

Join Date: March 23, 2010

Recent Posts

Don't use a hook to override portal.properties. Just create a new text file portal-ext.properties in the ROOT\WEB-INF\classes folder.
Althaf Hussain Shaik
RE: OPEN-ID ISSUE
January 31, 2013 9:23 PM
Answer

Althaf Hussain Shaik

Rank: Junior Member

Posts: 61

Join Date: May 3, 2012

Recent Posts

Hi

I placed open.id.auth.enabled=true this in portal-ext.properties but still i am not able to log in with open-id.
Steve Lum
RE: OPEN-ID ISSUE
June 25, 2013 2:15 PM
Answer

Steve Lum

Rank: New Member

Posts: 1

Join Date: June 25, 2013

Recent Posts

I am also having the same issue. I have added the properties file as instructed above and enabled authentication using the Control Panel. I am using the built-in Login portlet and I can see the OpenID link. I have tried to login with multiple OpenID providers and get the same message "Your request failed to complete." I am using 6.1.1CE GA2.