Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
raj rao
Service builder with Liferay 6.1 on weblogic error while using BLOB as type
February 8, 2013 2:55 PM
Answer

raj rao

Rank: New Member

Posts: 2

Join Date: January 20, 2013

Recent Posts

Hi,
I create service builder with an entity having one column type as BLOB.
when I built service the service DataModelImpl.java created with error, method resetOriginalValues() is having errors.
I manually corrected the same and deployed the portlet and getting below error,
I am not getting Class not found if BLOB column is removed.
Using liferay-plugins-sdk-6.1.20.

17:44:46,162 ERROR [ ExecuteThread: '6' for queue: 'weblogic.kernel.Default (self-tuning)'][BasicLazyInitializer:110] Javassist Enhancement f
ailed: com.sb.model.HotTopicsDataDOC_CONTENTBlobModel
java.lang.RuntimeException: by java.lang.NoClassDefFoundError: org/hibernate/proxy/HibernateProxy
at javassist.util.proxy.ProxyFactory.createClass3(ProxyFactory.java:510)
at javassist.util.proxy.ProxyFactory.createClass2(ProxyFactory.java:487)
at javassist.util.proxy.ProxyFactory.createClass1(ProxyFactory.java:423)
at javassist.util.proxy.ProxyFactory.createClass(ProxyFactory.java:395)
at org.hibernate.proxy.pojo.javassist.JavassistLazyInitializer.getProxyFactory(JavassistLazyInitializer.java:162)
at org.hibernate.proxy.pojo.javassist.JavassistProxyFactory.postInstantiate(JavassistProxyFactory.java:65)
at org.hibernate.tuple.entity.PojoEntityTuplizer.buildProxyFactory(PojoEntityTuplizer.java:185)
at org.hibernate.tuple.entity.AbstractEntityTuplizer.<init>(AbstractEntityTuplizer.java:167)
at org.hibernate.tuple.entity.PojoEntityTuplizer.<init>(PojoEntityTuplizer.java:77)
at sun.reflect.GeneratedConstructorAccessor57.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
at org.hibernate.tuple.entity.EntityTuplizerFactory.constructTuplizer(EntityTuplizerFactory.java:105)
at org.hibernate.tuple.entity.EntityTuplizerFactory.constructDefaultTuplizer(EntityTuplizerFactory.java:133)
at org.hibernate.tuple.entity.EntityEntityModeToTuplizerMapping.<init>(EntityEntityModeToTuplizerMapping.java:80)
at org.hibernate.tuple.entity.EntityMetamodel.<init>(EntityMetamodel.java:322)
Cristina C.S.
RE: Service builder with Liferay 6.1 on weblogic error while using BLOB as
June 25, 2013 1:57 AM
Answer

Cristina C.S.

Rank: New Member

Posts: 7

Join Date: May 21, 2009

Recent Posts

I have the same problem.
Does anybody solve this?
Axel Schmidt
RE: Service builder with Liferay 6.1 on weblogic error while using BLOB as
October 10, 2013 8:22 AM
Answer

Axel Schmidt

Rank: New Member

Posts: 1

Join Date: August 18, 2011

Recent Posts

Hi,

i have the same error with Tomcat 7.
Any help is appreciated.
oscar morro
RE: Service builder with Liferay 6.1 on weblogic error while using BLOB as
December 25, 2013 11:21 PM
Answer

oscar morro

Rank: New Member

Posts: 4

Join Date: October 22, 2012

Recent Posts

Could anyone solve this problem?