Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Behzad Gadimi
beanlocator error
March 3, 2013 3:42 AM
Answer

Behzad Gadimi

Rank: Junior Member

Posts: 31

Join Date: March 8, 2011

Recent Posts

Hi,
why I get the error : BeanLocator has not been set ?

It worked properly but when I edited service.xml file to add some exception and column names, this error apeared!
I changed my column names so that all of them start with lowercase and added some exceptions.
Habib Zare
RE: beanlocator error
March 3, 2013 4:36 AM
Answer

Habib Zare

Rank: Junior Member

Posts: 43

Join Date: October 28, 2012

Recent Posts

post your service.xml.
David H Nebinger
RE: beanlocator error
March 4, 2013 5:41 AM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 7153

Join Date: September 1, 2006

Recent Posts

Habib Zare:
post your service.xml.


Don't do this. Just google the forums, it has been answered before.
Behzad Gadimi
RE: beanlocator error
March 4, 2013 7:03 AM
Answer

Behzad Gadimi

Rank: Junior Member

Posts: 31

Join Date: March 8, 2011

Recent Posts

David H Nebinger:

Don't do this. Just google the forums, it has been answered before.



yes!
It has been answered! but none of them works for me.
I was thinking that if I mention the exact possible reason for this error in another thread, maybe I can reach my answer by the help of some legends of liferay.
I don't have the time to wait for couple of days for the answer of my question.
I can easily google the forum and get my answer, but when it didn't help, I have no choice but reposting it with my exact problem.
But you and many other legends of liferay were so king to me and I appreciate that!
You(and the others that think have words to say in liferay) can help the novice developers and you can't.
If you have something to answer, post it, if you have not, you can ignore the thread and looking somewhere else in the forum.

thanks for your great answers.
Behzad Gadimi
RE: beanlocator error
March 4, 2013 7:05 AM
Answer

Behzad Gadimi

Rank: Junior Member

Posts: 31

Join Date: March 8, 2011

Recent Posts

Habib Zare:
post your service.xml.



I have deleted the changes that I made to service.xml so that I be able to get it work again.
I don't have the source of it that isn't working.
Really thanks for your help.
David H Nebinger
RE: beanlocator error
March 4, 2013 7:38 AM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 7153

Join Date: September 1, 2006

Recent Posts

Behzad Gadimi:
I don't have the time to wait for couple of days for the answer of my question.


Sorry to be short, Behzad, but many new users will post messages here in the forums as though Liferay support is just sitting there waiting to answer. Many issues that new users face have been faced by lots of people before them, many have posted new threads looking for assistance where the forum already contains the answers although they might not be aware of it...

If we all ignored your post because it had been answered before and no one responded, you would be in a worse spot than if we suggested a forum search.

In the end, we're just trying to help you find your answer without retyping the answer over and over again...
Behzad Gadimi
RE: beanlocator error
March 4, 2013 8:30 AM
Answer

Behzad Gadimi

Rank: Junior Member

Posts: 31

Join Date: March 8, 2011

Recent Posts

David H Nebinger:
Behzad Gadimi:
I don't have the time to wait for couple of days for the answer of my question.


Sorry to be short, Behzad, but many new users will post messages here in the forums as though Liferay support is just sitting there waiting to answer.


I mean : I know that if I post my problem in forum and wait for answer, it may take couple of days. So if I wouldn't have an alternative, I have to post it here.
Because I've searched it and I couldn't get my answer and I know that searching may take a couple of minutes.
This is my search results: modify your web.xml file and put a listener .......
but it doesn't help in my case