Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Micael Ericsson
Old portlets will not deploy anymore
March 28, 2013 1:56 AM
Answer

Micael Ericsson

Rank: Junior Member

Posts: 88

Join Date: December 11, 2012

Recent Posts

We have a system with 10 test-portlets developed. Simple portlets with one purpose - show user interface to get som reaction/feedback from users.

Now in phase 2 we starta to connect these portlets with real data from another system.
First three portlets worked like a charm. But the following portlets will not deploy. I have tried 3 of them and none will deploy.
In phase 2 we have added more dependencies in order to get data. I have tried to compare working and not working portlets and they look the same. I have cleaned cache of liferay and netbeans and restarted Liferay - still no deploy.

I have tried to fins solution based on messages in server.log, but no luck so far.

This is the server log after deploy:
08:06:20,674 INFO [com.liferay.portal.kernel.deploy.auto.AutoDeployScanner][PortletAutoDeployListener:87] Portlets for C:\Product\Liferay\liferay-portal-6.1.1-ce-ga2\deploy\Information-1.0-SNAPSHOT.war copied successfully. Deployment will start in a few seconds.
mar 28, 2013 8:06:27 FM org.apache.catalina.startup.HostConfig checkResources
INFO: Undeploying context [/Information-1.0-SNAPSHOT]
----> down to this point the log is same for working and not working deployment of portal
mar 28, 2013 8:06:27 FM org.apache.catalina.loader.WebappClassLoader checkThreadLocalMapForLeaks
SEVERE: The web application [/Information-1.0-SNAPSHOT] created a ThreadLocal with key of type [com.liferay.portal.kernel.util.CentralizedThreadLocal.ThreadLocalMapThreadLocal] (value [com.liferay.portal.kernel.util.CentralizedThreadLocal$ThreadLocalMapThreadLocal@7311b6f2]) and a value of type [com.liferay.portal.kernel.util.CentralizedThreadLocal.ThreadLocalMap] (value [com.liferay.portal.kernel.util.CentralizedThreadLocal$ThreadLocalMap@100204e3]) but failed to remove it when the web application was stopped. Threads are going to be renewed over time to try and avoid a probable memory leak.
mar 28, 2013 8:06:27 FM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory C:\Product\Liferay\liferay-portal-6.1.1-ce-ga2\tomcat-7.0.27\webapps\Information-1.0-SNAPSHOT
mar 28, 2013 8:06:27 FM org.apache.catalina.loader.WebappClassLoader validateJarFile
INFO: validateJarFile(C:\Product\Liferay\liferay-portal-6.1.1-ce-ga2\tomcat-7.0.27\temp\9-Information-1.0-SNAPSHOT\WEB-INF\lib\servlet-api-2.5.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/servlet/Servlet.class
Micael Ericsson
RE: Old portlets will not deploy anymore
March 28, 2013 2:11 AM
Answer

Micael Ericsson

Rank: Junior Member

Posts: 88

Join Date: December 11, 2012

Recent Posts

A little more details about the environment:
- Liferay/Tomcat bundle. Liferay 6.1.1. Tomcat 7.0.27
- Running on JDK 1.7_15
- liferay-xxx packages ver 3.1.1
- corba iiop calls to remote Glassfish system
Developing in NetBeans 7.2.
Subhash Pavuskar
RE: Old portlets will not deploy anymore
March 28, 2013 3:44 AM
Answer

Subhash Pavuskar

Rank: Regular Member

Posts: 234

Join Date: March 12, 2012

Recent Posts

Hi Find the attachment and i hope the following link may help you to resolve your issue Click Here
Attachments: Memory-Leaks.pdf (193.2k)
Micael Ericsson
RE: Old portlets will not deploy anymore
March 28, 2013 3:52 AM
Answer

Micael Ericsson

Rank: Junior Member

Posts: 88

Join Date: December 11, 2012

Recent Posts

Hi

Thanks for the input. But my current problem is that portlet no longer will deploy.

Memory leak is a possible future problem. The log says: "..avoid a probable memory leak...."
Subhash Pavuskar
RE: Old portlets will not deploy anymore
March 28, 2013 4:48 AM
Answer

Subhash Pavuskar

Rank: Regular Member

Posts: 234

Join Date: March 12, 2012

Recent Posts

Have a look https://www.liferay.com/community/forums/-/message_boards/message/13659095
Micael Ericsson
RE: Old portlets will not deploy anymore
March 28, 2013 11:34 AM
Answer

Micael Ericsson

Rank: Junior Member

Posts: 88

Join Date: December 11, 2012

Recent Posts

Subhash Pavuskar:
Have a look https://www.liferay.com/community/forums/-/message_boards/message/13659095


I found that post earlier and it provided no help.
The portlets that I am having problem with was developed for the same environment some weeks ago and they did work before the data-read changes. And I have three portlets that is working with data-read changes.
They all look similar and this puzzles me.