Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Jacques Traore
Problem to display JournalArticle inserted by SOAP web service
March 28, 2013 6:16 AM
Answer

Jacques Traore

Rank: Junior Member

Posts: 46

Join Date: January 21, 2013

Recent Posts

Hi there. This is the 3rd day the following issue is killing me softly.
I use Liferay 6.1.1-ce-ga2 bundled with tomcat server and oracle 10g database.
My goal is to insert some content, as Journal article, and display them in an asset publisher (with a structure and template, already working).
I used JournalArticleServiceSoap.addArticle(...) with the right fields (groupid, structureid, templateid, ...). The contents are "correctly" inserted in the database and I can see them inside web contents from administrator content panel. The contents have also "Approved" as status. this is done by setting
1serviceContext.setWorkflowAction(WorkflowConstants.ACTION_PUBLISH)
.
However, I can't see the inserted contents displayed with the other contents in the asset publisher, until I open it again for edition and click on publish button (even without changing nothing). Then the content is published as expected. The problem is the number of contents. It is about 600 so I can't to this action for each one.
I do not understand what is the matter and how to figure it out??? In other words, what do I have to do to make web content, inserted by web service, displayed automatically?
Or, what does the "Publish" do exactly so I can try to reproduce programmatically with SOAP service (or SQL after insertion)?

Thank you by advance for your help.
Đorđe Torbica
RE: Problem to display JournalArticle inserted by SOAP web service
April 7, 2014 2:23 AM
Answer

Đorđe Torbica

Rank: New Member

Posts: 7

Join Date: February 21, 2014

Recent Posts

Hi,

how did you solve this problem? I have same problem with blogentry.

Thank you.
Jacques Traore
RE: Problem to display JournalArticle inserted by SOAP web service
June 6, 2014 12:23 PM
Answer

Jacques Traore

Rank: Junior Member

Posts: 46

Join Date: January 21, 2013

Recent Posts

Hi Dorde,
Unfortunatly I did not find another way. Yet.
Since I don't update my contents using SOAP so many times, I used the workaround (republishing the content through the control panel) to get it working.
This is really shame because the feature was very interesting.

Sorry.