Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Radhakrishna Meduri
Stable Lifreray to upgrade in tomcat 6.0.36
June 27, 2013 6:40 AM
Answer

Radhakrishna Meduri

Rank: New Member

Posts: 22

Join Date: December 5, 2011

Recent Posts

Hi

I posted may queries on using LR 5.1.2 on tomcat 6.0.36. I did not get much replies.

So we decided to use latest liferay version. I would like to know what is stable version to use?

Also we are using 5.1.2 Extension environment and portlets were developed using that environment.
If i use latest version of liferay, can i safely deploy the current portlets into new environment.
I understand that extention environment was no more and now we have to use SDK. Could you please guide me how to deploy existing portlets to new LR version?

Thanks
Radhakrishna
Tonu Sri
RE: Stable Lifreray to upgrade in tomcat 6.0.36
June 27, 2013 6:49 AM
Answer

Tonu Sri

Rank: Regular Member

Posts: 196

Join Date: April 15, 2011

Recent Posts

Hi Radhakrishna,

Current stable version of Liferay is 6.1 GA2.

You can upgrade your EXT environment to EXT plugin to work with latest version of Liferay.

You can follow this blog:

http://www.liferay.com/web/edward.shin/blog/-/blogs/upgrading-your-ext-environment-to-an-ext-plugin

Thanks:
Tonu
Radhakrishna Meduri
RE: Stable Lifreray to upgrade in tomcat 6.0.36
June 27, 2013 10:34 AM
Answer

Radhakrishna Meduri

Rank: New Member

Posts: 22

Join Date: December 5, 2011

Recent Posts

Thanks Tonu for you reply.
Understand that we need to migrate from extention environment to EXT.
From my understanding, we need to upgrade themes as well to 6.1.
Is it enough to change Liferay-look-and-feel.xml and liferay-plugin-package.xml available in Themes OR do we need to modify any change?
Apart from this, do we need to consider any other tasks in your experience.

Thanks
Radhakrishna
Tonu Sri
RE: Stable Lifreray to upgrade in tomcat 6.0.36
June 27, 2013 9:33 PM
Answer

Tonu Sri

Rank: Regular Member

Posts: 196

Join Date: April 15, 2011

Recent Posts

Hi RadhaKrishna,

Yes, you have to upgrade your theme plugins also.

You would need to manually include jQuery, as now it is not part of Liferay (Alloy UI is now a part). You can include them through the template files (*.vm).

There are a lot of customization's in the template files (portal_normal.vm, portlet.vm, navigation.vm etc) from 5.2 to 6.1, so if you have done customization's to these then you would have to again customize them.

For upgrading custom.css this link can help you:

http://www.liferay.com/community/wiki/-/wiki/Main/Upgrade+5.2.x+Themes+to+6.0.x


Thanks:
Tonu
Radhakrishna Meduri
RE: Stable Lifreray to upgrade in tomcat 6.0.36
June 28, 2013 4:36 AM
Answer

Radhakrishna Meduri

Rank: New Member

Posts: 22

Join Date: December 5, 2011

Recent Posts

Thanks Tonu for your help.
I have data how to migrate to new EXT environment, but i think i am missing where to start.

Currently i have following data.
1. The set of directories from old Extension environment.
Using this link http://www.liferay.com/web/edward.shin/blog/-/blogs/upgrading-your-ext-environment-to-an-ext-plugin
I need to upgrade my Extension environment.

2. Upgrade Themes using the link you suggested.

apart from these, may i know list of tasks which needs to do for lifeary 6.1.
one more question is how to create such database. We are using sybase already with older lifeary.
Can you provide me clear steps. I did not find anywhere clear documentation on full steps of installing 6.1 with ext-directories from old extention environment.

Thanks
Radhakrishn
Radhakrishna Meduri
RE: Stable Lifreray to upgrade in tomcat 6.0.36
June 29, 2013 5:11 AM
Answer

Radhakrishna Meduri

Rank: New Member

Posts: 22

Join Date: December 5, 2011

Recent Posts

Hi Tonu,
can you reply on this?
i am really waiting for your input to start liferay 6.0 installation.
Thanks
Radhakrishna
Tonu Sri
RE: Stable Lifreray to upgrade in tomcat 6.0.36
July 1, 2013 2:31 AM
Answer

Tonu Sri

Rank: Regular Member

Posts: 196

Join Date: April 15, 2011

Recent Posts

Hi Radhakrishna,

First you should start updating your liferay Portal to latest version, then you should move forward to update your plugins for example :theme, ext, portlet etc.

To upgarde your Liferay to latest version, you just connect your new Liferay installation with old database.

You can find more info at http://www.liferay.com/community/wiki/-/wiki/Main/Upgrade+Instructions+from+5.2+to+6.0.

Thanks:
Tonu
Radhakrishna Meduri
RE: Stable Lifreray to upgrade in tomcat 6.0.36
July 1, 2013 7:53 AM
Answer

Radhakrishna Meduri

Rank: New Member

Posts: 22

Join Date: December 5, 2011

Recent Posts

Thanks Toni.
I understand from the link that we need to upgrade to "5.2.3SE" to start upgrade.
Is it mandatory?

is it possible to direct upgrade from 5.1.2 to 6.1.1 GA2?

one more question on the already deployed life ray how to find out whether it is CE or EE?

The problem is previous developers did not document much on the procedure used during 5.1.2 life ray with ext development. So lots of confusion happened.

From the previous 5.1.2 development, i could see following directories are available. My question is how these directories are useful in upgrading to 6.1.1 GA2.

app.server.properties
build-common.xml
build-parent.xml
build.properties
build-theme.xml
build.xml
classes
ext-impl
ext-lib
ext-service
ext-web
lib
modules
pom.xml
sql
tools

We are using sybase database for database connectivity. I could see databsae connection properties in portal-impl.jar file ( META-INF/infrastructure-spring.xml ).
I am planning to keep the same.

Thanks
Radhakrishna