Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
G R Rajesh Babu
Build Error on creating new Liferay Portlet Plugin in plugins-sdk-6.2.0-ce
August 13, 2013 6:42 AM
Answer

G R Rajesh Babu

Rank: Junior Member

Posts: 77

Join Date: February 7, 2010

Recent Posts

Hi Guys,

I am unable to build a Liferay Portlet Plugin in plugins-sdk-6.2.0-ce by getting the following Error. Please suggets me where exactly I am getting wrong.

[Console output redirected to fileemoticon:\Program_Files\Liferay\Workspace_LDS\.metadata\.plugins\com.liferay.ide.eclipse.sdk\sdk.log]

Buildfile: D:\Program_Files\Liferay\Liferay6.2_M6\liferay-plugins-sdk-6.2.0-ce-m6-20130614143518319\liferay-plugins-sdk-6.2.0\portlets\build.xml
[ivy:resolve] :: Apache Ivy 2.3.0 - 20130110142753 :: http://ant.apache.org/ivy/ ::
[ivy:resolve] :: loading settings :: file = D:\Program_Files\Liferay\Liferay6.2_M6\liferay-plugins-sdk-6.2.0-ce-m6-20130614143518319\liferay-plugins-sdk-6.2.0\
ivy-settings.xml

BUILD FAILED
D:\Program_Files\Liferay\Liferay6.2_M6\liferay-plugins-sdk-6.2.0-ce-m6-20130614143518319\liferay-plugins-sdk-6.2.0\portlets\build.xml:5: The following error occ
urred while executing this line:
D:\Program_Files\Liferay\Liferay6.2_M6\liferay-plugins-sdk-6.2.0-ce-m6-20130614143518319\liferay-plugins-sdk-6.2.0\build-common-plugins.xml:5: The following err
or occurred while executing this line:
D:\Program_Files\Liferay\Liferay6.2_M6\liferay-plugins-sdk-6.2.0-ce-m6-20130614143518319\liferay-plugins-sdk-6.2.0\build-common.xml:47: The following error occu
rred while executing this line:
D:\Program_Files\Liferay\Liferay6.2_M6\liferay-plugins-sdk-6.2.0-ce-m6-20130614143518319\liferay-plugins-sdk-6.2.0\build-common-ivy.xml:34: The following error
occurred while executing this line:
D:\Program_Files\Liferay\Liferay6.2_M6\liferay-plugins-sdk-6.2.0-ce-m6-20130614143518319\liferay-plugins-sdk-6.2.0\build-common-ivy.xml:50: java.lang.NoClassDef
FoundError: org/bouncycastle/openpgp/PGPException
David H Nebinger
RE: Build Error on creating new Liferay Portlet Plugin in plugins-sdk-6.2.0
August 13, 2013 6:57 AM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 6129

Join Date: September 1, 2006

Recent Posts

6.2 hasn't even gone gold yet, they're still only at M6, and I don't know if the SDK has been bundled for release yet...

If you're not doing development/testing of the 6.2 line, revert back to 6.1...
G R Rajesh Babu
RE: Build Error on creating new Liferay Portlet Plugin in plugins-sdk-6.2.0
August 13, 2013 7:59 AM
Answer

G R Rajesh Babu

Rank: Junior Member

Posts: 77

Join Date: February 7, 2010

Recent Posts

Hi David,

Thanks for the Reply. I need to create some POCs on the latest Liferay version 6.2.0 M6 and need to verify the issues to decide which latest version of Liferay we can go ahead. That is the reason that I am getting this type of strange issues that have ever faced before.
David H Nebinger
RE: Build Error on creating new Liferay Portlet Plugin in plugins-sdk-6.2.0
August 13, 2013 8:06 AM
Answer

David H Nebinger

Rank: Liferay Legend

Posts: 6129

Join Date: September 1, 2006

Recent Posts

But until 6.2 is released, no one can guarantee that you're not encountering a bug that may have already been fixed in the source repository... It really is not meant to be an evaluation product for Liferay, only when the first CE goes gold will that be the case...

And even then, there is a history of problems in the initial new version releases. Heck, they're planning on 6.1 CE 3 to come out soon. Not their fault, most significant software changes come with impacts that are difficult to test with such a large installation base and such diverse environments.

My recommendation: if you're going to put this in production within a year of the actual public release of 6.2, stick with 6.1. If you're going to production sometime after a year, then go with 6.2...
G R Rajesh Babu
RE: Build Error on creating new Liferay Portlet Plugin in plugins-sdk-6.2.0
August 22, 2013 2:25 AM
Answer

G R Rajesh Babu

Rank: Junior Member

Posts: 77

Join Date: February 7, 2010

Recent Posts

Thanks for your recommendation David. will discuss with my boss on the same.
Andew Jardine
RE: Build Error on creating new Liferay Portlet Plugin in plugins-sdk-6.2.0
November 6, 2013 12:45 PM
Answer

Andew Jardine

Rank: Regular Member

Posts: 151

Join Date: December 22, 2010

Recent Posts

Hey Guys,

I am actually getting this same error on teh 6.1.1 SDK that was released with 6.1.2 GA3. I found this LPS ticket -- no mention of my version of course.

https://support.liferay.com/browse/LPS-36592

I went to GitHub and compared the ivy.xml, ivy.settings.xml and build-common-ivy.xml files from there to the ones that I have in my install and they are almost identical. I also verified that the sdk/lib folder has both the jars listed in the ticket. Frankly, I am at a loss as to what to do here, and I am even more confused how something so core (being able to build a plugin?) could possibly not be tested pre-release.

Perhaps I am missing something? Any guidance would be appreciated.
Onochie Ojekwe
RE: Build Error on creating new Liferay Portlet Plugin in plugins-sdk-6.2.0
April 17, 2014 9:16 AM
Answer

Onochie Ojekwe

Rank: New Member

Posts: 12

Join Date: April 8, 2011

Recent Posts

try downloading the ivy cache folder then unzip and place in SDK folder http://files.liferay.org.es/staged/public-files/liferay-ide/dependencies/files/ivy-cache.zip