Combination View Flat View Tree View
Threads [ Previous | Next ]
James Falkner
Liferay Portal 6.2 Release Preparation
October 2, 2013 11:36 AM
Answer

James Falkner

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1222

Join Date: September 17, 2010

Recent Posts

If you are a Liferay Developer and have published (or are about to publish) a Liferay Marketplace App, there are a few things you need to be aware of as we approach the next release of Liferay Portal (version 6.2).

As you know, inside your app, you are required to declare the version(s) of Liferay with which your app is compatible. Up until now, you have had things like liferay-versions=6.1.1+,6.1.20+ in your liferay-plugin-package.properties. This declares that your app is compatible with Liferay 6.1.1 (aka Liferay 6.1 CE GA2) and later, and Liferay 6.1.20 (aka Liferay 6.1 EE GA2) and later. The "and later" part means "within the same release family", which in this example means all future Liferay Portal 6.1.x releases. It does not include Liferay 6.2 or later! So what do you need to do to prepare for the new Liferay Portal release?

1. Test your app against Liferay 6.2. As 6.2 hasn't yet been "officially" released, you can use the most recent Release Candidate (check out the Release Dashboard for download pointers).

2. Once your app has been confirmed to work with 6.2, add ",6.2.0+" to the end of your version string, and submit a new version of your app with the updated version compatibility declaration. For example, if your app is compatible with 6.1 CE GA2+,6.1 EE GA2+, and 6.2 CE GA1+, then you'd put liferay-versions=6.1.1+,6.1.20+,6.2.0+

You can do this now using the 6.2 RC builds, but be aware that there may be last minute changes to the final release that may invalidate your app (cause it to not work) once 6.2 is actually released (but the chances of this happening are very low). If you are OK with waiting, then you can wait until 6.2 is actually released (expected some time this month), before doing any testing or updating. It just means that users who are using 6.2 will not be able to deploy your app (they will see "Not Compatible" in Control Panel -> Apps), or they will get a deploy error if they manually try and deploy your app.

Thanks again for your contributions to our community and to the Marketplace, and I look forward to a smooth transition for all of your apps and users!