Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Pablo M Mino
Maven portlet: My portlet is running from temp folder, why?
March 26, 2010 2:44 PM
Answer

Pablo M Mino

Rank: Regular Member

Posts: 135

Join Date: October 2, 2009

Recent Posts

Hi,

I made a portlet with jsf, spring, hibernate and maven, when the portlet runs the ApplicationContext sets the web app root to the temp folder, instead to the one in webapps

I've created the same portlet with Plugins SDK and that doesn't happen

So my guess is Plugins SDK does something specific that tells LR how to deploy correctly the portlet, and I'm not doing that on my maven antrun

Can someone help me plz?

Also it doesn't recognize the category correctly, I assume it's the same reason but that's not so urgent

P.S.: moved this from development to see if I could get better results here emoticon
atul patel
RE: Maven portlet: My portlet is running from temp folder, why?
March 26, 2010 2:56 PM
Answer

atul patel

Rank: Regular Member

Posts: 190

Join Date: November 17, 2006

Recent Posts

Take a look at the deployed web.xml for both versions. Is there anything different about the configured listeners?
Pablo M Mino
RE: Maven portlet: My portlet is running from temp folder, why?
March 26, 2010 3:29 PM
Answer

Pablo M Mino

Rank: Regular Member

Posts: 135

Join Date: October 2, 2009

Recent Posts

Both files are exactly the same, didn't knew Liferay add so many things to them btw...
Pablo M Mino
RE: Maven portlet: My portlet is running from temp folder, why?
March 27, 2010 10:15 PM
Answer

Pablo M Mino

Rank: Regular Member

Posts: 135

Join Date: October 2, 2009

Recent Posts

Pablo M Mino:

Also it doesn't recognize the category correctly, I assume it's the same reason but that's not so urgent


Found that my maven is not transforming the liferay-plugin-package.properties to .xml which might solve the problem quoted, I'm not adding any lib from that file anyway

How can I tell my maven-ant-run to create that?

P.S: this means my app is still running from temp, plz help
Pablo M Mino
RE: Maven portlet: My portlet is running from temp folder, why?
April 5, 2010 6:31 PM
Answer

Pablo M Mino

Rank: Regular Member

Posts: 135

Join Date: October 2, 2009

Recent Posts

I'm a newbie at deploying.... I really need a hand

There must be someone who already created a portlet as a full project with maven