Forums

Home » Liferay Portal » English » 3. Development

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Cynthia Kimball
openID not responding to portal-ext.properties [Resolved]
August 25, 2010 10:24 AM
Answer

Cynthia Kimball

Rank: Junior Member

Posts: 45

Join Date: July 26, 2010

Recent Posts

Hello allemoticon

Ok, I know my portal-ext.prop file is working due to other parts of it working, but for some reason my call to openID essentially turning it off, is not working.

My code is:

1open.id.auth.enabled=false


I also changed the navigation.jsp code within the login portlet to
 1boolean showCreateAccountIcon = false;
 2
 3if (!strutsAction.equals("/login/create_account") && company.isStrangers()) {
 4    showCreateAccountIcon = false;
 5}
 6
 7boolean showFacebookConnectIcon = false;
 8
 9if (!strutsAction.startsWith("/login/facebook_connect") && FacebookConnectUtil.isEnabled(company.getCompanyId())) {
10    showFacebookConnectIcon = false;
11}
12
13boolean showForgotPasswordIcon = false;
14
15if (!strutsAction.equals("/login/forgot_password") && (company.isSendPassword() || company.isSendPasswordResetLink())) {
16    showForgotPasswordIcon = true;
17}
18
19boolean showOpenIdIcon = false;
20
21if (!strutsAction.equals("/login/open_id") && OpenIdUtil.isEnabled(company.getCompanyId())) {
22    showOpenIdIcon = false;
23}
24
25boolean showSignInIcon = false;
26
27if (Validator.isNotNull(strutsAction) && !strutsAction.equals("/login/login")) {
28    showSignInIcon = true;
29}


And yet, the openID link appears in the login portlet. The other IDs that I turned to false are no longer listed, so I am trying to figure out why openID won't disappear.

Any ideas?

Thia emoticon
Dikie Rendra Aditya
RE: openID not responding to portal-ext.properties
August 25, 2010 2:44 AM
Answer

Dikie Rendra Aditya

Rank: New Member

Posts: 8

Join Date: March 11, 2009

Recent Posts

Hello I think you can remove the option for the login portlet in control panel. You must login as an administrator to do this.

Go to Control Panel > Settings then in 'Configuration' on the left select 'Authentication'.

On General tab you can enable/disable setting such as allowing users to automatically login, allowing users to request forgotten passwords, allow users to request password reset, allow strangers to create account, etc

To disable OpenID then click on OpenID tab then uncheck the 'Enabled' checkbox.


That about it, hope this help you
Cynthia Kimball
RE: openID not responding to portal-ext.properties
August 25, 2010 10:23 AM
Answer

Cynthia Kimball

Rank: Junior Member

Posts: 45

Join Date: July 26, 2010

Recent Posts

**chuckling** And I was trying to make it so hard!

Thanks! It worked perfectly!~

Thia emoticon