Forums

Home » Liferay Portal » English » 2. Using Liferay » General

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Abhi Mahan
Message Board Mailing List Email Problem: Empty Reply-To header
November 16, 2010 2:28 PM
Answer

Abhi Mahan

Rank: New Member

Posts: 5

Join Date: November 16, 2010

Recent Posts

Hi,

I'm using the bundle liferay-portal-tomcat-6.0.5 that runs on tomcat-6.0.26.

I've successfully configured email (i.e. portal@xyz.com) for my server as per the instructions at - SMTP Setup

I've configured Message Board with different categories and have assigned a mailing list email address (i.e. portal.forums@xyz.com) that will send notifications to subscribed users of a category.

When any user adds a thread/posts a reply, all the subscribed users receive notification emails.

Now I want the users to be able to post replies to the previous posts through emails as mentioned at - Mailing Functionality in Message Boards

But when a user tries to reply to the notification email, the recipient email address appears as "portal@xyz.com" instead of the mailing list email address "portal.forums@xyz.com" and the feedback doesn't get posted.

When the user manually sets the correct email address i.e. "portal.forums@xyz.com" the reply gets posted to the message board. Now we can't expect every user to specify the mailing list email address manually every time they have to reply.

At Mailing Functionality in Message Boards the following is mentioned under the section "Description"

The second part of the implementation allows users to answer to those emails or even write their own new threads using email. To achieve that Liferay assigns an email address to each category in the message boards. Such address is automatically added to the reply-to headers of emails sent to subscriber so that a simple reply to mails received from the message board will result in a new post in the appropriate place. Besides the reply-to header a second header is used so that when a user replies the original message is identified and the message boards can do proper threading.


So I checked the email headers of the notification emails:

 1From: XYZ Forums <portal@xyz.com>
 2Reply-To: <>
 3Message-ID: <mb.12419.12507@events.xyz.com>
 4In-Reply-To: <mb.12419.12502@events.xyz.com>
 5References: <mb.12419.12502@events.xyz.com>
 6Subject: [PI Cat 1] RE: Msg 1
 7MIME-Version: 1.0
 8Content-Type: text/html;charset="UTF-8"
 9Content-Transfer-Encoding: 7bit
10
11
12Reply by Admin
13--
14XYZ Message Boards
15http://111.222.333.444/group/policy/discussions/-/message_boards/view_message/12507
16
17http://111.222.333.444


As you can see at line #2, the "Reply-To" header is empty
Also line #16 is empty. This is part of the mail signature and it should have the mailing list email address (portal.forums@xyz.com) mentioned here (i.e. [$MAILING_LIST_ADDRESS$] )

As a result of this empty "Reply-To" header all replies get addressed to the "From" field value i.e portal@xyz.com.

I looked around and found others facing the same problem:


I still don't know how to fix this. How do I set the "Reply-To" header with the Mailing List Email Address - portal.forums@xyz.com?

Pls help. Look forward to your reply.

thanks & regards,
Abhi.
Trey Howard
RE: Message Board Mailing List Email Problem: Empty Reply-To header
May 20, 2011 7:16 AM
Answer

Trey Howard

Rank: Junior Member

Posts: 38

Join Date: May 10, 2011

Recent Posts

While I have noticed this problem in our LR instance, I've also noticed that an email generated from an email-driven message board post often has the following problems:
1. The From address is the individual user rather than the messageboard address. Just as in Abhi's scenario, this prevents the recipient from simply replying to the email to post back to the forum, since the email address must be changed.
2. An unrelated category appears in the subject line of the email. While unrelated, this wrong category is consistently chosen for inclusion into the subject line. Additionally, the category appears enclosed in square braces ([The Other Category]), whereas our subject line format does not contain any category and does not use square brackets for the formatting of the thread title.
3. This morning, one of our users brought to my attention that when these first two problems occur, the footer also appears wrong--it has extra content. I don't recognize the formatting of the extra content, but it looks a like a default footer, with a hyperlink to the thread.
4. Line breaks are removed from the reply unless OWA Light is used. Other email clients tested: Outlook desktop app, OWA Full (IE7 if relevant), Thunderbird.

I'm not gaining much traction on any of these problems, but they all seem related, since I have a reproducible scenario that will generate an email with all these problems.

Any help would be greatly appreciated!
-Trey
Abhi Mahan
RE: Message Board Mailing List Email Problem: Empty Reply-To header
July 18, 2011 3:26 AM
Answer

Abhi Mahan

Rank: New Member

Posts: 5

Join Date: November 16, 2010

Recent Posts

Tried the same on liferay-portal-tomcat-6.0.6-20110225 build hoping this would have been fixed by now.. no such luck emoticon.
geetha rani
RE: Message Board Mailing List Email Problem: Empty Reply-To header
February 14, 2012 10:54 PM
Answer

geetha rani

Rank: New Member

Posts: 14

Join Date: February 2, 2012

Recent Posts

]HI Abhi,
I have the same issue when the user A created the new thread on that thread B given replay Means instead of user A ,mailling list configured email address getting the replay emails how can you resolved please reply me where i need to change the files
this is argent requirement please
Attachments: mailling list issue.bmp (733.7k)