Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Bruno Galvao
LDAP Import Enabled not working.
June 10, 2011 1:55 PM
Answer

Bruno Galvao

Rank: New Member

Posts: 12

Join Date: June 7, 2011

Recent Posts

I have LDAP Import checked but not the Import on Startup. I want the Microsoft Active Directory
users to login with their Active Directory account and have LDAP import their credentials into LifeRay.

I cannot login with an Active Directory user. However, when I create an account in LifeRay with the Active Directory user's email address it will authenticate with the Active Directory user's password.

Am I doing something wrong? What should I check?
Walter Christian Guardia Casas
RE: LDAP Import Enabled not working.
June 11, 2011 1:05 AM
Answer

Walter Christian Guardia Casas

Rank: Regular Member

Posts: 126

Join Date: May 5, 2010

Recent Posts

Hi,

If you want to import users from LDAP the user must have an email, a screenname and userId, these 3 parameters are neccessary to be import. If the user haven't email you could setup in the portal(-ext).properties these:

#
# Set this to false if you want to be able to create users without an email
# address. An email address will be automatically assigned to a user based
# on the property "users.email.address.auto.suffix".
#
users.email.address.required=false

#
# Set the suffix of the email address that will be automatically generated
# for a user that does not have an email address. This property is not used
# unless the property "users.email.address.required" is set to false. The
# autogenerated email address will be the user id plus the specified suffix.
#
users.email.address.auto.suffix=@no-emailaddress.com

I hope this can help you.

Regards,
Bruno Galvao
RE: LDAP Import Enabled not working.
June 14, 2011 8:22 AM
Answer

Bruno Galvao

Rank: New Member

Posts: 12

Join Date: June 7, 2011

Recent Posts

The users do have emails.

LifeRay CE is not importing the user accounts from AD at the time of login, authentication with AD works if we create the user manually and login using the AD credentials, also it appears that the import at start up will work if we set that option, but that is not something we want to do.

Any help would be appreciated. Thanks.
Scott Palmer
RE: LDAP Import Enabled not working.
June 14, 2011 10:24 PM
Answer

Scott Palmer

Rank: Junior Member

Posts: 36

Join Date: January 8, 2010

Recent Posts

Hi Walter,

I believe you also need to set this property:

##
## Request Header Authentication
##

#
# Set this to true to automatically import users from LDAP if they do not
# exist in the portal. The property "auto.login.hooks" must contain a
# referece to the class
# com.liferay.portal.security.auth.RequestHeaderAutoLogin to enable request
# header authentication.
#
request.header.auth.import.from.ldap=true

Regards,
Scott