Forums

Home » Liferay Portal » English » Liferay Legacy

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Tim Pletcher
CMS Community Disappears after 4.2 upgrade
December 19, 2006 8:51 AM
Answer

Tim Pletcher

Rank: Junior Member

Posts: 33

Join Date: September 8, 2006

Recent Posts

Has anyone had this issue:

We ran the upgrade scripts and looked at the wiki to make sure we executed properly, but now the CMS community is gone from the avaialble communities for the admin user...

By extension this also means no access to the structures and templates and the several hundred articles in our conent repository...

If anyone has come across this issue please let em mknow and also of course if there any fixes for this issue..

thanks,

tim
Mika Koivisto
RE: CMS Community Disappears after 4.2 upgrade
December 19, 2006 12:38 PM
Answer

Mika Koivisto

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1505

Join Date: August 7, 2006

Recent Posts

My CMS community didn't disappear but the content from CMS community did. As it turns out that content was moved to guest community. This has probably something to do with the new feature that each article, structure and template now belongs to some community and that community id part of their primary key.
Tim Pletcher
RE: CMS Community Disappears after 4.2 upgrade
December 19, 2006 4:44 PM
Answer

Tim Pletcher

Rank: Junior Member

Posts: 33

Join Date: September 8, 2006

Recent Posts

Well,

Whats odd is that I see some of the articles from the content repositroy, but the vast majority are missing....

also all of the structures and templates are gone too...these were obviously linked to the CMS community and users, but we know all of the users are still in the system, so this is odd....

I know there are a fair amount of issues with the upgrade process, and they are bein gworked through, but this is pretty major. I can't be the only one experienceing this...
David Truong
RE: CMS Community Disappears after 4.2 upgrade
December 19, 2006 6:37 PM
Answer

David Truong

LIFERAY STAFF

Rank: Expert

Posts: 312

Join Date: March 23, 2005

Recent Posts

Did you check your guest community yet?

Add a hidden page.
Add the journal portlet to that page
See if everything is there
Tim Pletcher
RE: CMS Community Disappears after 4.2 upgrade
December 20, 2006 4:03 AM
Answer

Tim Pletcher

Rank: Junior Member

Posts: 33

Join Date: September 8, 2006

Recent Posts

Hi David,

Ok, I see the content, which is great...

Next question is, where did all of the structures and templates go? I had significantly added to the ones that come with the base sample data...

Any guidance on recovering access to those....

Thanks,

Tim
David Truong
RE: CMS Community Disappears after 4.2 upgrade
December 20, 2006 12:16 PM
Answer

David Truong

LIFERAY STAFF

Rank: Expert

Posts: 312

Join Date: March 23, 2005

Recent Posts

they should also be in the guest community

try opening your article and clicking on the structure and template links on the bottom of the article and see where they take you