Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Dave Weitzel
Language deployment issues
July 8, 2011 8:25 AM
Answer

Dave Weitzel

Rank: Regular Member

Posts: 186

Join Date: November 18, 2009

Recent Posts

Can anyone explain how Liferay actually detects and implements the various Language_xx.properties files?
I have added Language_fi.properties to a hook that I have running.
I thought I could just add it to the webapps/hookname/WEB_INF/classes/content directory and restart the server but it isn't found
I then added it to the webapps/hookname/WEB-INF/src/content/ directory as well (I always thought these were superflous in a deployed hook anyway)

but it still isn't picked up

So how does the system manage these files? Is there a record made somewhere when you actually deploy the hook through a war?
If I recall correctly when using the IDE I always had to rebuild the hook and then do a fresh restart and deploy before I could test the new language properties files (and then it had to be Language_en.properties - my locale being en_US.)

I would love there be a way to make more dynamic language changes - especially during development but also like in this case when I want to add new language file to existing site with minimal disruption.

Anyone able to throw light on this or make suggestion as to how to make things easier?
Dave Weitzel
RE: Language deployment issues
July 8, 2011 12:46 PM
Answer

Dave Weitzel

Rank: Regular Member

Posts: 186

Join Date: November 18, 2009

Recent Posts

Silly me
I didn't add an additional

<language-properties>content/Language_fi.properties</language-properties>
to the hook xml file

Still would prefer to just have entry here to say there are Language property files not having to specify them all.
Orin Fink
RE: Language deployment issues
January 24, 2013 5:39 PM
Answer

Orin Fink

Rank: Junior Member

Posts: 42

Join Date: March 24, 2010

Recent Posts

Dave, thanks for sharing your story... lead me right to the answer i was looking for tonight.