Forums

Home » Liferay Portal » English » 2. Using Liferay » General

Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
lou cat
Liferay 6.0 LAR import error and other bugs...
June 28, 2012 1:56 AM
Answer

lou cat

Rank: Regular Member

Posts: 196

Join Date: January 26, 2012

Recent Posts

Hi all!

I really need to be able to export the pages of an organization in order to replicate them in other new organizations, but the LAR import/export is not working properly emoticon
I export correctly, I create a new organization but when I try to import that LAR for public or private pages, I got "You have entered invalid data, please try again" and "An unexpected error occurred while importing your file. ".

I also had problems with site templates:

http://www.liferay.com/community/forums/-/message_boards/message/12245067

so it's going to be very tricky and long for me to organize all the website and intranet for my company if I don't solve these problems emoticon

Could these be some bugs that I could fix with patches?
Honestly I haven't seen any "updates available" message since I installed LF6 various months ago, so I'm not sure on how these works but... do I have to install some patches and important updates for my version (6.0.6 CE)?
lou cat
RE: Liferay 6.0 LAR import error and other bugs...
June 28, 2012 2:22 AM
Answer

lou cat

Rank: Regular Member

Posts: 196

Join Date: January 26, 2012

Recent Posts

Just to confirm I have this problem on another installation too: it's in another server location but always with tomcat + liferay 6.0.6 CE.
Hitoshi Ozawa
RE: Liferay 6.0 LAR import error and other bugs...
June 28, 2012 3:22 AM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7990

Join Date: March 23, 2010

Recent Posts

have to install some patches and important updates for my version (6.0.6 CE)?


Sorry, Liferay.com does not provide patches and updates for the CE versions. You'll have to fix the problems yourself. emoticon
Sunil Rai
RE: Liferay 6.0 LAR import error and other bugs...
June 28, 2012 4:13 AM
Answer

Sunil Rai

Rank: Junior Member

Posts: 43

Join Date: January 31, 2012

Recent Posts

I am facing the similar issue on Liferay 6.0.6 CE. Anyone can suggest how to debug and proceed for this issue?
Milen Dyankov
RE: Liferay 6.0 LAR import error and other bugs...
June 28, 2012 4:23 AM
Answer

Milen Dyankov

Rank: Regular Member

Posts: 173

Join Date: September 23, 2009

Recent Posts

lou cat:
I create a new organization but when I try to import that LAR for public or private pages, I got "You have entered invalid data, please try again" and "An unexpected error occurred while importing your file. "


Is there some error message in the logs? If you can reproduce this locally then perhaps you can start Liferay in debug mode and trace down the method / data record causing the error.
Hitoshi Ozawa
RE: Liferay 6.0 LAR import error and other bugs...
June 28, 2012 4:33 AM
Answer

Hitoshi Ozawa

Rank: Liferay Legend

Posts: 7990

Join Date: March 23, 2010

Recent Posts

They're using 6.0.6 CE so it may be the following issue:
http://issues.liferay.com/browse/LPS-16425

Try to find where this got fixed and find a patch. emoticon

I've resorted to creating my own import/export routines because liferay's LAR seems to keep having problems. Better to get it fixed once properly then trying to get it fixed forever. :-)
lou cat
RE: Liferay 6.0 LAR import error and other bugs...
June 29, 2012 4:21 AM
Answer

lou cat

Rank: Regular Member

Posts: 196

Join Date: January 26, 2012

Recent Posts

Thank you for replying guys. even with sad news for us Community Edition users... emoticon

I got a pretty scary error log (you find it in the attachment if you are curious) and I don't know exactly where to start, but the first error is:

1[LayoutImporter:898] No theme loaders are deployed


and then I can see exceptions related to journal articles (as if it was trying to create in the db something that was suppose to be unique?), so I've tried to import the organization without "Data" in the portlets and it does work!

But of course I need data, and strangely I got the above error anyway in catalina.out!
Attachments: importLAR-error.txt (115.6k)
lou cat
RE: Liferay 6.0 LAR import error and other bugs...
June 29, 2012 4:51 AM
Answer

lou cat

Rank: Regular Member

Posts: 196

Join Date: January 26, 2012

Recent Posts

Ok now I'm honestly quite confused...

1) The first time I imported with the default settings checked and was not successful.

2) Then I've tried unchecking all the checkboxes under "portlets" (Setup, Archived Setups, User Preferences, Data) and it worked fine, but without data inside the portlets...

3) Eventually I've just unticked the "Data" checkbox and... everything seems fine! with data inside the portlets!

So... is it just me who didn't understand a thing of how this thing works??
What am I not importing when I deselect Portlets->Data ??
Ján Ondrušek
RE: Liferay 6.0 LAR import error and other bugs...
January 10, 2013 2:45 PM
Answer

Ján Ondrušek

Rank: New Member

Posts: 12

Join Date: April 26, 2009

Recent Posts

Actually it works well as you said. This will import everything but data (web conent, gallery, ...) Then, in second import, simply untick everything but the data. And it's all there!