Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Marcin Kierdelewicz
Liferay 6.0.1 and SpagoBI 2.5
May 12, 2010 2:11 PM
Answer

Marcin Kierdelewicz

Rank: New Member

Posts: 10

Join Date: July 18, 2008

Recent Posts

Hi,
I am trying to deploy SpagoBI.war using control panel and I get 2 errors:

1) During starting Tomcat I get error message:

20:56:29,203 INFO [PortletHotDeployListener:246] Registering portlets for SpagoBI
20:56:29,480 ERROR [HotDeployUtil:107] com.liferay.portal.kernel.deploy.hot.HotDeployException: Error registering portlets for SpagoBI
com.liferay.portal.kernel.deploy.hot.HotDeployException: Error registering portlets for SpagoBI
at com.liferay.portal.kernel.deploy.hot.BaseHotDeployListener.throwHotDeployException(BaseHotDeployListener.java:48)
at com.liferay.portal.deploy.hot.PortletHotDeployListener.invokeDeploy(PortletHotDeployListener.java:130)
at com.liferay.portal.kernel.deploy.hot.HotDeployUtil._doFireDeployEvent(HotDeployUtil.java:104)
at com.liferay.portal.kernel.deploy.hot.HotDeployUtil._flushPrematureEvents(HotDeployUtil.java:167)
at com.liferay.portal.kernel.deploy.hot.HotDeployUtil.flushPrematureEvents(HotDeployUtil.java:43)
at com.liferay.portal.servlet.MainServlet.initPlugins(MainServlet.java:966)
at com.liferay.portal.servlet.MainServlet.init(MainServlet.java:472)
at javax.servlet.GenericServlet.init(GenericServlet.java:212)
at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1173)
at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:993)
at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4187)
at org.apache.catalina.core.StandardContext.start(StandardContext.java:4496)
at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)
at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)
at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:546)
at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:637)
at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:563)
at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:498)
at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1277)
at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:321)
at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053)
at org.apache.catalina.core.StandardHost.start(StandardHost.java:785)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
at org.apache.catalina.core.StandardService.start(StandardService.java:519)
at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
at org.apache.catalina.startup.Catalina.start(Catalina.java:581)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:616)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)
Caused by: java.lang.ClassCastException: it.eng.spago.dispatching.httpchannel.AdapterPortlet cannot be cast to javax.portlet.Portlet
at com.liferay.portal.deploy.hot.PortletHotDeployListener.initPortlet(PortletHotDeployListener.java:484)
at com.liferay.portal.deploy.hot.PortletHotDeployListener.doInvokeDeploy(PortletHotDeployListener.java:269)
at com.liferay.portal.deploy.hot.PortletHotDeployListener.invokeDeploy(PortletHotDeployListener.java:127)
... 32 more

2) I get empty page with no plugins when I try to list them in control panel

21:11:35,140 ERROR [PortletContextFactory:77] Portlet DocumentsBrowser_WAR_SpagoBI has a null portlet bag
21:11:35,145 ERROR [IncludeTag:229] Current URL /group/control_panel/manage?p_p_auth=zkV4uiN0&p_p_id=136&p_p_lifecycle=0&p_p_state=maximized&p_p_mode=view&doAsGroupId=10147&refererPlid=10298 generates exception: java.lang.NullPointerException
21:11:35,149 ERROR [IncludeTag:157] java.lang.NullPointerException
at com.liferay.portlet.PortletContextFactory._create(PortletContextFactory.java:84)
at com.liferay.portlet.PortletContextFactory.create(PortletContextFactory.java:43)
at com.liferay.portlet.PortletConfigFactory._create(PortletConfigFactory.java:65)
at com.liferay.portlet.PortletConfigFactory.create(PortletConfigFactory.java:37)
at com.liferay.portal.util.PortalImpl.getPortletTitle(PortalImpl.java:2443)
at com.liferay.portal.util.PortalUtil.getPortletTitle(PortalUtil.java:729)
at com.liferay.portal.util.comparator.PortletTitleComparator.compare(PortletTitleComparator.java:54)
at com.liferay.portal.util.comparator.PortletTitleComparator.compare(PortletTitleComparator.java:1)
at java.util.Arrays.mergeSort(Arrays.java:1283)
at java.util.Arrays.mergeSort(Arrays.java:1294)
at java.util.Arrays.mergeSort(Arrays.java:1295)
at java.util.Arrays.mergeSort(Arrays.java:1294)
at java.util.Arrays.mergeSort(Arrays.java:1294)
at java.util.Arrays.sort(Arrays.java:1223)
at java.util.Collections.sort(Collections.java:176)
at com.liferay.portal.kernel.util.ListUtil.sort(ListUtil.java:165)
at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:377)
at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:313)


Any ideas where I could look for a solution?

Thanks in advance, Marcin
Juan Fernández
RE: Liferay 6.0.1 and SpagoBI 2.5
May 13, 2010 2:29 AM
Answer

Juan Fernández

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1227

Join Date: October 2, 2008

Recent Posts

Hi Marcin:
Did you solve this problem?
is SpagoBI.war a Liferay portlet?
Greetings
Marcin Kierdelewicz
RE: Liferay 6.0.1 and SpagoBI 2.5
May 13, 2010 2:41 AM
Answer

Marcin Kierdelewicz

Rank: New Member

Posts: 10

Join Date: July 18, 2008

Recent Posts

Hi Juan,
I didn't solve it yet.

SpagoBI (http://forge.ow2.org/project/showfiles.php?group_id=204) is not a standard Liferay portlet but has liferay portlet configuration in it.

Could you give me any suggestion where I could find a reason that causes those problems?

Thanks,
Marcin
Marcin Kierdelewicz
RE: Liferay 6.0.1 and SpagoBI 2.5
May 13, 2010 6:11 AM
Answer

Marcin Kierdelewicz

Rank: New Member

Posts: 10

Join Date: July 18, 2008

Recent Posts

I have solved that and it works fine now.
I was loading the same jar libraries twice.
Juan Fernández
RE: Liferay 6.0.1 and SpagoBI 2.5
May 13, 2010 8:01 AM
Answer

Juan Fernández

LIFERAY STAFF

Rank: Liferay Legend

Posts: 1227

Join Date: October 2, 2008

Recent Posts

Great!
Thanks for posting your error and its solution emoticon
By the way: can you tell us about your experience using SpagoBI? I mean: what are you using it for, why with Liferay, the integration process, etc? I think this is quite interesting for the community
Thanks a lot
Jean-Bob Billon
RE: Liferay 6.0.1 and SpagoBI 2.5
May 27, 2010 3:46 AM
Answer

Jean-Bob Billon

Rank: New Member

Posts: 1

Join Date: May 27, 2010

Recent Posts

Hi Marcin,

Could you try to explain the way you deployed SpagoBI 2.5 in Liferay 6.0.1?

I am new to the world of Liferay (and more globally with the portals/portlets) and I succeeded the operation with older versions (SpagoBI 2.3 in Liferay 5.2.3). But with these new ones I am lost emoticon

Thanks
Rasheed Abdur Muhammad
RE: Liferay 6.0.1 and SpagoBI 2.5
December 19, 2012 10:27 PM
Answer

Rasheed Abdur Muhammad

Rank: New Member

Posts: 3

Join Date: June 21, 2009

Recent Posts

Hi Marcin,

I'm facing issue with Liferay 6.1.1 with Spago 3.6.
Following is my post
https://www.spagoworld.org/jforum/posts/list/0/1942.page

Kindly help me out.