Combination View Flat View Tree View
Threads [ Previous | Next ]
toggle
Roman Hoyenko
Registering of deployed portlets/themes
May 2, 2011 3:53 PM
Answer

Roman Hoyenko

Rank: Liferay Master

Posts: 868

Join Date: October 8, 2007

Recent Posts

How are the portlets/themes that we deploy to portal regitered so Liferay knows about them?

It looks like when I try to deploy the theme it could be deployed, but it doesn't appear in the list of themes. The process in weblogic is 2-steps, first allow the Liferay autodeploy to do it's magic (unzip, add it's stuff, zip again), then use console to deploy the resulting file. The file shows as deployed in weblogic console, but I don't see it in the Look & Feel section. Hence the question.
Roman Hoyenko
RE: Registering of deployed portlets/themes
May 3, 2011 11:51 AM
Answer

Roman Hoyenko

Rank: Liferay Master

Posts: 868

Join Date: October 8, 2007

Recent Posts

Anyone has an idea how this works?
Joseph Wolfe
RE: Registering of deployed portlets/themes
December 15, 2011 6:52 AM
Answer

Joseph Wolfe

Rank: Regular Member

Posts: 103

Join Date: February 22, 2011

Recent Posts

Roman Hoyenko:
Anyone has an idea how this works?



was there ever an answer to this?

I am having an issue where manually deployed themes are deploying as portlets, however, using the console correctly deploys as themes. It seems the manual script deployed themes all have portlet.xml included in the WEB-INF, which is causing the issue.

Does anyone have any insight on this?

Much obliged!
Roman Hoyenko
RE: Registering of deployed portlets/themes
February 6, 2012 9:57 AM
Answer

Roman Hoyenko

Rank: Liferay Master

Posts: 868

Join Date: October 8, 2007

Recent Posts

I never got an answer on that. I just deployed the theme together with the portal, but would like to know how to do it properly, so I don't need to redeploy the portal every time I update the theme.