Foren

Home » Liferay Portal » English » 3. Development

Kombinierte Ansicht Flache Ansicht Baumansicht
Threads [ Zurück | Nächste ]
alen dumas
probleme with liferay 6.0.6
23. April 2012 18:13
Antwort

alen dumas

Rang: Junior Member

Nachrichten: 40

Eintrittsdatum: 12. März 2012

Neue Beiträge

hello,
I can deploy a web application in struts 2 in liferay 6.0.6 bundle with jboss

This web application contains code to generate a report with jasper report pdf
This procedure is done with success

but when I try to connect this web application with the EJB project (for further operation: eg list the user base through a given link in the JSP application that uses the DAO EJB project) and generate a. jar for EJB and. war for the web part and put in the deploy folder of liferay

I can find the application deployed but when I clicked on the link found in the jsp page: Liser users

this error is displayed at liferay (portlet is unavailable)

in eclipse when I try to point to the server jboss 5.1 of liferay 6.0.6 bundle with jboss in order to add the WEB and EJB project in this server this error is displayed:
The server does not support version 3.1 of the J2EE EJB Module specification



I try to switch to liferay 6.1 bundled with jboss the same web application can not be deployed (I mean the first example which generate a PDF report with struts without using a project EJemoticon
maybe I inspired in the structure of web project (which I have already done to make reporting with jasper report) the structure of a portlet made with liferay 6.0.6

and the probleme that jasper report is not supported by liferay 6.1


I need help


best ragards

alen
David H Nebinger
RE: probleme with liferay 6.0.6
23. April 2012 18:20
Antwort

David H Nebinger

Rang: Liferay Legend

Nachrichten: 6129

Eintrittsdatum: 1. September 2006

Neue Beiträge

Sorry, Alen, I just got done posting a reply to your french post (I'm glad google translate works, my french is so rusty I could grasp 50% of what you had written).

As I said, I think your issue is probably more having to do w/ getting everything working under jboss 7 (to get the EJB 3.1 support you need).

Jasper is supported in the 6.0 and 6.1 lines, so I don't think the problem is necessarily there.
alen dumas
RE: probleme with liferay 6.0.6
23. April 2012 19:25
Antwort

alen dumas

Rang: Junior Member

Nachrichten: 40

Eintrittsdatum: 12. März 2012

Neue Beiträge

thank you for your reply

I try to work with liferay 6.1 bundle withe jboss (jboss 7 that supports EJB 3.1)
but as I say I have an example of a web application with struts2 which also contains another file as liferay-portlet.xml and display.xml that helps for the deployment in liferay

but the problem that this example is running in liferay 6.0.6 and not running in liferay 6.1

Note that this example does not contain a part of EJB

is the structure of a portlet 6.0.6 is different from a portlet 6.1 ?

in my example I change the file liferay-display.xml
liferay liferay-by-display_6_0_0.dtd display_6_1.dtd

 1
 2<? xml version = "1.0"?>
 3<! DOCTYPE display PUBLIC "- / / Liferay / / DTD Display 6.1 / / EN" "http://www.liferay.com/dtd/liferay-display_6_1.dtd">
 4
 5<display>
 6<category name="category.sample">
 7<portlet id="Portlettest />
 8</ category>
 9</ display>
alen dumas
RE: probleme with liferay 6.0.6
23. April 2012 19:36
Antwort

alen dumas

Rang: Junior Member

Nachrichten: 40

Eintrittsdatum: 12. März 2012

Neue Beiträge

this error is displayed when I deploy web project in liferay 6.1 budle with jboss

 1        ... 11 more
 2
 301:30:13,258 INFO  [org.jboss.as.server.controller] (DeploymentScanner-threads -
 4 2) Deployment of "Portlettest.war" was rolled back with failure message {"Fail
 5ed services" => {"jboss.deployment.unit.\"Portlettest.war\".INSTALL" => "org.jb
 6oss.msc.service.StartException in service jboss.deployment.unit.\"Portlettest.w
 7ar\".INSTALL: Failed to process phase INSTALL of deployment \"Portlettest.war\"
 8"},"Services with missing/unavailable dependencies" => ["jboss.naming.context.ja
 9va.module.Portlettest.Portlettest.Validator missing [ jboss.naming.context.jav
10a.module.Portlettest.Portlettest ]","jboss.naming.context.java.module.Portlettest.Portlettest.ValidatorFactory missing [ jboss.naming.context.java.module.Portlettest.Portlettest ]"]}
1101:30:13,304 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-6) Sto
12pped deployment Portlettest.war in 48ms
1301:30:13,306 ERROR [org.jboss.as.deployment] (DeploymentScanner-threads - 1) {"C
14omposite operation failed and was rolled back. Steps that failed:" => {"Operatio
15n step-2" => {"Failed services" => {"jboss.deployment.unit.\"Portlettest.war\".
16INSTALL" => "org.jboss.msc.service.StartException in service jboss.deployment.un
17it.\"Portlettest.war\".INSTALL: Failed to process phase INSTALL of deployment \
18"Portlettest.war\""},"Services with missing/unavailable dependencies" => ["jbos
19s.naming.context.java.module.Portlettest.Portlettest.Validator missing [ jboss
20.naming.context.java.module.Portlettest.Portlettest ]","jboss.naming.context.j
21ava.module.Portlettest.Portlettest.ValidatorFactory missing [ jboss.naming.con
22text.java.module.Portlettest.Portlettest]"]}}}
Neil Griffin
RE: probleme with liferay 6.0.6
5. Mai 2012 14:36
Antwort

Neil Griffin

LIFERAY STAFF

Rang: Liferay Legend

Nachrichten: 1971

Eintrittsdatum: 26. Juli 2005

Neue Beiträge

I just saw the same "Validator missing" and "ValidatorFactory missing" errors in FACES-1208. Not sure if the problem you are experiencing is caused by the same thing as the Liferay Faces demo portlets, but the solution I found is posted there in the issue description.
Hitoshi Ozawa
RE: probleme with liferay 6.0.6
5. Mai 2012 14:44
Antwort

Hitoshi Ozawa

Rang: Liferay Legend

Nachrichten: 7990

Eintrittsdatum: 23. März 2010

Neue Beiträge

Neil, you've also commented that it can break http://issues.liferay.com/browse/FACES-183
Have you found any final solution to this?
Neil Griffin
RE: probleme with liferay 6.0.6
5. Mai 2012 14:53
Antwort

Neil Griffin

LIFERAY STAFF

Rang: Liferay Legend

Nachrichten: 1971

Eintrittsdatum: 26. Juli 2005

Neue Beiträge

I haven't finished my testing yet, but I *think* JBoss 7.0.x and 7.1.x no longer need the following markup in WEB-INF/web.xml:
1<listener>
2<listener-class>com.sun.faces.config.ConfigureListener</listener-class>
3</listener>

So you might want to try keeping the listener and see what happens.
djo vitch
RE: probleme with liferay 6.0.6
19. Mai 2013 07:07
Antwort

djo vitch

Rang: New Member

Nachrichten: 24

Eintrittsdatum: 4. April 2013

Neue Beiträge

Hi alen, could you please share an example of jasper report and struts2 app. thanks