Foren

Home » Liferay Portal » Español » 3. Desarrollo

Kombinierte Ansicht Flache Ansicht Baumansicht
Threads [ Zurück | Nächste ]
toggle
Tecnausa Tecnausa
problemas con mi primer Hook
9. Januar 2013 02:50
Antwort

Tecnausa Tecnausa

Rang: New Member

Nachrichten: 3

Eintrittsdatum: 3. Januar 2013

Neue Beiträge

Hola.
Estoy empezando a trastear con los Hooks y como es normal, a tener problemas.
e seguido la pequeña guia de este blog y lo que me pasa es que a la hora de compilar con el ant y me salta este error
1/root/Desktop/liferay-plugins-sdk-6.1.1/build-common-plugin.xml:449: /root/Desktop/bundles/tomcat-7.0.27/webapps/ROOT/WEB-INF/lib does not exist.

por supuesto la carpeta bundles no existe en el escritorio

otra cosa es que aún no entiendo el porque se recomienda usar hooks en vez de editar los archivos jsp "a pelo", (que es lo que estoy haciendo ahora mismo)

un saludo y gracias
Gustavo Fernández Gómez
RE: problemas con mi primer Hook
9. Januar 2013 07:26
Antwort

Gustavo Fernández Gómez

Rang: Regular Member

Nachrichten: 191

Eintrittsdatum: 26. Oktober 2007

Neue Beiträge

te recomendaría que leyeras
http://www.liferay.com/community/wiki/-/wiki/Main/Plugins+SDK
Tiene pinta de que tienes mal configurado el entorno del sdk y que los paths del fichero de configuración no está apuntando a donde debería... Hay un fichero de properties que tiene que tener un formato y un nombre concreto en el que se especifican esos paths. (esto desde el sdk directamente sin usar el IDE), si estás usando el IDE creo que lo que tendrás es que configurar los paths donde se encuentra el liferay para que no te de ese error.

Respecto a por que no modificar el core de un producto sino usar el modelo de desarrollo que proponga el propio producto, creo que no hay lugar a dudas de cual es la mejor manera de hacerlo, en este caso es un tema de mantenibilidad de los desarrollos.