Foren

Home » Liferay Social Office

Kombinierte Ansicht Flache Ansicht Baumansicht
Threads [ Zurück | Nächste ]
toggle
Peter Dimitri
Can't install SO anymore
6. März 2013 12:22
Antwort

Peter Dimitri

Rang: Junior Member

Nachrichten: 35

Eintrittsdatum: 9. Januar 2013

Neue Beiträge

From time to time I do a fresh Liferay and/or Social Office Installation for demonstration purposes in preparation for customer pre-sales pitches. Last time, three weeks ago everything worked like a charm. But now I'm unable to set up a brand new Liferay 6.1.1 CE2 Liferay Installation with Social Office. I tried it several times on different machines today. What I did today was:

- created a brand new DB schema in MySQL
- Installed a fresh Liferay 6.1.1 CE2 Tomcat Bundle
- created a portal-ext.properties file to use the new DB Schema
- deleted welcome-theme and resources-importer-web from Web-apps folder
- fired up Liferay and gone through the initial setup process
- went to control panel and downloaded social office
- installed social office
- saw several exceptions in tomcats log file

Results:

- no changes in the Liferay tool bar
- the SO theme is available, Login Page has been changed, but the "default social office site" site template is empty

Problems seem to have been started here in the logs:

119:21:23,954 ERROR [pool-2-thread-2][JDBCExceptionReporter:76] Incorrect string value: '\xE4\xB8\xBB\xE9\xA1\xB5...' for column 'name' at row 1
219:21:23,960 ERROR [pool-2-thread-2][InstanceUtil:78] com.liferay.portal.kernel.exception.SystemException: com.liferay.portal.kernel.dao.orm.ORMException: org.hibernate.exception.GenericJDBCException: Could not execute JDBC batch update
3com.liferay.portal.kernel.exception.SystemException: com.liferay.portal.kernel.dao.orm.ORMException: org.hibernate.exception.GenericJDBCException: Could not execute JDBC batch update
4    at com.liferay.portal.service.persistence.impl.BasePersistenceImpl.processException(BasePersistenceImpl.java:193)
5...
6...


I've attached the whole Tomcat log, from first startup until the end of my tests (only 60kemoticon
Anhänge: catalina.out (58,7k)
James Falkner
RE: Can't install SO anymore
6. März 2013 13:01
Antwort

James Falkner

LIFERAY STAFF

Rang: Liferay Legend

Nachrichten: 1218

Eintrittsdatum: 17. September 2010

Neue Beiträge

Michael Dolphin:
From time to time I do a fresh Liferay and/or Social Office Installation for demonstration purposes in preparation for customer pre-sales pitches. Last time, three weeks ago everything worked like a charm. But now I'm unable to set up a brand new Liferay 6.1.1 CE2 Liferay Installation with Social Office. I tried it several times on different machines today. What I did today was:

- created a brand new DB schema in MySQL
- Installed a fresh Liferay 6.1.1 CE2 Tomcat Bundle
- created a portal-ext.properties file to use the new DB Schema
- deleted welcome-theme and resources-importer-web from Web-apps folder
- fired up Liferay and gone through the initial setup process
- went to control panel and downloaded social office
- installed social office
- saw several exceptions in tomcats log file

Results:

- no changes in the Liferay tool bar
- the SO theme is available, Login Page has been changed, but the "default social office site" site template is empty

Problems seem to have been started here in the logs:

119:21:23,954 ERROR [pool-2-thread-2][JDBCExceptionReporter:76] Incorrect string value: '\xE4\xB8\xBB\xE9\xA1\xB5...' for column 'name' at row 1
219:21:23,960 ERROR [pool-2-thread-2][InstanceUtil:78] com.liferay.portal.kernel.exception.SystemException: com.liferay.portal.kernel.dao.orm.ORMException: org.hibernate.exception.GenericJDBCException: Could not execute JDBC batch update
3com.liferay.portal.kernel.exception.SystemException: com.liferay.portal.kernel.dao.orm.ORMException: org.hibernate.exception.GenericJDBCException: Could not execute JDBC batch update
4    at com.liferay.portal.service.persistence.impl.BasePersistenceImpl.processException(BasePersistenceImpl.java:193)
5...
6...


I've attached the whole Tomcat log, from first startup until the end of my tests (only 60kemoticon



Looks like you didn't set the encoding on your DB properly. How did you create the database in MySQL? I usually use

1
2create database foo default character set utf8;
Hitoshi Ozawa
RE: Can't install SO anymore
6. März 2013 13:19
Antwort

Hitoshi Ozawa

Rang: Liferay Legend

Nachrichten: 7990

Eintrittsdatum: 23. März 2010

Neue Beiträge

I usually just execute the following command without the "default" but it shouldn't make too much of a difference.
If you're using MySQL Admin tools, I think they didn't have an option to specify encoding. So, you'll have to execute the following command from the sql command line.

CREATE DATABASE lportal CHARACTER SET utf8;
Peter Dimitri
RE: Can't install SO anymore
7. März 2013 03:56
Antwort

Peter Dimitri

Rang: Junior Member

Nachrichten: 35

Eintrittsdatum: 9. Januar 2013

Neue Beiträge

Thanks, that was really part of the problem. Anyway: I'can't get SO installed properly. I've tried it several times for hours now, without any success.
Everytime I did a really fresh install with a new DB-Schema (UTF-8 of course), and a fresh extracted Liferay 6.1.1 CE2 Tomcat Bundle.

I've only run through the initial Install procedure, and as soon as my standard user "test@liferay.com" accesses the portal for the first time, I go to the control panel -> Marketplace->purchased, then I download an install SO.

Afterwards the SO Theme is available but not used by the default site, the SO Site Templates are selectable under CP->Site-Templates (Default Social Office Site, Social Office User Home, Social Office User Profile) but that's all. The Toolbar stays unchanged, the Users Profile Pages are still standard Liferay L&F, no Social Office Theme used by default, no changed Login Screen (meaning http://myserver/web/guest/so/login isn't available) etc.

There where no Exceptions in the Logs during Liferay Setup or while deploying the SO package. The Exceptions at the end of the attached log file started, while I created another "real" user, but I'm not sure if that's not only coincidence.

What am I missing? Can't rember that I ever had this kind of trouble when installing SO, and I really already did it often in the past.
Anhänge: catalina.out (58,1k)
Jamie L Sammons
RE: Can't install SO anymore
7. März 2013 06:31
Antwort

Jamie L Sammons

Rang: Junior Member

Nachrichten: 33

Eintrittsdatum: 18. November 2008

Neue Beiträge

Hi Michael,

Do you have your users added to the Social Office User Role? Even test@liferay.com does not get added to that Role be default when you deploy SO. Once added the Dashboard link should appear at the top.

As for the stack trace it almost looks like maybe you have Liferay Sync deployed somewhere trying to hit an old instance of Liferay? Not sure on that one but thought I would ask.

Thanks,
Jamie
Peter Dimitri
RE: Can't install SO anymore
7. März 2013 07:49
Antwort

Peter Dimitri

Rang: Junior Member

Nachrichten: 35

Eintrittsdatum: 9. Januar 2013

Neue Beiträge

Jamie You're brilliant!

Yes, I have several other Liferay Installations on my "Customer Demo" Machine, and one of them is especially for showing the document management capabilities of Liferay. So it has Liferay Sync installed (and all those document preview generating external services). I just installed that yesterday in the other Liferay instance, so I've never seen these Exceptions before. I thought Liferay Sync would be implemented using Hooks (which shouldn't affect any other Liferay Installation while the server isn't running), but obviusly I was wrong.

Back to SO: Here you are also right. In my former SO Installations I always already had some users, organisations, groups etc. configured when I installed SO. When I switched to one of those users after SO installation, the dashboard was shown immediatly. But not in a really "Clean" install without any users besided the "test" user. Just added another user to the Social Office User role - é voilá! Social Office is there.

Thanks a lot to all of you, who took the time to investigate my problem.

Kind Regards

Michael
stephan raju
RE: Can't install SO anymore
28. Mai 2013 21:52
Antwort

stephan raju

Rang: New Member

Nachrichten: 4

Eintrittsdatum: 28. Mai 2013

Neue Beiträge

Thanks for providing the command i think it would be help for me