Foren

Home » Liferay Portal » English » 3. Development

Kombinierte Ansicht Flache Ansicht Baumansicht
Threads [ Zurück | Nächste ]
toggle
Wolfgang Joppich
401 errors during WebDAV connections
22. März 2013 09:47
Antwort

Wolfgang Joppich

Rang: New Member

Nachrichten: 13

Eintrittsdatum: 13. Dezember 2011

Neue Beiträge

Hi,
unfortunately I experience a very strange behaviour of the Liferay WebDAV implementation. Normally I connect to Liferay via WebDAV and put files and file properties into the DMS of Liferay without any problem. But after some time I cannot connect to Liferay anymore, but get a 401 error back. If that occurs the only possible solution is to restart Liferay and to login the user with the login portlet. Then I can use the WebDAV interface again. What is going wrong here?
Thanks,
Wolfgang
Hitoshi Ozawa
RE: 401 errors during WebDAV connections
22. März 2013 18:48
Antwort

Hitoshi Ozawa

Rang: Liferay Legend

Nachrichten: 7952

Eintrittsdatum: 23. März 2010

Neue Beiträge

You'll have to tell us which version of Liferay you're using and webdav client.
Wolfgang Joppich
RE: 401 errors during WebDAV connections
23. März 2013 14:03
Antwort

Wolfgang Joppich

Rang: New Member

Nachrichten: 13

Eintrittsdatum: 13. Dezember 2011

Neue Beiträge

Yes sure. I am using Liferay 6.0.6 CE and Jackrabbit in the latest version. But I had the same problem with Sardine.
Hitoshi Ozawa
RE: 401 errors during WebDAV connections
23. März 2013 20:02
Antwort

Hitoshi Ozawa

Rang: Liferay Legend

Nachrichten: 7952

Eintrittsdatum: 23. März 2010

Neue Beiträge

And which web browser? If you're on earlier version of windows, I think there was a patch. Also, did you set the authentication? There's basic and digest and you'll need to set which one you're using.
Wolfgang Joppich
RE: 401 errors during WebDAV connections
24. März 2013 04:10
Antwort

Wolfgang Joppich

Rang: New Member

Nachrichten: 13

Eintrittsdatum: 13. Dezember 2011

Neue Beiträge

We are using IE and Firefox in different versions. But I guess that the browser is not the point, since I am having trouble with the WebDAV connection, not with the browser connection.
The authentication method I have to check on Monday. But I guess we are using the default value.
Hitoshi Ozawa
RE: 401 errors during WebDAV connections
24. März 2013 05:29
Antwort

Hitoshi Ozawa

Rang: Liferay Legend

Nachrichten: 7952

Eintrittsdatum: 23. März 2010

Neue Beiträge

Sorry, it wasn't the browser issue. It's an OS issue. Some MacOS people were having problem with WebDAV too. It went OK when they used a third party WebDAV client.
Wolfgang Joppich
RE: 401 errors during WebDAV connections
24. März 2013 06:46
Antwort

Wolfgang Joppich

Rang: New Member

Nachrichten: 13

Eintrittsdatum: 13. Dezember 2011

Neue Beiträge

We experience this behaviour on our Windows machines. But we are using third party WebDAV clients. We tried with Sardine and Jackrabbit. So I guess it is a problem with the Liferay implementation.
Juan Gonzalez
RE: 401 errors during WebDAV connections
24. März 2013 14:52
Antwort

Juan Gonzalez

LIFERAY STAFF

Rang: Liferay Legend

Nachrichten: 2176

Eintrittsdatum: 28. Oktober 2008

Neue Beiträge

Hi Wolfgang,

If using 6.1.1 GA2 guess you're hitting this issue:

http://issues.liferay.com/browse/LPS-30026

Try with lcepatcher's version and tell if it worked:

https://www.lcepatchers.org/downloads
Wolfgang Joppich
RE: 401 errors during WebDAV connections
25. März 2013 10:36
Antwort

Wolfgang Joppich

Rang: New Member

Nachrichten: 13

Eintrittsdatum: 13. Dezember 2011

Neue Beiträge

Hi,

thanks for the hints.
I am not sure what you mean with BasicAUTH. Well I am using these default values in the portal.properties:
passwords.digest.encoding=base64
basic.auth.password.required=true

I doubt that the issue LPS-30026 is related to my problem. In my case the 401 errors are very seldom. Definitely not in every second request. Actually I could not reproduce it today. But a team member and I had it a couple of times on different machines already. Still looking for a solution and a way to reproduce the error. A test will be running over night, so let' see if I can raise the error again.

Regards,
Wolfgang
Wolfgang Joppich
RE: 401 errors during WebDAV connections
26. März 2013 08:38
Antwort

Wolfgang Joppich

Rang: New Member

Nachrichten: 13

Eintrittsdatum: 13. Dezember 2011

Neue Beiträge

Okay, after some research I figured out the problem. I could only reproduce the problem if I was using the same user for the portal login and the WebDAV connection at the same time. And even then it did not occur very often. But this is actually not a problem for us. We just used the portal connection for testing purposes. We do not need the WebDAV user to log in to the web portal.

I lowered the debug level and found the following entry in my log file:
09:46:20,360 WARN [UserPersistenceImpl:2589] No User exists with the key {companyId=10301, emailAddress=app-user}
This is interesting actually. The method really tries to find the user with the email address, but uses the screen name. What is more we have configured Liferay to use the screen name for login. Maybe this is interesting for somebody. For me the problem is solved.

Thanks for the hints and regards,
Wolfgang