Foren

Home » Liferay Portal » English » 3. Development

Kombinierte Ansicht Flache Ansicht Baumansicht
Threads [ Zurück | Nächste ]
toggle
Ranen Das
AutoDeployException: ChartHandler-portlet.war does not support this version
1. Mai 2013 07:34
Antwort

Ranen Das

Rang: Regular Member

Nachrichten: 137

Eintrittsdatum: 6. April 2011

Neue Beiträge

Hello Guys,

I am facing a problem with LR EE, I have few portlet which I tested in LR CE, it works fine, I developed those portlets using Eclipse(Juno) and liferay-plugins-sdk-6.1.1 as plugin. Portlets works fine in CE.

But now I am trying to deploy in LR EE(I got license version of EE),now I need to use EE, but I am getting this error:-

AutoDeployException: -portlet.war does not support this version of Liferay

Why is LR EE behaving this way?And how can I get rid of this error?


Regards,
R
Ranen Das
RE: AutoDeployException: ChartHandler-portlet.war does not support this ver
1. Mai 2013 07:38
Antwort

Ranen Das

Rang: Regular Member

Nachrichten: 137

Eintrittsdatum: 6. April 2011

Neue Beiträge

My environments:-

liferay-portal-6.1.20-ee-ga2
tomcat-7.0.27

and developed the portlets in Eclipse
liferay-plugins-sdk-6.1.1 as plugin
Ranen Das
RE: AutoDeployException: ChartHandler-portlet.war does not support this ver
10. Mai 2013 06:54
Antwort

Ranen Das

Rang: Regular Member

Nachrichten: 137

Eintrittsdatum: 6. April 2011

Neue Beiträge

is portlet develop using liferay-plugins-sdk-6.1.1 as plugin NOT COMPATIBLE to deploy in LR EE, if yes, its not at all good as per as LR EE is concern
Anderson Mendes dos Santos
RE: AutoDeployException: ChartHandler-portlet.war does not support this ver
17. September 2014 09:14
Antwort

Anderson Mendes dos Santos

Rang: New Member

Nachrichten: 8

Eintrittsdatum: 21. August 2014

Neue Beiträge

I am with same problem, i using Liferay Developer Studio 6.2 with SDK 6.2 i need deploy the plugin liferay to version LF EE 6.1, what i do?
David H Nebinger
RE: AutoDeployException: ChartHandler-portlet.war does not support this ver
17. September 2014 12:04
Antwort

David H Nebinger

Rang: Liferay Legend

Nachrichten: 7075

Eintrittsdatum: 1. September 2006

Neue Beiträge

Download EE 6.1 and the 6.1 SDK. Copy your code to the 6.1 SDK that uses the 6.1 EE bundle (check your liferay-plugin-package.properties file in the copy to ensure it has the correct target version string). Build (and fix errors) then deploy your artifact.