« Zurück zu Liferay IDE

Liferay IDE Getting Started Tutorial

Alternative Languages: 日本語

Installation #

If you have not already installed Liferay IDE view Liferay IDE Installation Guide for a detailed walk-through of installation.

Requirements before getting started #

  • 1. Liferay Portal 6.0 (RC2 or greater) downloaded and installed (or download in the IDE itself)
  • 2. Liferay Plug-ins SDK 6.0 (RC2 or greater) downloaded and installed (or download in the IDE itself)
  • 3. Eclipse Helios/Galileo Java EE for developers package - see the Liferay IDE Installation Guide for more information.

Note: earlier versions of Liferay, e.g. 5.x, are not supported yet by the Liferay IDE

Liferay Plug-ins SDK Setup #

Before you can begin creating new Liferay plug-in projects, a Liferay Plug-ins SDK and Liferay Portal must be installed and configured in the IDE.

  • 1. Open Eclipse with Liferay IDE installed.
  • 2. Open Preference page for Liferay > Installed SDKs ( Go to Window > Preferences > Liferay > Installed SDKs )

  • 3. If you have not already downloaded the Liferay Plug-ins SDK for your portal version you can download it from the sourceforge.net Liferay downloads page. Liferay plugin sdk is located available in the "portal" folder. In the "portal" folder, select the Liferay version matching the Liferay version. Within this folder, look for liferay-plugins-sdk-x.x.x.zip (usually the last file).
  • 4. Add your SDK using the Add button which brings up the Add SDK Dialog:

  • 5. Browse to the location of your Plug-ins SDK installation.
  • 6. The default name is the name of the directory but you can change it if you wish.
  • 7. Select OK and you should see your SDK in the list of Installed SDKs.

Note: multiple SDKs can be added to the preferences but you will need to select at least one SDK to be the default which is represented by the SDK that has the checkbox selected.

Note: if you have version 6.0.4 of Liferay Portal and the Plugin SDK, you will need to change your build.properties file. The SDK plugin assumes you have installed the SDK at the same level (same directory) as the portal directory. In the line

  • app.server.dir=${project.dir}/../bundles/app_server_name of build.properties you have to change bundles with the name of the Liferay portal installation directory e.g. liferay-portal-6.0.4.

Otherwise, portlets created with the SDK plugin will not be deployed by Ant.

Liferay Portal Tomcat Runtime / Server Setup #

  • 1. In eclipse open the Runtime environments preference page (Go to Window > Preferences > Server > Runtime environments)

  • 2. Click Add to add a new Liferay runtime and find Liferay v6 Tomcat under the Liferay, Inc. category and click Next.

  • 3. If you have not already downloaded and installed a copy of the Liferay Portal Tomcat bundle then you can download the latest Liferay Portal Tomcat bundle by clicking the "Download and Install..." button within the wizard.

  • 4. If you used the download option you can skip this step, if not, click Browse and select the location of the liferay-portal-6.0.2 directory.

  • 5. Once you have selected the Liferay portal directory if it has a bundled JRE then that bundled JRE will be automatically selected as the JRE to use for launching the server. However, if there is no bundled JRE (Mac and Linux users) then you will need to select the JRE to use for launch.

  • 6. Click finish and you should see the Liferay portal runtime in the list of runtimes in the preference page.

  • 7. Click OK to save the runtime preferences.
  • 8. If you didn't choose to create a server you will need to create one from the servers view before you can test the server.

  • 9. Find the Liferay, Inc category and select the Liferay v6 Server and choose the Liferay v6 Runtime that you had previously created.

Setting the Console Encoding #

This step is not necessary for Liferay IDE 1.2 and greater, see http://issues.liferay.com/browse/IDE-287

This steps are not necessary if Liferay is installed on an OS whose encoding is latin1 or UTF-8 (most US and European OS). Otherwise, it is necessary to specify the console encoding to properly display console messages.

  • 1. Select "Run" - "Run Configuration..." from the Eclipse menu.
  • 2. Select "Liferay v6.0 Server" from the menu.
  • 3. Select the "Common" tab.
  • 4. In the encoding section, select "Other" and "UTF-8". Select "Apply" - "Close".

Testing the Liferay portal server #

  • 1. Go to the servers view and you should see the new server that was created. right click and choose "Start" or "Debug"

  • 2. You should see messages appear in the Console view and once it starts, the servers view will update to show that it is "Started" and then, right-click the server and select the (Liferay Portal > Open Portal Home) action.

Create new Liferay Plug-in Project #

  • 1. Now that a SDK and portal server have been configured you can create a new Liferay plug-in project. Go to File > New Project... > Liferay > Liferay Plug-in Project

  • 2. In the Liferay Plugin project wizard page, select the SDK and Liferay runtime and then select the plug-in type (portlet is default) and now you can create a new plug-in project, by clicking Finish.

  • 3. If it worked you should see a new plugin project in the package explorer, so you are ready to begin Plugin Development.

18 Anhänge
292618 Angesehen
Durchschnitt (15 Stimmen)
Die durchschnittliche Bewertung ist 4.666666666666667 von max. 5 Sternen.
Kommentare
Antworten im Thread Autor Datum
When I click "Finish" in step 6, nothing... Devanshu Chakraborty 22. Juni 2010 12:45
Why these two radio buttons for "Theme" and... Devanshu Chakraborty 23. Juni 2010 00:14
This problem got solved by the solution given... Devanshu Chakraborty 23. Juni 2010 02:33
Are you still unable to configure the runtime? Gregory Amerson 24. Juni 2010 05:57
Don't remove the bundled jre from liferay... MohdFaizul Sulaiman 25. August 2010 18:36
I deployed it as said above. What is the user... Devanshu Chakraborty 23. Juni 2010 01:16
If you are using 6.0 RC2 and if you haven't... Gregory Amerson 24. Juni 2010 05:59
Thanks for the replies gregory. I didn't remove... Devanshu Chakraborty 24. Juni 2010 09:20
I'm sure there is a way to do what you are... Gregory Amerson 26. Juni 2010 10:53
Hi, While creating new plugin project ... p chandru 23. Juni 2010 03:21
Themes and layout plugins are not yet supported... Gregory Amerson 24. Juni 2010 05:59
Hello Gregory, I'm using SDK 1.0.1. The... Maarten van Heiningen 2. August 2010 06:18
Hi Gregory, Didn't read your Wiki about the... Maarten van Heiningen 2. August 2010 12:33
You can test what is currently there right now... Gregory Amerson 3. August 2010 10:50
hi my friend i use... Alireza Bahrami 6. August 2010 10:18
Glassfish isn't yet supported for development. ... Gregory Amerson 19. August 2010 06:46
As you noticed in the 1.1 plan layout template... Gregory Amerson 3. August 2010 10:49
Hi, everything smooth until i hit the "Finish"... Alex Menz 30. Juni 2010 11:39
Any idea when the theme and layout functions... Michelle Winchell 30. Juni 2010 15:02
Layout template support is being worked on... Gregory Amerson 2. Juli 2010 07:33
I cannot create a new Liferay Plug-in Project:... Marco Dussin 6. Juli 2010 07:07
Hello Marco, can you go over to the IDE forums... Gregory Amerson 9. Juli 2010 05:37
Hi Colleagues, An XP user (me) reports about... Péter Füzi 7. Juli 2010 04:57
Hello Peter, I posted your question over on... Gregory Amerson 7. Juli 2010 07:51
We were installing the following these... Amy Mead 8. Juli 2010 07:19
Hello Amy, Thanks for letting me know that it... Gregory Amerson 9. Juli 2010 05:36
Consider it done! Actually, it is done;)! ... Amy Mead 10. Juli 2010 13:24
Actually, I just noted the following: "Note:... Amy Mead 10. Juli 2010 13:27
Hi Amy, Unfortunately there are no officially... Gregory Amerson 12. Juli 2010 06:43
Excellent ! ilke Muhtaroglu 9. Juli 2010 03:53
Perfect! Please keep these guides coming, they... Joel Protivnak 14. Juli 2010 08:01
This was very helpful. The only very small... Bruce Altner 16. Juli 2010 09:08
Glad you are up and running. The double-finish... Gregory Amerson 16. Juli 2010 09:29
I did all steps right, but when i try to... Marcelo Agostinho 23. Juli 2010 06:06
Could you create a new topic in the Liferay IDE... Gregory Amerson 23. Juli 2010 08:35
Great job Gregory !!! What is the... Corné Aussems 27. Juli 2010 10:42
Nice Tutorial,, I have followed the same and... Harish Kumar 31. Juli 2010 03:28
Themes will be enabled in the 1.1 release. Gregory Amerson 3. August 2010 10:48
It may have been mentioned elsewhere, but when... gavin rawson 15. September 2010 04:27
Thanks for the note Gavin. I've added it to... Gregory Amerson 15. September 2010 14:42
What if I run liferay on a separate tomcat... Jakub Liska 2. Oktober 2010 05:45
Hi Jakub, separate catalina_home/cataline_base... Gregory Amerson 6. Oktober 2010 03:18
I have Liferay 6.0.5 deployed on directory =... Apoena Oliveira Machado 3. November 2010 10:23
Liferay IDE doesn't support developing against... Gregory Amerson 8. Dezember 2010 11:33
Two problems possibly related to Liferay IDE: ... Jeff Zhuk 20. November 2010 16:04
help me .my portlets created with the SDK... anh phuoc 29. November 2010 08:23
1. Very good job. 2. Any points: (I use IDE... Behemoth . 16. Januar 2011 10:53
Could you try the latest Liferay IDE 1.2... Gregory Amerson 14. Februar 2011 09:34
I'm OK up until hitting "Finish" on the... Terry Healy 30. Januar 2011 11:19
Could you post your question over on the... Gregory Amerson 14. Februar 2011 09:35
HI Gregory, I imported my existing hook to ide... Smilelws2010 lwz 16. Februar 2011 07:12
Hi ! When I click "finish" at the end, I get an... Arthur Toenz 3. März 2011 00:43
Hi Arthur, can you post your problem and the... Gregory Amerson 3. März 2011 08:07
Can I use Liferay Developer Studio with Oracle... Advait Trivedi 14. März 2011 08:08
Hello Advait, Oracle Weblogic 10.3.4 is not... Gregory Amerson 21. März 2011 11:21
I followed all the instructions. In the... Taekyu Shin 24. Juni 2011 06:43
I am sorry that I forgot to mention something. ... Taekyu Shin 24. Juni 2011 06:52
I would like to write here that I have resolved... Taekyu Shin 24. Juni 2011 11:42
Hello, I have some issues attacing liferay... Jane Eyre 21. Juli 2011 07:44
Just terric!! Thanks for the treasure. Vijay Mudivedu 13. Oktober 2011 03:31
It saved my time Thanks for the effort, Great... Joseph John 2. November 2011 22:18
Its imposiible to unzip ... Ay Kay 22. November 2011 08:22
Andre, use a better dezip tool, like 7zip, to... Francois Delanoe 30. November 2011 05:25
Hello, I'm having trouble running the server. I... Xavi Carrillo 12. März 2012 11:36
Hello Xavi, can you post the contents of the... Gregory Amerson 4. Mai 2012 05:48
Everything went well upto the last step... Kamal Khattar 10. Mai 2012 00:43
Couldn't figure out what is the problem. But I... Kamal Khattar 10. Mai 2012 03:54
something is wrong with mine.. missing step #... Leslie Hanley 20. Februar 2013 01:45
"Location must be a valid Liferay Plugin SDK."... Luís Mascarenhas 27. Mai 2013 06:31
Hello Luis, Only version 6.0.2 and greater of... Gregory Amerson 27. Mai 2013 06:33
Thanks for the clarification Gregory. Luís Mascarenhas 27. Mai 2013 06:36
Thanks, it works great! Amine RYANE 18. November 2013 13:40
i am not able to process after step 3 Varun Kumar Thendoolkar 12. Mai 2014 04:43
Hello Varun, Can you download or unzip a new... Lu Li 14. Mai 2014 04:39
hi Li li, i have followed the steps but... Varun Kumar Thendoolkar 14. Mai 2014 21:20
Hi Varun, Thanks for the quick response , I... Lu Li 14. Mai 2014 22:48
Lu li, I have tried the same now but this time... Varun Kumar Thendoolkar 14. Mai 2014 23:03
Hi , varun It seems that your SDK is not a... Lu Li 14. Mai 2014 23:19
Lu li, i can see almost all folder but not... Varun Kumar Thendoolkar 15. Mai 2014 00:02

When I click "Finish" in step 6, nothing happens!!! Window remains as it is there.

Can you pls tell me why it's happening so ?
Gepostet am 22.06.10 12:45.
Why these two radio buttons for "Theme" and "Layout" are disabled? How can we make theme and layout plugins from eclipse?
Gepostet am 23.06.10 00:14 als Antwort auf Devanshu Chakraborty.
I deployed it as said above. What is the user id and password to log into the portal? the id "test@liferay.com" with password "test" gives error message: The email address you requested is not registered in our database.

v 5.2 didn't give this error ever. Can somebody tell me if i missed something or I need to do some explicit steps to populate some user table with user details. I need a super admin which has each and every right in the system to run over the application.
Gepostet am 23.06.10 01:16.
This problem got solved by the solution given in link http://www.liferay.com/community/forums/-/message_boards/message/5131178. Really a good discussion. Spring-aop.jar was missing and secondly I had to use Liferay Portal 6 RC2.
Gepostet am 23.06.10 02:33 als Antwort auf Devanshu Chakraborty.
Hi,
While creating new plugin project
1. Theme plugin
2. Layout plugin
both are disabled.
How to enable them?
How to create theme and layout using the Liferay IDE?
How to work with the existing theme ans layouts?
Gepostet am 23.06.10 03:21.
Are you still unable to configure the runtime?
Gepostet am 24.06.10 05:57 als Antwort auf Devanshu Chakraborty.
If you are using 6.0 RC2 and if you haven't uninstalled the 7cogs hook, then you will need to use bruno@7cogs.com/bruno, once you delete the 7cogs hook then all of the built-in data will be removed and you can then use the test@liferay.com/test account.
Gepostet am 24.06.10 05:59 als Antwort auf Devanshu Chakraborty.
Themes and layout plugins are not yet supported by the IDE. I'm working on Layout support right now and it should be available for version 1.1.
Gepostet am 24.06.10 05:59 als Antwort auf p chandru.
Thanks for the replies gregory. I didn't remove the 7cogs hook. But I found in some article in this site itself to use the "bruno" id and was able to log into it.

I'm really not much into velocity. Is it possible to use tiles and jsp to construct themes. Though I'm trying to develop themes by mapping and converting the corresponding ".vm" files into tiles.

If it is possible then can u please give me some hints and tips for that or refer me some help page to start with.

By d way ur suggestion on page "http://www.liferay.com/community/forums/-/message_boards/message/5129414" helped me to sort out my one setup problem.

Thanks.
Gepostet am 24.06.10 09:20 als Antwort auf Gregory Amerson.
I'm sure there is a way to do what you are attempting but I just don't know how exactly it would work. You can post over on the Liferay english development forums and likely will hear from someone who has tried your very scenario.
Gepostet am 26.06.10 10:53 als Antwort auf Devanshu Chakraborty.
Hi, everything smooth until i hit the "Finish" button. Then I get the error message "Failed while installing Liferay Portlet 6.0" - The "Details" only show a null pointer exception. Please help.
Gepostet am 30.06.10 11:39.
Any idea when the theme and layout functions will be available?
Gepostet am 30.06.10 15:02.
Layout template support is being worked on currently and will be available in version 1.1.
Gepostet am 02.07.10 07:33 als Antwort auf Michelle Winchell.
I cannot create a new Liferay Plug-in Project:
"Project name is invalid."

Where am i wrong?
Gepostet am 06.07.10 07:07.
Hello Marco, can you go over to the IDE forums and post your issue and we can try to help you out.

http://www.liferay.com/community/forums/-/message_boards/category/4627757
Gepostet am 09.07.10 05:37 als Antwort auf Marco Dussin.
Hi Colleagues,

An XP user (me) reports about his problem.
I'm stopped at Liferay Plug-ins SDK Setup / step 5. What particular IDE-SDK folder or file should be browsed in this field? I'm over the installation with success. Unfortunately I'm a newbie in Eclipse technology. Most likely it concludes me as I cannot give the correct place of the IDE SDK installed.

May I appreciate your guidance?
Thank you: Péter
Gepostet am 07.07.10 04:57.
Hello Peter,

I posted your question over on the Liferay forums so that I can add my answers there and you can ask followup questions if you need them.

http://www.liferay.com/community/forums/-/message_boards/message/5255785
Gepostet am 07.07.10 07:51 als Antwort auf Péter Füzi.
We were installing the following these directions and when we got to the "Step 5", we could not FINISH - as was stated by others. We also had the "Select Server Runtime" grayed out an we could not select it. After batting our heads against the wall, we decided to upgrade our Liferay installation on the MAC from 5.2.3 to 6.0. When we did this, we were able to proceed with the installation. I did not realize that having Liferay 6.x installed was a pre-requisite for the plugin to work. Is this really the case?

Also, we would like to develop on the MAC and deploy on an Ubuntu Liferay platform. Our Ubuntu Liferay deployment is on 5.2.3. Can we develop on the MAC with the Liferay 6.0 environment and deploy on Ubuntu Liferay 5.2.3?

Lastly is there some automated way to develop on the MAC using the runtime of the server?
Gepostet am 08.07.10 07:19.
Hello Amy,

Thanks for letting me know that it wasn't clear that only Liferay v6 is supported by the IDE. I'll update this document (and others) to try to make that more clear.

Regarding your other questions, could you ask those same questions in the Liferay IDE forums?

http://www.liferay.com/community/forums/-/message_boards/category/4627757

That way others can benefit when I post the reply. emoticon Thanks!
Gepostet am 09.07.10 05:36 als Antwort auf Amy Jean Mead.
Consider it done! Actually, it is done;)!

Greg, since we have Liferay 5.2.3 in production, can we use Liferay 6 IDE for development? If not, I guess I just need to adapt these instructions for the Liferay plugins for 5.2.3?
Gepostet am 10.07.10 13:24 als Antwort auf Gregory Amerson.
Actually, I just noted the following:

"Note: earlier versions of Liferay, e.g. 5.x, are not supported yet by the Liferay IDE"

If this is the case, what tools do you use to develop to a Liferay 5.2.3 system?
Gepostet am 10.07.10 13:27 als Antwort auf Amy Jean Mead.
Hi Amy,

Unfortunately there are no officially supported eclipse based tools for version 5.2.3. There has been some discussions internally about supporting them at least for launching the server, but nothing official yet.
Gepostet am 12.07.10 06:43 als Antwort auf Amy Jean Mead.
Perfect! Please keep these guides coming, they are so helpful. emoticon
Gepostet am 14.07.10 08:01.
This was very helpful. The only very small glitch I ran into was after creating the test-portlet project and clicking "Finish" the IDE reminded me that was not in the Liferay perspective and asked if I wanted to be. I said OK, but then had to click "Finish" again. I wish all my installation problems were that trivial.
Gepostet am 16.07.10 09:08.
Glad you are up and running. The double-finish thing sounds weird. Let me know if you see anything strange in your error log that could be a problem.
Gepostet am 16.07.10 09:29 als Antwort auf Bruce Altner.
I did all steps right, but when i try to initialize the server i got the following message:
"Could not Create the Java Virtual Machine"
"Error occurred during initialization of VM"
"Could not reserve enough space for object heap"
Gepostet am 23.07.10 06:06 als Antwort auf Gregory Amerson.
Could you create a new topic in the Liferay IDE forums and I can follow up there and try to help you get up and running.

http://www.liferay.com/community/forums/-/message_boards/category/4627757
Gepostet am 23.07.10 08:35 als Antwort auf Marcelo Agostinho.
Great job Gregory !!!

What is the best/preferred way to have a development portal-developer.properties configuration?
#1 keep it in the servers /ROOT/WEB-INF/classes
#2 keep it somewhere else on the -cp
#3 use a development hook?
Gepostet am 27.07.10 10:42.
Nice Tutorial,,

I have followed the same and get it up with Liferay 6.0.4
Layout plugin is also working fine but last option Themes is still disabled..
Gepostet am 31.07.10 03:28.
Hello Gregory,

I'm using SDK 1.0.1. The possibility to select Layouts is there but I'm getting a porlet setup instead and not the expected layout tpl files.

I'm working on the Liferay 6.0.4 with the latest available sdk on Eclipse Galileo.

Have you got any suggestions?
What would be the expected release date for Liferay SDK 1.1 with theme development?

Thanks,
Maarten
Gepostet am 02.08.10 06:18 als Antwort auf Gregory Amerson.
Hi Gregory,

Didn't read your Wiki about the Liferay IDE 1.1 plan
http://www.liferay.com/community/wiki/-/wiki/Main/Liferay+IDE+1.1+Plan

So I know I have to wait. If you need any testers please let me know.

Thank,
Maarten
Gepostet am 02.08.10 12:33 als Antwort auf Maarten van Heiningen.
Themes will be enabled in the 1.1 release.
Gepostet am 03.08.10 10:48 als Antwort auf Harish Kumar.
As you noticed in the 1.1 plan layout template and themes will be available officially there.
Gepostet am 03.08.10 10:49 als Antwort auf Maarten van Heiningen.
You can test what is currently there right now if you want to switch to the nightly URL:

http://releases.liferay.com/tools/ide/eclipse/helios/nightly/
Gepostet am 03.08.10 10:50 als Antwort auf Maarten van Heiningen.
hi my friend

i use liferay-portal-6.0.4(Glassfish 3.0) but with this way we just can develop liferay(tomcat 6)
i want use (liferay-portal glassfish server)

thanks
Gepostet am 06.08.10 10:18 als Antwort auf Gregory Amerson.
Glassfish isn't yet supported for development. Hopefully we will be able to add it in a future release.
Gepostet am 19.08.10 06:46 als Antwort auf Alireza Bahrami.
Don't remove the bundled jre from liferay tomcat bundle. If you remove it, the "Installed Jre.." will not enabled. An it won't works. I think this is a defect.
Gepostet am 25.08.10 18:36 als Antwort auf Devanshu Chakraborty.
It may have been mentioned elsewhere, but when I tried to create a portlet I got a null pointer exception and an incomplete portlet project. I eventually found this was due to me just having the java eclipse rather than the j2ee versio. After adding the j2ee stuff to eclipse at all seems fine. I guess the doc should mention j2ee in its requirements ??

apart from that, great guide !
Gepostet am 15.09.10 04:27.
Thanks for the note Gavin. I've added it to the requirements section that you need the full Java EE package from Eclipse.
Gepostet am 15.09.10 14:42 als Antwort auf gavin rawson.
What if I run liferay on a separate tomcat instance / catalina_base ? I then cannot add the tomcat instance to the liferay IDE because it's not the main instance (catalina_home) with all runtime libraries.
Gepostet am 02.10.10 05:45.
Hi Jakub, separate catalina_home/cataline_base setup is not yet supported in Liferay IDE.
Gepostet am 06.10.10 03:18 als Antwort auf Jakub Liska.
I have

Liferay 6.0.5 deployed on directory = /Tomcat6/webapps/lportal

But I can't create server runtime for use on IDE. Says that cannot needs liferay-portal-6.0.2 or bigger.

Why?
Gepostet am 03.11.10 10:23.
Two problems possibly related to Liferay IDE:

Both cases happen when debagging in Eclipse and IDE moves the war file from deploy/temp to the webapps directory.

1. Calls to web services / AXIS within Liferay/Tomcat cause ClassCastException:
http://www.liferay.com/community/forums/-/message_boards/mess­age/6453987

Jar dependences cause creating "tomcat/webapps/ROOT/WEB-INF/lib/util-java.jar" in the portlet/WEB-INF/lib with included "client-config.wsdd"

What should be changed to prevent inclusing of the client-config.wsdd?

2. Timezone
http://www.liferay.com/community/forums/-/message_boards/message/6354044­
Gepostet am 20.11.10 16:04.
help me .my portlets created with the SDK plugin not be deployed by Ant.
Gepostet am 29.11.10 08:23 als Antwort auf Jeff Zhuk.
Liferay IDE doesn't support developing against a tomcat where the deployment of Liferay has been changed from ROOT. Support for that will be added in the future.
Gepostet am 08.12.10 11:33 als Antwort auf Apoena Oliveira Machado.
1. Very good job.
2. Any points:
(I use IDE 1.1)
- Both are not correct:
* 3. If you have not already downloaded the Liferay Plug-ins SDK for your portal version you can download it from the sourceforge.net Liferay downloads page. Look for liferay-plugins-sdk-6.0.2.zip. - Can't find.

* 3a. An alternative to downloading yourself is using the "Download..." button on the Installed SDK page and it will automatically download and install the latest Liferay Plug-ins SDK for you. - creates location with name "...sdk-6.0.2". - But last version SDK - 6.0.5

- What todo if Runtime Environment must be in any steps? For example:
start mail-server, start db-server, start Tomcat. And back sequence for stop.
Gepostet am 16.01.11 10:53.
I'm OK up until hitting "Finish" on the hello-world portlet. It fails saying "Failed while installing Dynamic Web Module 2.5" due to a null pointer. Any suggestions what I did wring?

-thanks
Gepostet am 30.01.11 11:19.
Could you try the latest Liferay IDE 1.2 update? It should have those issues fixed.
Gepostet am 14.02.11 09:34 als Antwort auf Behemoth ..
Could you post your question over on the Liferay IDE forums along with the full error stack trace available from the Error log view? thanks. http://www.liferay.com/community/forums/-/message_boards/category/4627757
Gepostet am 14.02.11 09:35 als Antwort auf Terry Healy.
HI Gregory,

I imported my existing hook to ide and is running fine, but I have errors all over the jsp page. can you help me to get rid of that.
here is the forumn topic for the same
http://www.liferay.com/community/forums/-/message_boards/message/7560150?_19­_preview=false
Gepostet am 16.02.11 07:12 als Antwort auf Gregory Amerson.
Hi !
When I click "finish" at the end, I get an error :
"Failed while installing Dynamic Web Module 2.5

Reason:
Failed while installing Dynamic Web Module 2.5

>>Details:
java.lang.NullPointerException"

What can I do ?
Gepostet am 03.03.11 00:43.
Hi Arthur, can you post your problem and the full steps to replicate over in the Liferay IDE forums? Here is the url: http://www.liferay.com/community/forums/-/message_boards/category/4627757 Thanks!
Gepostet am 03.03.11 08:07 als Antwort auf Arthur Toenz.
Can I use Liferay Developer Studio with Oracle Weblogic 10.3.4 as my App Server ? If yes, can some one guide me with that? I am stuck at Configuring a Liferay Portal runtime. Even though I added Oracle Weblogic runtime. Basically, new Liferay Project command is not allowing me to create new portlet unless I select a runtime, and it doesnt show my Weblogic runtime as an option.
Gepostet am 14.03.11 08:08.
Hello Advait,

Oracle Weblogic 10.3.4 is not yet supported by Liferay Developer Studio. It is planned for a future version.
Gepostet am 21.03.11 11:21 als Antwort auf Advait Trivedi.
I followed all the instructions.
In the 'Testing the Liferay portal server' section, I just cannot pass #2.
select the (Liferay Portal > Open Portal Home) action. ==> The Liferay button does not show.
I did not set up ANT , however, I feel that this should not be the reason.

The major problem is that When I tried http:localhost:8080, it was unavailable. Could anybody give me some idea?
Gepostet am 24.06.11 06:43.
I am sorry that I forgot to mention something.

Of course, I started the server installed, then tried localhost:8080. The page did
not show, and the setting for the port number is right(8080).
Gepostet am 24.06.11 06:52 als Antwort auf Taekyu Shin.
I would like to write here that I have resolved the issue. For some reason, it collided with the liferay installed on my machine. I resolved it by getting the Eclipse IDE bundled already with Liferay from liferay website. I can finally get to the project for the company.
Gepostet am 24.06.11 11:42 als Antwort auf Taekyu Shin.
Hello,

I have some issues attacing liferay source to IDE. Can some one help me in doing this? I would like to debug the portlets using Liferay IDE.

Thanks in advance
Jane
Gepostet am 21.07.11 07:44 als Antwort auf Taekyu Shin.
Just terric!!

Thanks for the treasure.
Gepostet am 13.10.11 03:31.
It saved my time
Thanks for the effort, Great and simple
Gepostet am 02.11.11 22:18 als Antwort auf Vijay Mudivedu.
Its imposiible to unzip
"liferay-portal-jboss-6.1.0-ce-b4-20111110.zip"
on a windows PC. Period.
"Pathname exceeds 260 characters...."
Gepostet am 22.11.11 08:22 als Antwort auf Joseph John.
Andre,

use a better dezip tool, like 7zip, to avoid this trouble.
Gepostet am 30.11.11 05:25 als Antwort auf Andre Kuhn.
Hello,
I'm having trouble running the server.
I follow all the commands but when I try to run the server in the testing part nothing happends. The server remains [Stopped, Synchroniced].
I'm working with a Windows Vista.
I'll apreciate some help emoticon
Gepostet am 12.03.12 11:36 als Antwort auf Fanch D.
Hello Xavi,

can you post the contents of the eclipse error log <workspace>/.metadata/.log in a new forums post here?
http://www.liferay.com/community/forums/-/message_boards/category/4627757
Gepostet am 04.05.12 05:48 als Antwort auf Xavi Carrillo.
Everything went well upto the last step mentioned.
But then I am facing one problem.
When I add test-portlet project on the server , it deploys it(webapps\test-portlet is present) but doesn't make it available for use.

Following are the logs
INFO: Server startup in 117649 ms
May 10, 2012 7:21:10 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory C:\SoftwaresKK\liferay-portal-6.1.0-ce-ga1\tomcat-7.0.23\webapps\test-portlet
May­ 10, 2012 7:21:11 AM org.apache.catalina.startup.TaglibUriRule body
INFO: TLD skipped. URI: http://java.sun.com/portlet is already defined

When checked liferay - Add -> More -> Sample - this test portlet was not there.Please help.
I am using liferay-plugins-sdk-6.1.0-ce-ga1. Other details are in the logs.
Gepostet am 10.05.12 00:43 als Antwort auf Gregory Amerson.
Couldn't figure out what is the problem. But I deleted the existing installations for portal and plugins. Installed again. It worked.
Gepostet am 10.05.12 03:54 als Antwort auf Kamal Khattar.
something is wrong with mine.. missing step # 2. No liferay, Inc
Gepostet am 20.02.13 01:45.
"Location must be a valid Liferay Plugin SDK." when trying to install "liferay-plugins-sdk-5.2.1". Can give me some clue to solve this?
Gepostet am 27.05.13 06:31.
Hello Luis,

Only version 6.0.2 and greater of the plugins SDK is supported. Sorry about that.
Gepostet am 27.05.13 06:33 als Antwort auf Luís Mascarenhas.
Thanks for the clarification Gregory.
Gepostet am 27.05.13 06:36 als Antwort auf Gregory Amerson.
Gepostet am 18.11.13 13:40.
i am not able to process after step 3
Gepostet am 12.05.14 04:43.
Hello Varun,

Can you download or unzip a new SDK and try again ?
http://jaist.dl.sourceforge.net/project/lportal/Liferay%20Portal/6.2.1%20GA2/lif­eray-plugins-sdk-6.2-ce-ga2-20140319114139101.zip

you can try the steps:
1.unzip it .open IDE
2.setup SDK in IDE : Window > Preferences > Liferay > Installed SDKs .click "add" then in the popup dialog browse the location where you unzipped your SDK ,like mine is "D:\liferay-plugins-sdk-6.2-ce-ga2-20140319114139101\liferay-plugins-sdk-6.2"
3.then you can do the rest on the tutorial ,if you you still have any problem to process , please let us know and try to post more details

Thanks
Gepostet am 14.05.14 04:39 als Antwort auf Varun kumar.
hi Li li,

i have followed the steps but whenever i chose location of sdk like "D:\liferay-plugins-sdk-6.2-ce-ga2-20140319114139101\liferay-plugins-sdk-6.2" it tells that "name must have a value" what should i do? i am able to configure server but here i am stuck. because of this i am not able to develop liferay plugin portlet. i am new to liferay helpme out
Gepostet am 14.05.14 21:20 als Antwort auf Lu Li.
Hi Varun,

Thanks for the quick response , I get what you mean , you can just simply type a name in the 'Name' field.
If you clicked the 'Browse' button next to "Location" it should fill a name same as the SDK name in the "Name" field ,if no then you can manually add a name .
Please let us know if you have any problem to follow the tutorial .
Gepostet am 14.05.14 22:48 als Antwort auf Varun kumar.
Lu li,
I have tried the same now but this time "Location must be a valid Liferay Plugin SDK." it tells like this . emoticon i am confused
Gepostet am 14.05.14 23:03 als Antwort auf Lu Li.
Hi , varun

It seems that your SDK is not a complete sdk , check of the size of your SDK , its is like 3MB after you unzipped it . Could you take a look at the root dir if there is some folders like "themes" "portlets" "hooks" etc and some .xml files like "build-common-plugins.xml" "build-common-plugin.xml" "build-common.xml" etc
Besides , can you tell me what version of IDE are u using , click "Help" in the top column of eclipse then choose "About Eclipse" , in the popout dialog , there are alot icons , click the white cube icon then copy the version , like "Liferay IDE 2.1.0**********"

Thanks
Gepostet am 14.05.14 23:19 als Antwort auf Varun Kumar Thendoolkar.
Lu li,
i can see almost all folder but not "hooks", and
Eclipse Java EE IDE for Web Developers.
Version: Kepler Service Release 2
and configured liferay over here by installing new liferay software for eclipse here.
i can configure and run liferay server and meanwhile i am able to open liferay portal home. only sdk part is problem
Gepostet am 15.05.14 00:02 als Antwort auf Lu Li.