Foros

Inicio » Liferay IDE » English

Vista combinada Visión Plana Vista de árbol
Discusiones [ Anterior | Siguiente ]
toggle
Roger Thal
Error: Dynamic Web Module 3.0 requires Java 1.6 or newer
18 de febrero de 2012 18:53
Respuesta

Roger Thal

Ranking: New Member

Mensajes: 16

Fecha de incorporación: 21 de enero de 2012

Mensajes recientes

I installed Liferay IDE and successfully imported two "Liferay Projects from Plugins SDK".

When trying to import the 3rd projects from the Plugins SDK, all of the sudden there's a popup with this error message

One or more constraints have not been satisfied.
One or more constraints have not been satisfied.
One or more constraints have not been satisfied.
Dynamic Web Module 3.0 requires Java 1.6 or newer.

Nothing changed in my Eclipse JEE Indigo setup, nothing changed in my Java environment. What gives ?
Gregory Amerson
RE: Error: Dynamic Web Module 3.0 requires Java 1.6 or newer
19 de febrero de 2012 17:03
Respuesta

Gregory Amerson

LIFERAY STAFF

Ranking: Liferay Master

Mensajes: 895

Fecha de incorporación: 16 de febrero de 2010

Mensajes recientes

Check to see that your original project that you are trying to import doesn't have a .settings/org.eclipse.wst.common.project.facet.core.xml that specifies web 3.0 or java 1.6. Another thing to check would be if your project has web.xml version 3.0 specified.
Roger Thal
RE: Error: Dynamic Web Module 3.0 requires Java 1.6 or newer
20 de febrero de 2012 17:05
Respuesta

Roger Thal

Ranking: New Member

Mensajes: 16

Fecha de incorporación: 21 de enero de 2012

Mensajes recientes

The projects that I'm trying to import are of the simplest kind, i.e. generated by "create.bat" (I'm just trying to learn JSP).
Furthermore, I'm using Java 1.7 rje so it shouldn't even complain about needing 1.6 or higher. Just strange.
Gregory Amerson
RE: Error: Dynamic Web Module 3.0 requires Java 1.6 or newer
20 de febrero de 2012 17:15
Respuesta

Gregory Amerson

LIFERAY STAFF

Ranking: Liferay Master

Mensajes: 895

Fecha de incorporación: 16 de febrero de 2010

Mensajes recientes

Roger Thal:
The projects that I'm trying to import are of the simplest kind, i.e. generated by "create.bat" (I'm just trying to learn JSP).
Furthermore, I'm using Java 1.7 rje so it shouldn't even complain about needing 1.6 or higher. Just strange.



Check to see what your default JRE compiler level is for your workspace, make sure that it is not set to low.
Roger Thal
RE: Error: Dynamic Web Module 3.0 requires Java 1.6 or newer
23 de febrero de 2012 10:36
Respuesta

Roger Thal

Ranking: New Member

Mensajes: 16

Fecha de incorporación: 21 de enero de 2012

Mensajes recientes

The compiler compliance level is already set to 1.7.

But the problem seems to get resolved by doing the following (which does not make sense to me, but it seems to work!):

Preferences / Java / Compiler:
Make sure Compiler compliance level is 1.6 or higher (mine was already set to 1.7)
Uncheck "Use default compliance settings"
Leave all the choices that were greyed out now active as is, i.e. 1.7 in my case.
Roger Thal
RE: Error: Dynamic Web Module 3.0 requires Java 1.6 or newer
25 de febrero de 2012 6:54
Respuesta

Roger Thal

Ranking: New Member

Mensajes: 16

Fecha de incorporación: 21 de enero de 2012

Mensajes recientes

Delete the project in the IDE (make sure do not delete from disk!)
Import again.
No more error about Dynamic Web Module 3.0 requiring Java 1.6 or newer (when your RJE is already 1.7!)
Hitoshi Ozawa
RE: Error: Dynamic Web Module 3.0 requires Java 1.6 or newer
26 de febrero de 2012 5:06
Respuesta

Hitoshi Ozawa

Ranking: Liferay Legend

Mensajes: 7990

Fecha de incorporación: 23 de marzo de 2010

Mensajes recientes

From your description, it just seemed to have been a cache problem. There may have been an old version in the cache. I've encountered this problem several times myself too with eclipse. emoticon
mohammad azaruddin
RE: Error: Dynamic Web Module 3.0 requires Java 1.6 or newer
26 de diciembre de 2012 4:27
Respuesta

mohammad azaruddin

Ranking: Expert

Mensajes: 393

Fecha de incorporación: 17 de septiembre de 2012

Mensajes recientes

Hi
Hitoshi Ozawa

I tried above mentioned method.but it is not working.So Can u tel me how can we solve cache problem

Regards
azar
Bijan Vakili
RE: Error: Dynamic Web Module 3.0 requires Java 1.6 or newer
15 de noviembre de 2013 22:15
Respuesta

Bijan Vakili

Ranking: Regular Member

Mensajes: 133

Fecha de incorporación: 10 de marzo de 2009

Mensajes recientes

mohammad azaruddin:
Hi
Hitoshi Ozawa

I tried above mentioned method.but it is not working.So Can u tel me how can we solve cache problem

Regards
azar



Hi Azar,

I realize this response is past due.
I had the same issue as you today; but then, I discovered this solution:
Remove all JREs except v6.

Eclipse Standard/SDK
Version: Kepler Service Release 1
Build id: 20130919-0819

OS: Ubuntu 13.10

Default JRE was java-1.7.0-openjdk-amd64
java version "1.7.0_25"
OpenJDK Runtime Environment (IcedTea 2.3.12) (7u25-2.3.12-4ubuntu3)
OpenJDK 64-Bit Server VM (build 23.7-b01, mixed mode)


It's not great, but it works. Good luck my friend.
Adjunto

archivos adjuntos: eclipse_installed_jres_fix_error.png (101,5k)
mohammad azaruddin
RE: Error: Dynamic Web Module 3.0 requires Java 1.6 or newer
17 de noviembre de 2013 21:23
Respuesta

mohammad azaruddin

Ranking: Expert

Mensajes: 393

Fecha de incorporación: 17 de septiembre de 2012

Mensajes recientes

Hi thank you emoticon

Yeah...Greate job...May be helpful to someone else in future emoticonemoticonemoticon